Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Anthony @ LG Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6)


Reply
 
Thread Tools
Old 10-27-2009, 11:53 PM   #1
KBone
KBone
 
Drives: Jeep & 2010 2SS
Join Date: Jul 2009
Location: Langhorne, PA
Posts: 29
Burning smell (clutch?)

I have a 2SS M6 with 1500mi on it. I have been noticing a what smells like clutch when I back out of a parking spot. Yes I am letting the clutch slip just a bit. But at low rpm and just a very little bit. I have never smelled clutch in any of my other stick shifts and was wondering if anyone had any ideas? Break in issue? poor driver? goop on the clutch from the factory?
Thanx
KBone is offline   Reply With Quote
Old 10-28-2009, 09:24 AM   #2
CamaroSpike23
Truth Enforcer
 
CamaroSpike23's Avatar
 
Drives: anything I can get my hands on
Join Date: Sep 2006
Location: anywhere and everywhere
Posts: 22,824
Send a message via Yahoo to CamaroSpike23
even at low rpm, depending on how long you are taking to back out, you might get some burning from the clutch, but it shouldnt be a lot unless you are barely grabbing the clutch while backing
__________________
Never race anything you can't afford to light on fire and push off a cliff
A group as a whole tends to be smarter than the smartest person in that group until one jackass convinces everyone otherwise.
Quote:
Originally Posted by BowtieGuy View Post
Nobody makes CamaroSpike happy. You just disgust him a little less than other people.

Quote:
Originally Posted by WheelmanSS View Post
Post count is truly an accurate measure of how cool someone is on the Internet.
Quote:
Originally Posted by Greg Norris View Post
I piss excellence
and fart awesomeness
"You can think I'm wrong, but that's no reason to quit thinking.”
Quote:
Originally Posted by Overflow View Post
But not all people were born awesome like you, Spike.
CamaroSpike23 is offline   Reply With Quote
Old 10-28-2009, 09:53 AM   #3
srevoal
Like the Batmobile Honey
 
srevoal's Avatar
 
Drives: Black 2SS/RS M6
Join Date: Jun 2009
Location: Junction City, OR
Posts: 89
The clutch is delicate on the Camaro. It will burn on hill starts, and low speed clutch starts. Had the same problem. Less clutch = problem solved.
__________________
6/29/09 Preliminary Order - 1100
9/2/09 2000!
9/15/09 3000 10/05/2009
9/22/09 3300 10/05/2009
10/1/09 3400 10/5/2009
10/9/09 3800 2G1FT1EW1A9153975 ETA 10/23
10/24/09 IN MY GARAGE!!!
Big thanks to Viz for satisfying my obsession. It was more than worth the wait. Black on black 2SS/RS M6
srevoal is offline   Reply With Quote
Old 10-28-2009, 10:13 AM   #4
alex33x
 
Drives: 2013 Camaro ZL1
Join Date: Apr 2009
Location: El Paso, Tx
Posts: 688
Quote:
Originally Posted by srevoal View Post
The clutch is delicate on the Camaro. It will burn on hill starts, and low speed clutch starts. Had the same problem. Less clutch = problem solved.
Delicate? Don't the G8 guys wished they had our clutches cause we have the same clutch as the ZO6?
__________________
Devliered July 20, 2012
alex33x is offline   Reply With Quote
Old 10-28-2009, 08:45 PM   #5
JHart
I haz camaro again :)
 
JHart's Avatar
 
Drives: 2010 Chevrolet Camaro 1SS
Join Date: Mar 2009
Location: Union, South Carolina
Posts: 664
mine burns all the time, sometimes when i'm in line getting food in a drive thru, it stinks too good lord.
__________________
2010 Camaro 1SS(back in a camaro again, yessssss!)

2010 silverado z71 ccsb(sold, old dd)
2010 camaro1ss(sold, missed, will have another someday)
JHart is offline   Reply With Quote
Old 10-28-2009, 08:53 PM   #6
lawdogg149
 
lawdogg149's Avatar
 
Drives: Corvette ZO6 CSR edition #47
Join Date: Apr 2009
Location: Calhoun, GA
Posts: 740
Let me chime in. I have since replaced my clutch with a fidanza twin ceramic. I too was smelling clutch burning all the time. Even before I turbcharged it. Well after the turbo it lasted maybe two weeks and was cooked with one pass on the strip. When we removed there was alot of dust but the pads looked like they had gotten very hot. I even had a spot on the flywheel were the disk had stuck to it. I don't think the stock clutch would of made it a whole year even before the turbo. We will see soon enough. I did go to the dealership and complain in which got nowhere. Stock clutches suck. If and when it dyes be sure to get the fidanza quicker revs and alot more holding power.
lawdogg149 is offline   Reply With Quote
Old 12-01-2009, 12:14 PM   #7
VABrit
 
Drives: Black 2SS
Join Date: Mar 2009
Location: Blacksburg, VA
Posts: 14
I have noticed this increasingly as I approach 5,000 miles. I get the smell reversing, and with any moderate pull away. My concern is more that this smell (& dust) is getting inside the car. I never noticed anything like this on my GTO, even with the most aggressive high rpm clutch dumps. Anyone got any further ideas? Any dealers know of this issue and any good fixes (other than an aftermarket clutch)?
VABrit is offline   Reply With Quote
Old 12-01-2009, 10:33 PM   #8
Foster26
 
Drives: 2SS/RS IOM 6SP CGRS #9761
Join Date: Mar 2007
Location: Tuttle, OK
Posts: 294
I too am experiencing the same problem. Been driving a stick for several years with no problems so I'm not taking credit for the problem! I sure hope I don't have to replace this thing anytime soon.
Foster26 is offline   Reply With Quote
Old 12-02-2009, 09:17 PM   #9
MikeBing
 
MikeBing's Avatar
 
Drives: 2010 CGM/IO 2SS RS
Join Date: Apr 2009
Location: College Station, Texas
Posts: 112
same problems here. would an aftermarket clutch solve the problem? I don't want to do that though with the car under warranty and all. grand.
MikeBing is offline   Reply With Quote
Old 12-02-2009, 09:22 PM   #10
drtwo
 
drtwo's Avatar
 
Drives: 2SS RS Yellow, Raptor, Vrod
Join Date: Jul 2009
Location: South Dakota
Posts: 600
I have the same issue, it is aweful smelling. I used to think it was from being new, but still has it at 2500+ miles. I assume that it is normal and just wearing off the 'virgin' layer?!!
__________________
2SS RS Rally Yellow, LS3, M6, sunroof, extra on the fast!
drtwo is offline   Reply With Quote
Old 12-03-2009, 10:03 PM   #11
Indy2010
 
Indy2010's Avatar
 
Drives: 2010 IOM Camaro
Join Date: Nov 2009
Location: Hannibal, MO
Posts: 93
Same problem here. I have noticed that it happens in those situations where holding the clutch a little is needed (starting on a incline, reverse, pulling the car into a tight spot, etc...). It really surprised me because I have been much more careful with the Camaro than any other stick shift that I have ever driven.
Indy2010 is offline   Reply With Quote
Old 12-03-2009, 10:12 PM   #12
Alfieboy
Madman
 
Alfieboy's Avatar
 
Drives: White 2014 ZL1
Join Date: Jun 2009
Location: RICHMOND VA
Posts: 1,380
Same here noticed it.. it is nasty smelling
Alfieboy is offline   Reply With Quote
Old 12-04-2009, 03:10 PM   #13
Mhoward08
 
Mhoward08's Avatar
 
Drives: Black 2SS/RS Silver Hood/Hockey
Join Date: Nov 2009
Location: Huntsville Texas
Posts: 83
Through my first 200 miles i noticed it all the time. Now with only 500 miles on mine its not anywhere as bad.
Mhoward08 is offline   Reply With Quote
Old 12-04-2009, 03:19 PM   #14
rudack
Rudack
 
rudack's Avatar
 
Drives: ABM 2SS/RS
Join Date: May 2009
Location: Coconut Creek, FL
Posts: 742
Send a message via AIM to rudack Send a message via MSN to rudack
I get the same thing. Been driving stick for better part of 12 years.
__________________
ABM 2SS/RS #33390
rudack is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch fluid contamination problems on Vette fixed for Camaro??? LDGn63 V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) 11 05-28-2012 09:17 PM
Occasional burning smell manual tranny Arli 5th Gen Camaro SS LS LT General Discussions 31 08-31-2009 12:28 PM
Vengeance Racing Introduces RPS Organic Street Twin Clutch for 2010 Camaro!!! Ron@Vengeance V8 Bolt-Ons & Tunes 2 08-05-2009 01:03 PM
Just picked my L99 up last night... burning smell Verio Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 19 07-24-2009 11:41 PM
Burned my clutch a bit with Launch Control.... Caution you guys... Embalmer 5th Gen Camaro SS LS LT General Discussions 49 04-23-2009 08:49 PM


All times are GMT -5. The time now is 07:29 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.