Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vector Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 07-03-2014, 08:16 PM   #1
grimace70
 
grimace70's Avatar
 
Drives: 2010 Camaro 2SS inferno orange
Join Date: Dec 2012
Location: northern mn
Posts: 3
2010 center counsel gauges dead?

Today I was driving and I happened to look down at the gauges on my 10 2SS and the are stone dead? Checked every fuse twice in the door jam also under hood and in trunk. Nothing? Any help
grimace70 is offline   Reply With Quote
Old 07-04-2014, 07:19 AM   #2
TheHorse13

 
TheHorse13's Avatar
 
Drives: 2011 Black SS M6
Join Date: Oct 2010
Location: Harpers Ferry, WV
Posts: 881
Have you looked under the gauge cluster to see if the connector is unplugged or loose? It takes about 5 minutes to do.
TheHorse13 is offline   Reply With Quote
Old 07-04-2014, 05:29 PM   #3
grimace70
 
grimace70's Avatar
 
Drives: 2010 Camaro 2SS inferno orange
Join Date: Dec 2012
Location: northern mn
Posts: 3
That worked thanks!
grimace70 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.