Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Trunk Monkey Parts
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Regional Forums > USA - NY / NJ / PA


Reply
 
Thread Tools
Old 03-31-2010, 11:27 AM   #1
BrianGriffin78

 
BrianGriffin78's Avatar
 
Drives: 2009 GMC Yukon
Join Date: May 2009
Location: New York
Posts: 920
Calling all NY and NJ Camaro owners with Paint chip issues

Hey Everyone,

So took my Car out to a meet on Saturday and the car in front of me must of hit a filled pot hole, and gravel hit my car. I now have about 25 to 30 chips, but just had my car touched up with the other 6 or 7 from before. My body guy said this is not normal and there could be a problem with the primer.

I'm asking anyone out there with problems to possibly meet up with a GM rep so we could get our cars fixed on their expense. Obviously GM has a track history of poor paint, and this should not be let go.

Please let me know. Went to my dealer Paramus Chevorlet and he said well that is normal rock chipping. I said 30 chips is normal to you? With a car with only 6,000 miles on it?

There is no way to avoid it, but need to get my car repainted. Whether it comes out of my pocket or not is the major question at hand.

Thank You everyone!
__________________
BrianGriffin78 is offline   Reply With Quote
Old 03-31-2010, 12:09 PM   #2
"prima"Donna
HWAY STR
 
"prima"Donna's Avatar
 
Drives: 2010 RJT VIN#7085 & 2014 CRT C7
Join Date: May 2009
Location: New York
Posts: 13,081
So sorry for you...will you be able to have it re-painted ABM, since that color is no longer available???...love your ABM...that was my 2nd choice after the RJT.....
__________________
~ HWAY STR 2 ~
"prima"Donna is offline   Reply With Quote
Old 03-31-2010, 12:10 PM   #3
myold88


 
myold88's Avatar
 
Drives: SUMMIT WHITE 2SS/RS CAMARO
Join Date: Feb 2008
Location: Ct.
Posts: 6,696
I've said for months now on camaro5 that the Camaro has a chipping/paint problem. I have owned dozens of cars and have never seen a car that chips like this one. I think it must be in the primer/preperation process. I don't think complaining to GM will go to far. It will be a cold day in hell before they agree to refinish thousands of Camaros.
myold88 is offline   Reply With Quote
Old 03-31-2010, 12:35 PM   #4
"prima"Donna
HWAY STR
 
"prima"Donna's Avatar
 
Drives: 2010 RJT VIN#7085 & 2014 CRT C7
Join Date: May 2009
Location: New York
Posts: 13,081
Do any of you with the paint chips have splash guards??...just curious, since we've had the splash guards on our Camaro since 'Day1', and "knock on wood", "fingers crossed", don't have the paint chip issues as of today...I have owned my car since last May....
I would love to see a poll with people having paint chips with/without splash guards...
__________________
~ HWAY STR 2 ~
"prima"Donna is offline   Reply With Quote
Old 03-31-2010, 12:37 PM   #5
BrianGriffin78

 
BrianGriffin78's Avatar
 
Drives: 2009 GMC Yukon
Join Date: May 2009
Location: New York
Posts: 920
Quote:
Originally Posted by "prima"Donna View Post
So sorry for you...will you be able to have it re-painted ABM, since that color is no longer available???...love your ABM...that was my 2nd choice after the RJT.....
The color would still be ok, but it won't be stock paint........which is probably a better thing. My body guy is not regulated by the EPA so he can put more than 2 coats. We just need to see what is causing the problem first.

Quote:
Originally Posted by myold88 View Post
I've said for months now on camaro5 that the Camaro has a chipping/paint problem. I have owned dozens of cars and have never seen a car that chips like this one. I think it must be in the primer/preperation process. I don't think complaining to GM will go to far. It will be a cold day in hell before they agree to refinish thousands of Camaros.
I can give them hell. If they don't at least offer something to me, this will be my last GM product.........heard those GTR's are nice. Too bad I cannot afford one.
__________________
BrianGriffin78 is offline   Reply With Quote
Old 03-31-2010, 01:14 PM   #6
myss
 
myss's Avatar
 
Drives: 1ss/rs rally yellow blk strips 6spd
Join Date: Nov 2009
Location: staten island NY
Posts: 252
paint chips

Had an issue with the rear bumper meeting the quarters,looked like paint was peeling about 2 weeks into ownership.I brought it back to dealer and he sent me to his body guy and got it fixed.But ive had a few little touch ups ive fixed myself .Door jam ,and lower passenger door.i bought some touch up.but i have only 500 miles on car since sept.Hopefully it will be ok
myss is offline   Reply With Quote
Old 03-31-2010, 03:19 PM   #7
HaZe_X

 
HaZe_X's Avatar
 
Drives: Trailblazer SS & Camaro SS
Join Date: Nov 2009
Location: North Jersey
Posts: 758
thankgod my boy owns a body shop, he'll fixes all my paint problems.
HaZe_X is offline   Reply With Quote
Old 03-31-2010, 03:23 PM   #8
Kendell347
Doc
 
Kendell347's Avatar
 
Drives: BLACKOUT (2SS/RS)
Join Date: Jul 2009
Location: Long Island, NY
Posts: 1,496
This is why I am going to 3M Clear bra my front bumper. With a black car you see everything. What's your VIN #? Since you have 6k on the odometer, you're probably one of the earlier cars.
__________________
1100-7/20/2009 * 6000-2/4/10 Proud Owner of Autographed Litho # 128Mods: CAI CAI, Emblempros Dash Plaque, R/C Lic. Plate, Fbodfathers signature, AAC SMD SML, AAC P13 LED DRL, TF center console, Full dash ABL, Noweed Exhaust Diverters, Heritage Grille, Door Projectors, 20watt LED reverse lights with strobe features, S.S. black billet grille with air scoops, custom designed engine cover, custom designed "BLACKOUT" cross drilled / slotted rotors, Borla S-type exhaust, Elite Engineering oil catch can, Nitto Invo Tires WWW. NY5THGEN.COM
Kendell347 is offline   Reply With Quote
Old 03-31-2010, 03:54 PM   #9
BrianGriffin78

 
BrianGriffin78's Avatar
 
Drives: 2009 GMC Yukon
Join Date: May 2009
Location: New York
Posts: 920
Quote:
Originally Posted by Kendell347 View Post
This is why I am going to 3M Clear bra my front bumper. With a black car you see everything. What's your VIN #? Since you have 6k on the odometer, you're probably one of the earlier cars.
I was one of the first waves I believe. It is 8313 the last 4.
__________________
BrianGriffin78 is offline   Reply With Quote
Old 03-31-2010, 05:45 PM   #10
LT1Jeep
Ecstatic Camaro SS Owner
 
LT1Jeep's Avatar
 
Drives: Jeep(s) [1in pieces] and 2010 SS/RS
Join Date: Oct 2008
Location: Westchester NY
Posts: 319
i have two or three chips from stuff while on the highway. one pebble bounced off the front fender then hit the mirror and put little chips in both! and another small on one the front bumper from something else. its annoying that it can chip so easily.
__________________
LT1Jeep is offline   Reply With Quote
Old 03-31-2010, 05:54 PM   #11
camaro4mybday
"Camaro Joe"
 
camaro4mybday's Avatar
 
Drives: 2010 SILVER ICE 2LT/RS CAMARO
Join Date: Feb 2010
Location: long island ny
Posts: 2,352
Send a message via AIM to camaro4mybday
after hearing all of this im thinking of shooting a little extra clear on the car right out of the showroom good thing i own my own shop
camaro4mybday is offline   Reply With Quote
Old 03-31-2010, 06:11 PM   #12
BrianGriffin78

 
BrianGriffin78's Avatar
 
Drives: 2009 GMC Yukon
Join Date: May 2009
Location: New York
Posts: 920
Quote:
Originally Posted by camaro4mybday View Post
after hearing all of this im thinking of shooting a little extra clear on the car right out of the showroom good thing i own my own shop
Yeah, I am in the insurance business and we refer a lot of buisness to a body shop. He said the paint has to be too thin since they are EPA regulated. I am going to get the car repainted and then put a clear bra. It is sorta like hitting the reset button except everything inside will be the same.
__________________
BrianGriffin78 is offline   Reply With Quote
Old 03-31-2010, 06:23 PM   #13
Krozzbow
 
Krozzbow's Avatar
 
Drives: 2LT/BB 3.6 V6 6-M Jun'09 #A9100242
Join Date: Jul 2009
Location: New York
Posts: 543
I have been following this problem in other threads with paint chipping on front-ends, quarters and gills areas. Itís seems that newer camaros have the most problems with paint chips. I have an earlier model and havenít experience nothing yet. I do have quarter flares and had driven in dirt & broken asphalt debris roads, but no chips on front-end or anywhere else. Could the type of primer or coating changed after the first few batches of camaros released from the start of the production? Just curious.
__________________
Krozzbow is offline   Reply With Quote
Old 03-31-2010, 06:46 PM   #14
myold88


 
myold88's Avatar
 
Drives: SUMMIT WHITE 2SS/RS CAMARO
Join Date: Feb 2008
Location: Ct.
Posts: 6,696
My SS has a chip on the front edge of the hood. It only had 2200 easy miles when I first saw it. In my opinion it's in the initial paint prep process- IE metal prep, primer, sealer. You can add all the color and clear you want, but if the body is not prepped correctly the color will not adhere properly.
myold88 is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:19 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.