Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Hurst Shifters
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum

Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum All audio, video, bluetooth, nav, radar, and electronics discussions.

Reply
 
Thread Tools
Old 04-15-2010, 12:47 PM   #1
gazi8
 
Drives: Firebird
Join Date: Jun 2009
Location: Virginia
Posts: 12
Metra Kit Installs

Please post pictures of your Metra Kit install.
gazi8 is offline   Reply With Quote
Old 04-15-2010, 02:07 PM   #2
Mod007
 
Mod007's Avatar
 
Drives: Camaro SS/RS
Join Date: May 2009
Location: Austin TX,
Posts: 475
__________________
Camaro SS/RS Corsa Catback
Mod007 is offline   Reply With Quote
Old 04-15-2010, 02:16 PM   #3
MacTruck
 
MacTruck's Avatar
 
Drives: Camaro RS
Join Date: Oct 2009
Location: Colorado
Posts: 318
I had cartoys put mine in last week. They just got a few in from metra. They said that a firmware update is required to fix the chime problem and the cruise problem. They said I got the latest one. Just an FYI. Might all be BS but mine has no issues. The only problem I am having with my install is a messed up tint job and bluetooth issues with my alpine.
__________________
Soon - Camaro Black 1SS/RS Convertible
Piece of Crap Toyota Tundra 4x4 CREWMAX SR5 5.7L
Yeah, I'm 7yrs old
MacTruck is offline   Reply With Quote
Old 04-15-2010, 02:59 PM   #4
y2jdmbfan
 
Drives: 2013 IOM ZL1
Join Date: Feb 2009
Location: Lemont, IL
Posts: 105
What is the cruise problem?
y2jdmbfan is offline   Reply With Quote
Old 04-15-2010, 03:00 PM   #5
MacTruck
 
MacTruck's Avatar
 
Drives: Camaro RS
Join Date: Oct 2009
Location: Colorado
Posts: 318
Quote:
Originally Posted by y2jdmbfan View Post
What is the cruise problem?

It didn't work on the old firmware.
__________________
Soon - Camaro Black 1SS/RS Convertible
Piece of Crap Toyota Tundra 4x4 CREWMAX SR5 5.7L
Yeah, I'm 7yrs old
MacTruck is offline   Reply With Quote
Old 04-15-2010, 03:40 PM   #6
y2jdmbfan
 
Drives: 2013 IOM ZL1
Join Date: Feb 2009
Location: Lemont, IL
Posts: 105
I just wish that it didn't mute the audio on start-up...
y2jdmbfan is offline   Reply With Quote
Old 04-15-2010, 06:54 PM   #7
CamaroDreams07


 
CamaroDreams07's Avatar
 
Drives: Slow V6
Join Date: Jun 2009
Location: East Lansing, MI
Posts: 9,287
I'm sorry but those buttons under there just look so cheesy and cheap to me. If you are gonna go double din the ONLY way I've seen is the way Jesse from LTL does it. That looks professional and clean. Just my two cents though.
CamaroDreams07 is offline   Reply With Quote
Old 04-15-2010, 06:58 PM   #8
Indpowr
Account Suspended
 
Drives: Corvette C6
Join Date: May 2008
Location: Florida
Posts: 7,028
Quote:
Originally Posted by CamaroDreams07 View Post
I'm sorry but those buttons under there just look so cheesy and cheap to me. If you are gonna go double din the ONLY way I've seen is the way Jesse from LTL does it. That looks professional and clean. Just my two cents though.
You spend the 1800 and let me know how it is..
I am all about customizing rides..
Indpowr is offline   Reply With Quote
Old 04-15-2010, 09:00 PM   #9
CamaroDreams07


 
CamaroDreams07's Avatar
 
Drives: Slow V6
Join Date: Jun 2009
Location: East Lansing, MI
Posts: 9,287
Quote:
Originally Posted by Indpowr View Post
You spend the 1800 and let me know how it is..
I am all about customizing rides..
Oh I definitely agree with you it is a TON of money. But when you figure a Kenwood DNX9960 is like $1700 on Amazon plus the Metra is about $200 I think, that takes you over the $1800 anyway, unless I'm missing something here.

I don't know I just feel the other option is the way to go. If you're gonna do it, do it the best way available. That's my opinion anyway

Edit: I didn't realize that just the KIT was $1000 from LTL. Holy smokes, so it's $1000 for the kit and then the unit is separate. Last time I checked I thought it was $1800 including the headunit. Sorry, I haven't been keeping up on this.

Last edited by CamaroDreams07; 04-15-2010 at 09:05 PM. Reason: More research indicated I was wrong :)
CamaroDreams07 is offline   Reply With Quote
Old 04-15-2010, 09:58 PM   #10
600hp-lpe


 
600hp-lpe's Avatar
 
Drives: 2010 2SS RS RJT MN6
Join Date: Jul 2009
Location: NH
Posts: 4,698
Quote:
Originally Posted by CamaroDreams07 View Post
Oh I definitely agree with you it is a TON of money. But when you figure a Kenwood DNX9960 is like $1700 on Amazon plus the Metra is about $200 I think, that takes you over the $1800 anyway, unless I'm missing something here.

I don't know I just feel the other option is the way to go. If you're gonna do it, do it the best way available. That's my opinion anyway

Edit: I didn't realize that just the KIT was $1000 from LTL. Holy smokes, so it's $1000 for the kit and then the unit is separate. Last time I checked I thought it was $1800 including the headunit. Sorry, I haven't been keeping up on this.

LTaudio's kit is $1800.00 + the cost of the head unit = $3600.00+ misc.... It looks good, but to much $$$ for me. I bought the metra kit..
__________________
2010 2SS/RS RJT 6SP
600 HP Lingenfelter package 526 RWHP 491 RWTRQ
Pedders Justice package with Z-bar and supercar coilovers
LPE ZR-1 twin disc Clutch, LPE rear w/3.73 gears
NHRA cert. 8.50 CM 10 point roll cage, Cobra racing Seats
Gforce 5 PT. Harnesses, MOMO steering wheel and pedals
285/35/19 Bridgestone RE-11 Tires, CCW 19X10 SP16A Wheels
315/30/18 Front, 335/30/18 Rear Hoosier tires, CCW C2K Wheels
Racing Brake Rotors, stainless lines, MT800 Brake pads
HD Rear Axles, Toe Links, Trailing Arms, Lower Control Arms
Beware of the LPE Brotherhood
600hp-lpe is offline   Reply With Quote
Old 04-15-2010, 11:43 PM   #11
thespymaster


 
thespymaster's Avatar
 
Drives: C7 / ZL1 / SS / trucsk
Join Date: Nov 2009
Location: G4 CLASSIFIED
Posts: 4,643
Quote:
Originally Posted by gazi8 View Post
Please post pictures of your Metra Kit install.

thespymaster is offline   Reply With Quote
Old 04-15-2010, 11:55 PM   #12
The 2010 Sin
CorkTulsa.com
 
The 2010 Sin's Avatar
 
Drives: 2010 2SS BLK, 2013 2SS CRT
Join Date: Feb 2010
Location: Tulsa, Oklahoma
Posts: 2,847
looks filthy spy! :-) love the painted to match pieces. :-)
__________________
The 2010 Sin is offline   Reply With Quote
Old 04-15-2010, 11:59 PM   #13
Atti2de
Móderator
 
Atti2de's Avatar
 
Drives: 2SS/RS
Join Date: Oct 2009
Location: San Antonio
Posts: 1,659
Mmmm mud flap chick
__________________
I'm not the one with the Atti2de problem it's everyone else that has a problem with my Atti2de!
Atti2de is offline   Reply With Quote
Old 04-16-2010, 01:05 PM   #14
gazi8
 
Drives: Firebird
Join Date: Jun 2009
Location: Virginia
Posts: 12
Quote:
Originally Posted by thespymaster View Post
Very Nice.
gazi8 is offline   Reply With Quote
Old 04-16-2010, 02:07 PM   #15
guyjusthere
 
guyjusthere's Avatar
 
Drives: 2010 Camaro 1SS
Join Date: Mar 2010
Location: Miami, FL
Posts: 229
hey SPY,

Is it just me, or is there a 1cm space at the top of the kit?
guyjusthere is offline   Reply With Quote
Old 04-18-2010, 04:26 PM   #16
gazi8
 
Drives: Firebird
Join Date: Jun 2009
Location: Virginia
Posts: 12
Anyone else with a Metra Kit installed?
gazi8 is offline   Reply With Quote
Old 04-18-2010, 10:39 PM   #17
SamReidland
 
SamReidland's Avatar
 
Drives: 2SS CGM LS3
Join Date: Dec 2009
Location: Grapevine Texas
Posts: 107
Why is there a mud flap lady in the center of the display?
Attached Images
 
SamReidland is offline   Reply With Quote
Old 04-19-2010, 01:44 AM   #18
chicagojoe16
 
chicagojoe16's Avatar
 
Drives: 2010 Camaro
Join Date: Jul 2009
Location: Kalamazoo
Posts: 269
I can't believe you have lambo doors, honestly rolling my eyes. Isn't that weird with there being no top to the door beyond the glass? Anyway, the only way I would ever get lambo doors is if I installed a fog machine that went off every time I got out of the car.
__________________
Imperial Blue SS
chicagojoe16 is offline   Reply With Quote
Old 04-21-2010, 11:35 AM   #19
dr1ven
 
Drives: '10 CGM
Join Date: Sep 2009
Location: Raleigh, NC
Posts: 174
How do I update the firmware to resolve the Metra issue? Any other issues out there? Mine is just collect dust right now. Trying to hear if there are any major problems out there before ripping out my factory system.
__________________
2SS/RS CGM. Black Int. Black Stripes. Grnd Effects.

1100: 09/1/09
3800: 12/18/09
Picked Up at the Dealership: 1/4/10

dr1ven is offline   Reply With Quote
Old 08-09-2010, 04:20 AM   #20
Misha
 
Misha's Avatar
 
Drives: 2 LT RS Black
Join Date: Aug 2010
Location: East Turkistan (Uyghur)
Posts: 53
Send a message via MSN to Misha Send a message via Skype™ to Misha
hi. I got Camaro 2010. It has OEM Boston sound system. If I change it to any 2 din audio will it affect sound quality??? Need advice!!!
Misha is offline   Reply With Quote
Old 08-09-2010, 06:53 PM   #21
Topdown
The wait is over!
 
Topdown's Avatar
 
Drives: 2010 Camaro, IOM, L99, Auto
Join Date: Mar 2010
Location: Washington
Posts: 1,081
Quote:
Originally Posted by Misha View Post
hi. I got Camaro 2010. It has OEM Boston sound system. If I change it to any 2 din audio will it affect sound quality??? Need advice!!!
yes it will... any change to your system will either improve or degrade the sound.

without more information, its impossible to tell whether you will be doing better or worse, but a cheap/noisy 2-din head unit can definitely sound worse than an OEM head unit...

you might want to start a new thread on this though... there are lots of questions and lots of answers left to explore before you make a decision.
__________________
Ordered - 4/17/2010
Delivered - 5/29/2010

AlphaDamp CLD Mat - Get more Sound Deadening with less Sound Deadener
Topdown is offline   Reply With Quote
Old 08-12-2010, 02:27 AM   #22
Ivan @ Southwest Speed

 
Ivan @ Southwest Speed's Avatar
 
Drives: '10 2SS/RS, '96 Z28
Join Date: May 2009
Location: Rio Rancho, NM
Posts: 11,873
WTH are the pics and yes, what the heck is up with the Mud Flap Girl!???

So full of WIN!!!

Dig it,
Ivan
Ivan @ Southwest Speed is offline   Reply With Quote
Old 08-12-2010, 08:23 AM   #23
AhX
 
AhX's Avatar
 
Drives: 2010 2SS IOM\IOM
Join Date: Jul 2008
Location: NJ
Posts: 163
Quote:
Originally Posted by dr1ven View Post
How do I update the firmware to resolve the Metra issue? Any other issues out there? Mine is just collect dust right now. Trying to hear if there are any major problems out there before ripping out my factory system.
here
AhX is offline   Reply With Quote
Old 08-12-2010, 12:15 PM   #24
nwotank
 
Drives: 2010 Camaro SS Rally Yellow
Join Date: Aug 2009
Location: New Braunfels, Texas
Posts: 124
I've had mine installed for quite some time now without issues
nwotank is offline   Reply With Quote
Old 08-12-2010, 12:55 PM   #25
Topdown
The wait is over!
 
Topdown's Avatar
 
Drives: 2010 Camaro, IOM, L99, Auto
Join Date: Mar 2010
Location: Washington
Posts: 1,081
the mudflap girl is a "present" that metra built into the display. it originally comes with a stick-figure man... but if you hold the "snowflake" button for 7 - 10 seconds, it changes to the "mudflap girl"
__________________
Ordered - 4/17/2010
Delivered - 5/29/2010

AlphaDamp CLD Mat - Get more Sound Deadening with less Sound Deadener
Topdown is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
METRA DOUBLE DIN RADIO KIT FINALLY SHIPPING! thespymaster Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum 10 08-09-2010 04:06 AM
Metra Kit Bugs/Notes... y2jdmbfan Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum 3 04-14-2010 05:54 PM
ULTIMATE PERFORMANCE* TURBO Camaro SS -- 750hp Custom Single Turbo Kit (T04Z) Ultimate Performance Forced Induction - V8 496 10-11-2009 02:29 PM
5202 (H16 ; 9009) Slim HID Kits !!! 09-Up Camaro Fog Light HID kits !!! HID_Guy Exterior Parts & Accessories 19 09-08-2009 02:07 AM
2010 Camaro Fog/DRL Light 5202 HID kits .... HID_Guy Exterior Parts & Accessories 1 09-07-2009 01:19 PM


All times are GMT -5. The time now is 03:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.