Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
GM Carlisle
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons


Reply
 
Thread Tools
Old 05-04-2010, 03:00 PM   #1
zlwebb
 
zlwebb's Avatar
 
Drives: 2010 Camaro
Join Date: Mar 2010
Location: Indiana
Posts: 110
Exclamation NEED HELP! Installed custom CAI:warning lights

I just installed a new cai. It says service stabilitrack now and the engine light is on along with all the traction system lights. It also sounded a bit rough...will it just take time to adjust??


zlwebb is offline   Reply With Quote
Old 05-04-2010, 03:03 PM   #2
Gnarlygianni
 
Gnarlygianni's Avatar
 
Drives: Black Camaro 2SS
Join Date: Nov 2009
Location: Tucson, Az
Posts: 365
Gnarlygianni is offline   Reply With Quote
Old 05-04-2010, 03:05 PM   #3
wullger
Supercharged
 
wullger's Avatar
 
Drives: 2010 Camaro 2SS/RS
Join Date: Apr 2009
Location: Tyler, Texas
Posts: 1,576
Please tell me this is a photoshop prank.
__________________
2SS/RS IBM A6, White Rallies
Ordered: 4/30/09 Delivered: 8/18/09


Appearance Mods:
Heritage Grille, ZL1 Replica Wheels
Performance Mods:
Flowmaster ARH Cat-Back Exhaust, ADM CAI, ADM L99-LS3 Conversion, ADM LSA Supercharger Kit, Lingenfelter GT9 Cam, Stainless Power Headers, Detroit Speed Sway Bars, ZL1 Fuel Pump

581 rwhp/535 lb/ft tq
wullger is offline   Reply With Quote
Old 05-04-2010, 03:06 PM   #4
TripleB
SoCal Mayhem
 
TripleB's Avatar
 
Drives: 2010 2SS/RS ABM Camaro A6
Join Date: May 2009
Location: Lakewood, California
Posts: 5,794
where is the MAF plugged in? i don't really see it from that picture. if you don't have that, you'll get those errors and the car might even stall because it thinks it's not getting any air flow.
__________________
TripleB is offline   Reply With Quote
Old 05-04-2010, 03:07 PM   #5
Tessa
Mischief Managed
 
Tessa's Avatar
 
Drives: 2SS/RS RJT with silver rallys
Join Date: Aug 2009
Location: Southbound
Posts: 8,176
I threw out my stabilitrack system this winter and as I took her out to get it serviced it re-set itself. Literally down the driveway and like 4 feet into the road....

Might want to call Onstar first just to make sure too....my engine light was not on - just all my stabilitrack lights and my ABS light....
Tessa is offline   Reply With Quote
Old 05-04-2010, 03:07 PM   #6
zlwebb
 
zlwebb's Avatar
 
Drives: 2010 Camaro
Join Date: Mar 2010
Location: Indiana
Posts: 110
The MAF is installed. so is the vacuum tube. I just tried starting it. It does want to stall now at idle unless I give it gas
zlwebb is offline   Reply With Quote
Old 05-04-2010, 03:08 PM   #7
zlwebb
 
zlwebb's Avatar
 
Drives: 2010 Camaro
Join Date: Mar 2010
Location: Indiana
Posts: 110
Should I take off one of the filters??
zlwebb is offline   Reply With Quote
Old 05-04-2010, 03:10 PM   #8
Blade


 
Blade's Avatar
 
Drives: 2012 Camaro 2SS SIM RS
Join Date: Dec 2009
Location: Charlotte
Posts: 4,623
Send a message via AIM to Blade
That is a wicked system.

Sounds like you need a tune. When you add a mod to these v6 engines, you will usually get a check engine light. To get rid of the CEL you will need a tune. Now you can keep driving with the CEL, but if something really goes wrong, your screwed.

You can drive around more, usually it irons out after a 100 miles or so. There are variances on each car.
__________________
Blade is offline   Reply With Quote
Old 05-04-2010, 03:15 PM   #9
zlwebb
 
zlwebb's Avatar
 
Drives: 2010 Camaro
Join Date: Mar 2010
Location: Indiana
Posts: 110
I just took one filter off. Still really rough...do I need to take it on the street to allow it to adjust first? Because now its just a standard cai and should be fine.
zlwebb is offline   Reply With Quote
Old 05-04-2010, 03:15 PM   #10
ddunerider
So-Cal Race team!!
 
ddunerider's Avatar
 
Drives: Tahoe LTZ,2010 2SS/M6 Camaro
Join Date: Apr 2009
Location: Phillips Ranch ca. So-Cal
Posts: 5,931
Send a message via AIM to ddunerider
Really......
__________________
WE RACE DEEP!!
BBK Intake, Flowmaster AT cat back Barton shifter,Painted stripes,,Heritage grill,LED DRLs, Smokin Tires!!
ddunerider is offline   Reply With Quote
Old 05-04-2010, 03:19 PM   #11
The Reaper
Founding Member of CTCC
 
The Reaper's Avatar
 
Drives: 2010 2SS RS RJT w/Silver Stripes
Join Date: Apr 2010
Location: Texas
Posts: 709
Just a wild shot here...I understand that the MAF is directional. Could it be backwards?
__________________

It's not how big your motor is, it's how well you shift it !!
The Reaper is offline   Reply With Quote
Old 05-04-2010, 03:22 PM   #12
zlwebb
 
zlwebb's Avatar
 
Drives: 2010 Camaro
Join Date: Mar 2010
Location: Indiana
Posts: 110
It is directional? I did turn it
zlwebb is offline   Reply With Quote
Old 05-04-2010, 04:12 PM   #13
The Reaper
Founding Member of CTCC
 
The Reaper's Avatar
 
Drives: 2010 2SS RS RJT w/Silver Stripes
Join Date: Apr 2010
Location: Texas
Posts: 709
So I understand, there is an arrow I believe that should point towards the throttle body. Any experts chime in here as I am going on what I have heard.
__________________

It's not how big your motor is, it's how well you shift it !!
The Reaper is offline   Reply With Quote
Old 05-04-2010, 04:56 PM   #14
zlwebb
 
zlwebb's Avatar
 
Drives: 2010 Camaro
Join Date: Mar 2010
Location: Indiana
Posts: 110
I redisigned it for just one filter. I turned the mass airflow sensor around. The traction lights are off and everything is running smooth now. The check engine light is still on though. Will pulling the battrry clear it?
zlwebb is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Please help!!! All lights on gauges coming on!! SS Mike Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 44 11-05-2014 09:02 AM
Angel Eye Mod (93-97 Camaros) CamaroSpike23 4th Generation Camaros 105 05-12-2014 03:17 PM
Knight Rider KITT LIGHTS INSTALLED thespymaster Camaro Photos | Spyshots | Video | Media Gallery 116 03-23-2011 06:12 PM
Cup holder lights installed bmwdon 5th Gen Camaro SS LS LT General Discussions 10 02-16-2010 12:23 PM
lights wont go off Parrish 4th Generation Camaros 3 09-09-2009 09:11 AM


All times are GMT -5. The time now is 08:40 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.