Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Cold Air Inductions
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V8

Forced Induction - V8 V8 Supercharger, turbo, nitrous discussions

Reply
 
Thread Tools
Old 05-05-2010, 04:31 PM   #1
PJ droopy pants
 
PJ droopy pants's Avatar
 
Drives: 2010 Camaro SS
Join Date: Dec 2009
Location: Tennessee
Posts: 36
Edelbrock E Force Supercharger Issue

Got a Edelbrock S/C installed monday and overall I am very satisfied, had it installed at my dealership and besides a leaky heater core hose the install went great. After test driving it after the install and opening up the throttle the check engine light came on and threw a code
P0121 Throttle Posistion [TP] Sensor 1 Performance.
Other than the ceck engine light there were no other noticable complications or loss of power. We checked the wires and made sure everything was tight and grounded and reset the code and it didn't come back untill today (Wednesday), again WOT and check engine light came on, same code. Called Edlebrock and they told me they havn't had an other issues and to just check the wires. Anyone have any ideas?

Super charger was installed on a totaly stock LS3 and used the edelbrock tune that came with, engine has 2,700 miles and no other issues other than the code.
PJ droopy pants is offline   Reply With Quote
Old 05-05-2010, 05:10 PM   #2
SonnyakaPig

 
Drives: C63 P31
Join Date: Feb 2010
Location: West Coast
Posts: 767
I feel for you, buddy. I hope you get the code situation worked out soon so that you can enjoy your new awesome supercharger.
SonnyakaPig is offline   Reply With Quote
Old 05-05-2010, 06:24 PM   #3
jsharp
NOW CAMMED & SUPERCHARGED
 
jsharp's Avatar
 
Drives: 2010 Camaro 2SS/RS Black w/ IOM
Join Date: Oct 2008
Location: Ar
Posts: 2,335
I know that they may not be claiming issues but about 85% of what I have read on here about people receiving the kit were not completly satisfied.
__________________
Livernois Motorsports: Maggie 2300 7psi, Livernois 2C cam/L99 to LS3 Conversion, Ported TB, Rotofab w/adm race scoop, adm trans cooler,Kooks headers no cats, Kooks 3" exhaust. METCO breather. Precision 2400 Vigilante TC. Eibach Lowering Springs & Swaybars. BMR Trailing arms, BMR Rear Cradle Bushings, BMR Toe Rods, BMR Differential bushings. Vossen CV3 20's w/ 305 Nitto 555R@25psi. Zl1 front bumper. OE Zl1 Hood and matte black insert. 556RWHP/500RWTQ L99
jsharp is offline   Reply With Quote
Old 05-05-2010, 07:52 PM   #4
Busy_Boi
SoCal C5 Family Member
 
Busy_Boi's Avatar
 
Drives: RJT 2010 camaro 2SS
Join Date: Aug 2009
Location: Los Angeles, CA
Posts: 1,018
Send a message via Yahoo to Busy_Boi
It may need to be dyno tune I have order this supercharger. But I have not gotten it yet. I am not going to use the edelbrock tune.
__________________
Busy_Boi is offline   Reply With Quote
Old 05-05-2010, 08:13 PM   #5
flyby

 
Drives: 2010 Silver SS
Join Date: Sep 2009
Location: Glen Gardner, NJ
Posts: 1,325
Take it to a tune shop and have it tuned properly, should end all problems.
flyby is offline   Reply With Quote
Old 05-05-2010, 09:13 PM   #6
HaveBlue
 
HaveBlue's Avatar
 
Drives: CTS/CAMARO
Join Date: Jun 2009
Location: SEMA/PERF INDUSTRY GUY
Posts: 484
He didn't speak to anyone in the supercharger department. Just a general tech. I've sent him a contact and phone number that will get him to the right person.
__________________
"everyone wants to go to heaven. but nobody wants to die" "you gotta pay to play"

SEMA PICTURES-PARTS & CARS
http://www.pbase.com/haveblue/sema_2009
HaveBlue is offline   Reply With Quote
Old 05-06-2010, 02:55 PM   #7
Mister HP
 
Mister HP's Avatar
 
Drives: Speed Shop owner
Join Date: Aug 2009
Location: Decatur, IN
Posts: 199
that code is def related to the tune. A good dyno tune will clear it all up. Let me know if you need help finding someone in your area,

Ed
Mister HP is offline   Reply With Quote
Old 05-06-2010, 03:00 PM   #8
Mike Norris
 

Join Date: Jul 2009
Location: Indianapolis, IN
Posts: 591
I agree that most likely a proper tune will take care of it, but it should not be needed seeing it is a simple bolt on and go with their tune. I would be checking over things carefully before doing a custom tune to be sure that a custom tune does not cover something up.

Mike Norris
Mike Norris is offline   Reply With Quote
Old 05-07-2010, 08:09 AM   #9
Mister HP
 
Mister HP's Avatar
 
Drives: Speed Shop owner
Join Date: Aug 2009
Location: Decatur, IN
Posts: 199
Quote:
Originally Posted by Mike Norris View Post
I agree that most likely a proper tune will take care of it, but it should not be needed seeing it is a simple bolt on and go with their tune. I would be checking over things carefully before doing a custom tune to be sure that a custom tune does not cover something up.

Mike Norris

Agreed, depending where the OP is in Tenessee, he's probly not too far from you Mike? I'm sure a good look over would clear things up pretty easily.

Ed
Mister HP is offline   Reply With Quote
Old 05-07-2010, 12:48 PM   #10
Total_Perf_Eng
 
Total_Perf_Eng's Avatar
 
Drives: Corvette
Join Date: Nov 2009
Location: Las Vegas
Posts: 509
Send a message via AIM to Total_Perf_Eng
The "Tune" has nothing to do with that code (Well, its in the tune, but its only 1 small parameter. It is a TP/MAP Correlation error. It is 1 specific section of the file that is a diagnostic test parameter.

It is no more than about a 3 minute correction.

That code is set, when the calculated airflow, and calculated MAP ore outside of their pre-calibrated parameters for greater than 3 seconds.

This is where you find it in HP Tuners
Engine Diagnostics > General > Diagnostics Tests. You can then go into the Max Airflow vs RPM, and increase it, or just go to the "Enable RPM" and bump it up a few thousand RPM. Then bump the min ECT to 256* This essentially disables that test.

Essentially, All it is doing, is measuring the amount of "Actual" airflow, against the Pre Determined airflow. If it sees more than what is pre-determined, then is goes into reduced engine power. Obviously, since we are running boosted cars, the airflow is substantially different. Most of the manufacturers that are tuning this section have just bumped the enable RPM limit. But if you still want to have this test work, then bump the airflow max about 10%, and you'll be set.
What it is doing, is one of MULPITPLE tests, verifying your throttle body is working properly. If the car senses (through testing) that the TB may be stuck, then it will shut everything down just to be safe. Some people may say thats a good thing.. haha. But this is one of many many many redundant tests.

Hope this helps

Last edited by Total_Perf_Eng; 05-11-2010 at 03:47 PM.
Total_Perf_Eng is offline   Reply With Quote
Old 05-11-2010, 12:58 PM   #11
PJ droopy pants
 
PJ droopy pants's Avatar
 
Drives: 2010 Camaro SS
Join Date: Dec 2009
Location: Tennessee
Posts: 36
Thanks for the advice guys, Edelbrock got back to me today and informed me that there is now an update for their tune on their site today to fix this issue. I have uploaded the updated tune and will be doing some test to see if it resovled the issue, I will be getting a full dyno tune as well later this week but I wanted to have the edlebrock tune right first. Here is their page to the update if you need it, the instructions are for a diablo predator but will work for the SCT programer as well.

http://www.edelbrock.com/automotive_...oft-tech.shtml
PJ droopy pants is offline   Reply With Quote
Old 05-11-2010, 03:55 PM   #12
10aSSee D

 
10aSSee D's Avatar
 
Drives: Silver 2010 SS Camaro
Join Date: Jul 2009
Location: TN
Posts: 1,829
Where in Tn. do you live? I'm in the Knoxville area.
__________________
MODS:

ADM built 417, 2.9L Whipple with 3.250 pulley, ADM ported and polished LSA heads,ADM stage3 cam,ADM LSA belt drive system,ADM CAI race scoop, ADM dual fuel pumps, ID 850's, BMR full suspension, Gforce 9 inch kit with 3.5 inch driveshaft, Street Slayer twin carbon clutch, Lingenfelter oil seperator. Tuned by built by ADM Performance, 740rwhp,685rwtq
10aSSee D is offline   Reply With Quote
Old 05-12-2010, 12:14 PM   #13
PJ droopy pants
 
PJ droopy pants's Avatar
 
Drives: 2010 Camaro SS
Join Date: Dec 2009
Location: Tennessee
Posts: 36
Quote:
Originally Posted by 10aSSee D View Post
Where in Tn. do you live? I'm in the Knoxville area.
Hey 10, Im in between Tullahoma and Lynchburg, Jack Daniels country.

After many atempts and running the car hard I have not been able to get that code to come back, seems that the tune was fixed! Going to dyno tune it tomorow and have boost and wideband gauges installed. Thanks for all the help guys!
PJ droopy pants is offline   Reply With Quote
Old 05-12-2010, 12:28 PM   #14
ron10


 
Drives: 2010 2SS IOM L99
Join Date: Jan 2010
Location: LOUISVILLE,KY..
Posts: 7,317
glad you found the problem.
ron10 is offline   Reply With Quote
Old 05-12-2010, 12:51 PM   #15
AlSuwaidi


 
AlSuwaidi's Avatar
 
Drives: BLACK LS3 GCC-Spec
Join Date: Oct 2009
Location: UAE - SHARJAH
Posts: 2,878
good there was a fix.. i have high hopes for this SC.. i am really considering
AlSuwaidi is offline   Reply With Quote
Old 05-12-2010, 03:49 PM   #16
10aSSee D

 
10aSSee D's Avatar
 
Drives: Silver 2010 SS Camaro
Join Date: Jul 2009
Location: TN
Posts: 1,829
Quote:
Originally Posted by PJ droopy pants View Post
Hey 10, Im in between Tullahoma and Lynchburg, Jack Daniels country.

After many atempts and running the car hard I have not been able to get that code to come back, seems that the tune was fixed! Going to dyno tune it tomorow and have boost and wideband gauges installed. Thanks for all the help guys!
Cool I used to live in Monteagle Tn. Glad you resolved your problem.
__________________
MODS:

ADM built 417, 2.9L Whipple with 3.250 pulley, ADM ported and polished LSA heads,ADM stage3 cam,ADM LSA belt drive system,ADM CAI race scoop, ADM dual fuel pumps, ID 850's, BMR full suspension, Gforce 9 inch kit with 3.5 inch driveshaft, Street Slayer twin carbon clutch, Lingenfelter oil seperator. Tuned by built by ADM Performance, 740rwhp,685rwtq
10aSSee D is offline   Reply With Quote
Old 05-12-2010, 07:42 PM   #17
Busy_Boi
SoCal C5 Family Member
 
Busy_Boi's Avatar
 
Drives: RJT 2010 camaro 2SS
Join Date: Aug 2009
Location: Los Angeles, CA
Posts: 1,018
Send a message via Yahoo to Busy_Boi
Can you post your before tune dyno run and after tune dyno please? And congrats on your supercharger have fun.
__________________
Busy_Boi is offline   Reply With Quote
Old 05-13-2010, 11:22 PM   #18
PJ droopy pants
 
PJ droopy pants's Avatar
 
Drives: 2010 Camaro SS
Join Date: Dec 2009
Location: Tennessee
Posts: 36
Sure absolutely, I will have the after tune dyno ealy next week. It ran 379hp/375tq before the S/C.
First video is the stock run, second is with S/C and Edelbrock tune.




Last edited by PJ droopy pants; 05-14-2010 at 10:02 AM.
PJ droopy pants is offline   Reply With Quote
Old 01-08-2011, 10:01 PM   #19
positron1169
 
Drives: 2010 camaro SS/RS
Join Date: Dec 2009
Location: New Jersey
Posts: 12
I am looking to install the Edelbrock E Force supercharger on the L99 . I have some questions for the guys you have already installed it, as I have never super charged any of my rides.

have you had any issues after the initial install. is your engine running well ? and those with automatics, has the tranny been fine with the added power?

I know that it is hard not to mash the pedal to the floor , once all the power is added, but when doing regular driving , is the gas mileage much worse than when it was not injected.

thanks
positron1169 is offline   Reply With Quote
Old 01-08-2011, 10:13 PM   #20
2010 SS RS

 
2010 SS RS's Avatar
 
Drives: 2010 2SS/RS IBM Black Polished
Join Date: Feb 2009
Location: Colorado
Posts: 2,130
Just throwing this out there as I have seen this before. Are you using the kit air box or aftermarket CAI? If retrofit aftermarket CAI make sure MAF is located properly. Also make sure it is installed with airflow the correct direction. Tune it out works but something causing the issue. Just an opinion and .02cents
__________________
418 Stroker, 621RWHP 648 lbs TORQUE Built by Laramie GM Auto Center Tuned by Nick at Mac Autosport. EForce SC, 2 3/4pulley,LPE dual fuel pump, JRE Twin fuel rail upgrade, posi clutch kit, RX oilcatch can and breather, Callies Compstar crankshaft and rods, Racing bearings, CP -13.8 race pistons, steel rings, Comp Cams X6 blower cam, Springs, HD timing chain and tensioner, Doug Thorley Tri Y LT headers, 89.7lb injectors, RPM rollbar, DSS1400 shafts, Simpson 5 pt harness, BMR Toe rods and trailing arms, led lights, RPM input and output shafts
2010 SS RS is offline   Reply With Quote
Old 01-08-2011, 10:25 PM   #21
POWERFREAK
I.AM.
 
POWERFREAK's Avatar
 
Drives: 2010 2SS/RS/M6
Join Date: Oct 2008
Location: NY
Posts: 2,360
Quote:
Originally Posted by jsharp View Post
I know that they may not be claiming issues but about 85% of what I have read on here about people receiving the kit were not completly satisfied.
really? i've heard nothing but great things about them AND their customer service.
__________________
2010 R6P-2SS/RS/LS3 - IBM w/ silver rally stripes / UNDER CONSTRUCTION.

NY5thgen.com
POWERFREAK is offline   Reply With Quote
Old 01-08-2011, 10:38 PM   #22
positron1169
 
Drives: 2010 camaro SS/RS
Join Date: Dec 2009
Location: New Jersey
Posts: 12
I am going to use the kit air box , but thanks for the heads up
positron1169 is offline   Reply With Quote
Old 01-09-2011, 07:25 AM   #23
lock

 
lock's Avatar
 
Drives: 11 2SS/RS E-Force Supercharged
Join Date: Apr 2010
Location: Charlotte
Posts: 814
Quote:
Originally Posted by POWERFREAK View Post
really? i've heard nothing but great things about them AND their customer service.
Ive seen very few complaints. I called their tech service and got awesome help. The kit itself is as professional as I could imagine and the install is very straight forward with great instructions.
__________________
11 IOM 2SS/RS E-Force Supercharged. 616 RWHP/578 RWTQ. Click link for my journal!!!


lock is offline   Reply With Quote
Old 01-09-2011, 10:48 AM   #24
sscamaro

 
sscamaro's Avatar
 
Drives: 2010 Camaro 2SS/RS
Join Date: Jan 2007
Location: Denver,PA
Posts: 1,838
I installed mine in September last year. I'm very satisfied with the kit. Straight forward installation and great results.

__________________
2010 2SS/RS Victory Red, MN6, 1-7/8 Kooks LT Headers, SLP Axle Back, Edelbrock E-Force S/C, ZL1 Fuel Pump, 72# Injectors, JRE fuel rail upgrade, Roto-Fab CAI, Elite Catch Can, Billet Hurst Shifter, DSS 1000HP axles, Spohn Trailing Arms, Toe Links, Lower Control Arms. 546/rwhp & 522/rwtq Tune by Jeremy Formato.
sscamaro is offline   Reply With Quote
Old 01-09-2011, 11:16 AM   #25
oachalon

 
Drives: 2010 Camaro 1SS
Join Date: Mar 2009
Location: Mentor, Ohio
Posts: 860
I installed mine around august of last year and i love it. I am not sure what the poster above was saying about people not liking it. From what i see on here, people are loving theres, and i am also loving mine.

Last edited by oachalon; 01-09-2011 at 11:58 AM.
oachalon is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Edelbrock Supercharger Kit for 2010 Camaro Pre Order Special TitanMotorsports Forced Induction 51 04-01-2010 09:26 AM
First Ever Kenne Bell Supercharger Install Special!!! Total_Perf_Eng Forced Induction 10 03-08-2010 10:24 AM
Some basic supercharger info SoloSK71 Forced Induction - V8 4 08-07-2009 02:00 AM
New Edelbrock supercharger for the Mustang bigralph General Automotive + Other Cars Discussion 10 12-13-2008 12:11 PM
Edelbrock E-Force Supercharger JameSS General Automotive + Other Cars Discussion 15 11-13-2008 04:23 PM


All times are GMT -5. The time now is 09:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.