Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Apex Paul
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 05-20-2010, 04:59 PM   #15
Milk 1027
Camaro➎ moderator
 
Milk 1027's Avatar
 
Drives: '13 BLK 1LE
Join Date: Aug 2008
Location: AZ
Posts: 13,518
You guys need to understand that we are here to help you out.

#89470 no problems with clutch engagement at all, just had it stick to the floor three times. All under hard acceleration.
__________________
Milk 1027 is offline   Reply With Quote
Old 05-20-2010, 05:05 PM   #16
Michael_Js
SoCal C5 Family Member
 
Michael_Js's Avatar
 
Drives: 2010 Camaro SS/RS - Black w/IOM; 6M
Join Date: Jul 2009
Location: San Diego, CA, USA
Posts: 5,306
Send a message via AIM to Michael_Js Send a message via MSN to Michael_Js
Michael J. VIN# A9136383 Driving a stick for decades, and decades, and...yup, more decades

Clutch sticks 1/2 way on aggressive take offs
lots of stinky clutch smell - not always, but slow backing up and the like

Already had clutch replaced - parts list:

Qty Part Number Description
4 - 11569956 Bolt 0.669 0Y CP BK
2 - 11569956 Bolt 0.669 0Y CP BK
1 - 12557583 Bearing 0.649 0Y CP
6 - 12561465 Bolt 0.862 0Y CP BK
1 - 24255748 Plate 0.859 0Y C
1 - 12571611 Flywhee 0.666 0Y C
1 - DLRUP DLRUP
1 - 89021297 Adhesiv 8.800 0 CPO
2 - RP001320 RylPrpl
__________________
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~
2010 Black 2SS/RS; 6M; IOM, GFX, sunroof; ADM Race CAI; Zoomers CB; Viper Alarm; Pdaft F&R sways, Adj Endlinks, Rtrailing arms, Camber kit, strut brace, Front Trailing Arm Bushing; SLP Skip-Shift Elim; Tinted lights/windows; Hurst Short-throw; LoJack; Door & Dash ABL Mods; ********; JBA Shorty headers; AACStyle LEDs; Stillen DS rotors, Hawk Ceramic pads; Havoc Blk Chrome wheels: 20x9s; Lingenfelter Blk Al Pedals; RevXtreme Catch Can; Goodridge SS lines; Ported TB; RK Sport hood; Hotchkis chassis brace; KW V3 coilovers;
Michael_Js is offline   Reply With Quote
Old 05-20-2010, 05:11 PM   #17
motorhead


 
motorhead's Avatar
 
Drives: Stormtrooper
Join Date: Sep 2009
Location: Bartertown
Posts: 9,518
Is it only with low vins. I drag mine all the time and haven't had any problems as long as I flush the fluid and replace after a day at the drags. vette does the same thing after a day of road coarse racing.



Edit: Check out this link. It might help some of you. http://www.torcavettes.com/tech/ClutchHydraulics.htm
motorhead is offline   Reply With Quote
Old 05-20-2010, 06:46 PM   #18
nascar14fan
 
nascar14fan's Avatar
 
Drives: 2010 Red 2SS/CGMStripes/RS/6sp
Join Date: Jul 2009
Location: Missouri
Posts: 101
Quote:
Originally Posted by Milk 1027 View Post
You guys need to understand that we are here to help you out.

#89470 no problems with clutch engagement at all, just had it stick to the floor three times. All under hard acceleration.
Good. Help. What do you need from me? And who is we? And do you think it was normal for your clutch to stick? Because If nobody can accelerate hard in a Camaro SS then I guess its time to get a GT or Challenger. And that is very very hard for me to say I was born in a UAW GM house and have never had anything but and my dad will probebly roll over in is grave. I drove my friends GT last weekend just like I drive my Camaro and not a problem except for burnt rubber. He drove mine like he does his and stuck clutch. I thought I bought a sports car that was made to accelerate hard. But I guess what you see is not what you get.
nascar14fan is offline   Reply With Quote
Old 05-20-2010, 07:13 PM   #19
GUMBALL
 
Drives: 2010 Camaro 1SS M6
Join Date: May 2010
Location: Baton Rouge, LA
Posts: 19
Mike #A9198969, 8000 miles. Owned 8 vehicles with a stick over the past 28 years.

1. Inconsistent clutch engagement, mostly at the very top
2. Clutch feels like it doesn't fully engage going into second
3. Herky jerky cold start in first gear
4. Clutch burning smell starting on a mild incline (never happened in other cars)
5. Never drove this car hard. GM can download my driving habits thru Onstar
6. Smooth launch difficult at any RPM
7. Improper pedal feel, no breaking point, no clutch pedal play at the top when you first step on the pedal.

**Note, I took delivery right from the car hauler. Only assemby line worker, car hauler guy and my salesman drove the car. Salesman got gas next door. No one took my car for any test drives etc.
GUMBALL is offline   Reply With Quote
Old 05-20-2010, 07:21 PM   #20
Milk 1027
Camaro➎ moderator
 
Milk 1027's Avatar
 
Drives: '13 BLK 1LE
Join Date: Aug 2008
Location: AZ
Posts: 13,518
Quote:
Originally Posted by nascar14fan View Post
Good. Help. What do you need from me? And who is we? And do you think it was normal for your clutch to stick? Because If nobody can accelerate hard in a Camaro SS then I guess its time to get a GT or Challenger. And that is very very hard for me to say I was born in a UAW GM house and have never had anything but and my dad will probebly roll over in is grave. I drove my friends GT last weekend just like I drive my Camaro and not a problem except for burnt rubber. He drove mine like he does his and stuck clutch. I thought I bought a sports car that was made to accelerate hard. But I guess what you see is not what you get.
It's a normal issue in Corvettes, from what we know. If you want another car, no one is stopping you.
Try changing your reservoir fluid and bleeding the clutch a few times.


and by we, I mean us, the moderators, the ones that are asking questions and being attacked for it.
__________________
Milk 1027 is offline   Reply With Quote
Old 05-20-2010, 07:25 PM   #21
CynAgain


 
CynAgain's Avatar
 
Drives: Chevy
Join Date: Dec 2008
Location: USA
Posts: 6,629
# 9855 I have no issues whatsoever *knocks on wood*
CynAgain is offline   Reply With Quote
Old 05-20-2010, 08:22 PM   #22
nascar14fan
 
nascar14fan's Avatar
 
Drives: 2010 Red 2SS/CGMStripes/RS/6sp
Join Date: Jul 2009
Location: Missouri
Posts: 101
Quote:
Originally Posted by Milk 1027 View Post
It's a normal issue in Corvettes, from what we know. If you want another car, no one is stopping you.
Try changing your reservoir fluid and bleeding the clutch a few times.


and by we, I mean us, the moderators, the ones that are asking questions and being attacked for it.
I guess it would be pointless to bleed everything right now since my new master cylinder cap has not come in yet which is leaking like crazy. And have been told by alot of people that that could definently cause my problem. Creates a nice hydro static lock. Kinda like a hydrolic hose on a back hoe put a hole in it and see what happens. But the dealer dont see it that way. And the 800# is not much help either.
nascar14fan is offline   Reply With Quote
Old 05-20-2010, 08:53 PM   #23
casadesola
 
casadesola's Avatar
 
Drives: 2010 SS/RS Rally Yellow M6
Join Date: May 2010
Location: New York
Posts: 16
I have some similar issues. VIN A9189529. Less than 500 miles. Haven't driven a stick in about 10 years so I thought I lost my touch until my cousin drove it (he drives stick daily) and said the pedal was too high and then couldn't find a consistent shift point.

1. Inconsistent clutch engagement, mostly at the very top
2. Clutch feels like it doesn't fully engage going into second
3. Herky jerky cold start in first gear
4. Clutch burning smell from time to time
5. Never drove this car hard. GM can download my driving habits thru Onstar
6. Improper pedal feel, no breaking point, no clutch pedal play at the top when you first step on the pedal.
7. Hate the 1-4 auto shift feature when driving in the city. Feels too steep to be in fourth gear when only doing 20 mph.
casadesola is offline   Reply With Quote
Old 05-20-2010, 09:49 PM   #24
GoPaul
H-Town Camaro Club
 
GoPaul's Avatar
 
Drives: 2010 Black Camaro 2LT RS M6
Join Date: Apr 2010
Location: Katy, TX
Posts: 928
VIN ...A9204414
2000 miles on the clock and clutch stuck this morning for the first (and hopefully last) time.
Have had some minor grinding issues too when changing gears.
__________________
Best Timeslip: <Time Slip> Latest Dyno (w. Injen only): <Dyno Sheet> Journal: <Here>
GoPaul is offline   Reply With Quote
Old 05-20-2010, 10:37 PM   #25
armysig
Catch me if you can
 
armysig's Avatar
 
Drives: 2012 IOM ZL-1
Join Date: Nov 2009
Location: Texas
Posts: 2,468
A9175524
M6

I have had an issue since day one of owning the car. My first ride down the road I down shifted from 4th to 3rd and it stuck half way. Then after about 500 miles I noticed that going from 1st to second my clutch pedal would stop half way. I wasn't trying to do a hard launch, just normal every day shifting.
Then one day I was attempting to release the clutch pedal in 1st and it became stuck half way. The next thing that happened was a large amount of clutch smoke coming through the vents and dash board. The car was shut down and brought to the dealership and was told they couldn't find an issue.

I have now had my car to the local dealership 3 times for this issue, and on the last time the dealership said they were instructed by GM to not work on the car unless I could reproduce the problem with a tech in the car. I have been able to get it to do it for a brief second, but not like it has in the past. So now, I'm at a loss due to GM not wanting to address the issue.
__________________
armysig is offline   Reply With Quote
Old 05-20-2010, 10:49 PM   #26
reddevil
 
Drives: Red Jewel camaro
Join Date: Sep 2009
Location: OKC
Posts: 49
vin A9141608 clutch sticks to floor sometimes on aggressive take offs.
reddevil is offline   Reply With Quote
Old 05-20-2010, 10:55 PM   #27
tylermoore
 
Drives: 2010 Camaro 1ss/LS3 Victory Red
Join Date: Feb 2009
Location: kinston, NC
Posts: 251
A9140766- I get frequent clutch chatter when down shifting and even more when backing out of my driveway, when i clutch to go from R to 1st there is always a clank clank clank. I am no seasoned manual driver but it just doesnt seem right. Am i doing something wrong????
__________________
2010 Camaro SS/LS3
1998 Camaro Z28 A4
tylermoore is offline   Reply With Quote
Old 05-21-2010, 03:23 AM   #28
Big Brunsy

 
Drives: 2010 supercharged LS3
Join Date: Jan 2010
Location: Le Mars, Iowa
Posts: 2,233
A9158850 - had clutch stick 3 times under hard acceleration. once to the floor and twice half way up. been driving manual trans for 8 years.
__________________
Big Brunsy is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I want a new clutch, you too????? Sign here tjbusa V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) 370 08-10-2013 03:27 AM
Clutch fluid contamination problems on Vette fixed for Camaro??? LDGn63 V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) 11 05-28-2012 09:17 PM
Oil Change Ramp mjlash22 Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 17 01-21-2010 10:40 PM
Clutch Sticking F N MUSCLE Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 12 12-07-2009 04:00 PM
Burned my clutch a bit with Launch Control.... Caution you guys... Embalmer 5th Gen Camaro SS LS LT General Discussions 49 04-23-2009 08:49 PM


All times are GMT -5. The time now is 04:07 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.