Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Kraft Werks
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum

Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum All audio, video, bluetooth, nav, radar, and electronics discussions.

Reply
 
Thread Tools
Old 10-25-2010, 08:50 PM   #126
fastkevman
 
fastkevman's Avatar
 
Drives: 2011 Victory Red 1SS/RS M6
Join Date: May 2010
Location: PA
Posts: 481
My best mod yet, I really like the system now!
I mostly listen to hard rock/heavy metal so removing the center speaker and lowering my settings worked out great for me.

Thanks guys!
fastkevman is offline   Reply With Quote
Old 10-25-2010, 09:27 PM   #127
KeepItGreasey
So It'll Go Down Easy
 
KeepItGreasey's Avatar
 
Drives: Camaro SS/RS
Join Date: Aug 2010
Location: Long Beach, CA
Posts: 899
Quote:
Originally Posted by Z28RockStar View Post
Thinking I might try this, (when I get my Z28)(yes lol I know its a diff system prolly), Can anyone post a vid of how this mod sounds with a little

BLACK LABEL SOCIETY w/ZAKK WYLDE?!

RAWR! =)
__________________
KeepItGreasey is offline   Reply With Quote
Old 10-26-2010, 02:45 AM   #128
Darkone
 
Darkone's Avatar
 
Drives: 2011 Camaro LT/RS SIM
Join Date: May 2010
Location: Oman
Posts: 168
Quote:
Originally Posted by fastkevman View Post
My best mod yet, I really like the system now!
I mostly listen to hard rock/heavy metal so removing the center speaker and lowering my settings worked out great for me.

Thanks guys!
Same here, but more of melodic death. What do you have your settings at?
Darkone is offline   Reply With Quote
Old 10-26-2010, 04:33 AM   #129
2011 5.0
Account Suspended
 
Drives: 2011 Mustang GT 5.0 "Kona Blue"
Join Date: Oct 2010
Location: Suffolk County, Long Island
Posts: 293
Quote:
Originally Posted by AlSuwaidi View Post
so it looks like it has surround... to fool the noobz

lol
2011 5.0 is offline   Reply With Quote
Old 10-26-2010, 07:55 AM   #130
shockandawe

 
Drives: 2006 LeMans Blue C6 Vette
Join Date: Dec 2008
Location: Wisconsin
Posts: 1,300
Excellent!
shockandawe is offline   Reply With Quote
Old 10-26-2010, 03:33 PM   #131
MF2SSRS
 
Drives: VR 1LE
Join Date: Oct 2010
Location: New Jersey
Posts: 126
Did this and honestly there really wasn't that much of a difference. I guess without the center speaker it MAY be a little crisper sounding but that could also be the placebo effect kicking in.

Seriously I was listening to the ipod with the speaker out and I would unplug and plug the harness back in during the song and would not be able to tell. If somebody told me they disconnected my center speaker I never would know the difference. ..but hey if you guys think it is much better then go for it!
MF2SSRS is offline   Reply With Quote
Old 10-26-2010, 05:51 PM   #132
fastkevman
 
fastkevman's Avatar
 
Drives: 2011 Victory Red 1SS/RS M6
Join Date: May 2010
Location: PA
Posts: 481
Quote:
Originally Posted by Darkone View Post
Same here, but more of melodic death. What do you have your settings at?
I am trying the -2, -4, and 0 right now with the center unhooked and it sounds good at the same or lower volumes than I have been using.

To me it sounds more crisp and I don't hear any crackling like I have been at higher settings and with the center hooked up.
fastkevman is offline   Reply With Quote
Old 10-31-2010, 01:06 PM   #133
BriCo84
 
Drives: 2011 CGM 2LT w/RS
Join Date: Jun 2010
Location: Miami, FL
Posts: 364
Ok so I have a question. I followed the instructions laid out on this thread for taking off the grille (btw, it is not as easy as everyone claims and the dash, and grille do get marked up and warped a little bit. Anyway, I got the grille off and it looks like some of the white pieces fell off on the left side of the grille but I couldn't find them in the car. I am wondering if anyone can confirm whether the grille is supposed to have 4 of the white tabs or only 2. Picture is below.

Thanks
Attached Images
 
BriCo84 is offline   Reply With Quote
Old 11-01-2010, 11:44 AM   #134
BriCo84
 
Drives: 2011 CGM 2LT w/RS
Join Date: Jun 2010
Location: Miami, FL
Posts: 364
can I get any help on this?
BriCo84 is offline   Reply With Quote
Old 11-01-2010, 01:33 PM   #135
Duper
 
Drives: 2011 Camaro 2SS / RS
Join Date: Jul 2010
Location: Pasadena, CA
Posts: 299
Yeah, there's supposed to be white tabs on those pieces too.
__________________
Duper is offline   Reply With Quote
Old 11-01-2010, 02:58 PM   #136
BriCo84
 
Drives: 2011 CGM 2LT w/RS
Join Date: Jun 2010
Location: Miami, FL
Posts: 364
You're sure? So they fell off? $H1T
BriCo84 is offline   Reply With Quote
Old 11-01-2010, 04:31 PM   #137
Duper
 
Drives: 2011 Camaro 2SS / RS
Join Date: Jul 2010
Location: Pasadena, CA
Posts: 299
Yeah, they're on mine and I've removed and replaced that grill several times.

It might not be that big of a deal though... there's tabs on the back side (closest to the windshield that you can see in the bottom of your pic above) that hook under the opening and with the two you haven't dropped, that should keep the grill stable in there.

Option 2 (but somewhat dishonest): replace the grill and go to the dealer complaining that there's rattling coming from that area of the dash when you're driving around. Say you don't know where it's coming from but it sounds like it's under the center grill. Let them 'discover' the missing tabs and they'll replace it for you.
__________________
Duper is offline   Reply With Quote
Old 11-01-2010, 04:51 PM   #138
BriCo84
 
Drives: 2011 CGM 2LT w/RS
Join Date: Jun 2010
Location: Miami, FL
Posts: 364
Good call. I will prob just put it back for now, and do what you said, have them replace them when I go next, which will be at 3000 miles for my free oil change
BriCo84 is offline   Reply With Quote
Old 11-01-2010, 05:01 PM   #139
BriCo84
 
Drives: 2011 CGM 2LT w/RS
Join Date: Jun 2010
Location: Miami, FL
Posts: 364
I just hope they dont discover that the speaker is unplugged and the wire is taped to it. lol
BriCo84 is offline   Reply With Quote
Old 11-01-2010, 05:07 PM   #140
rtcat600man
having FUN now 13.66@101
 
rtcat600man's Avatar
 
Drives: 2010 2LT IOM
Join Date: Nov 2009
Location: Clarkston, Michigan
Posts: 7,943
Quote:
Originally Posted by BriCo84 View Post
Ok so I have a question. I followed the instructions laid out on this thread for taking off the grille (btw, it is not as easy as everyone claims and the dash, and grille do get marked up and warped a little bit. Anyway, I got the grille off and it looks like some of the white pieces fell off on the left side of the grille but I couldn't find them in the car. I am wondering if anyone can confirm whether the grille is supposed to have 4 of the white tabs or only 2. Picture is below.

Thanks

If you use the proper tool you can pop the cover off in seconds. I know I just did it again to get a photo (below) for everyone to see the bottom side. No damage to anything when using a plastic tool.


Quote:
Originally Posted by Duper View Post
Yeah, there's supposed to be white tabs on those pieces too.
Yep, all four corners have white tabs on mine.

Quote:
Originally Posted by Duper View Post
Yeah, they're on mine and I've removed and replaced that grill several times.

It might not be that big of a deal though... there's tabs on the back side (closest to the windshield that you can see in the bottom of your pic above) that hook under the opening and with the two you haven't dropped, that should keep the grill stable in there.

Option 2 (but somewhat dishonest): replace the grill and go to the dealer complaining that there's rattling coming from that area of the dash when you're driving around. Say you don't know where it's coming from but it sounds like it's under the center grill. Let them 'discover' the missing tabs and they'll replace it for you.
By the looks of the metal tabs I think you have two metal tabs and two plastic tabs. Not sure why but I didn't see any metal tabs under the plastic ones. There would be no reason to have a plastic tab and a metal tab. Again not sure why you have two different ones. Just re-attach the cover and call it good.
Attached Images
 
__________________
rtcat600man is online now   Reply With Quote
Old 11-01-2010, 05:14 PM   #141
Duper
 
Drives: 2011 Camaro 2SS / RS
Join Date: Jul 2010
Location: Pasadena, CA
Posts: 299
Quote:
Originally Posted by BriCo84 View Post
I just hope they dont discover that the speaker is unplugged and the wire is taped to it. lol
You might want to plug it back in just in case! I'd bet they remove that center speaker just to look around in there. Again, I think you'll be fine without those plastic tabs anyway.
__________________
Duper is offline   Reply With Quote
Old 11-03-2010, 05:08 PM   #142
Hicompression
Rumbly Bumble Bee
 
Hicompression's Avatar
 
Drives: 2010 2SS Camaro
Join Date: Aug 2009
Location: DFW
Posts: 1,473
Quote:
Originally Posted by BriCo84 View Post
Anyway, I got the grille off and it looks like some of the white pieces fell off on the left side of the grille but I couldn't find them in the car. I am wondering if anyone can confirm whether the grille is supposed to have 4 of the white tabs or only 2. Picture is below.

Thanks
There are two types of tabs. Apparently on your grille, they ran out of the plastic ones at the factory. They used metal tabs on the other side. You are 100% ok.

Quote:
Originally Posted by Duper View Post
Yeah, there's supposed to be white tabs on those pieces too.
Not if they used the metal substitutes.

Quote:
Originally Posted by BriCo84 View Post
You're sure? So they fell off? $H1T
Again, no they didn't. The factory used two metal clips on yours.

Quote:
Originally Posted by Duper View Post
Yeah, they're on mine and I've removed and replaced that grill several times.
And...they're on mine too. But the OP's had two plastic ones and two metal put on at the factory.

Quote:
Originally Posted by BriCo84 View Post
Good call. I will prob just put it back for now, and do what you said, have them replace them when I go next, which will be at 3000 miles for my free oil change
Don't worry about it. Again, nothing fell off.
__________________
2010 RALLY YELLOW 2SS 6M
-OBX Longtubes FTW!
Hicompression is offline   Reply With Quote
Old 11-03-2010, 05:12 PM   #143
Hicompression
Rumbly Bumble Bee
 
Hicompression's Avatar
 
Drives: 2010 2SS Camaro
Join Date: Aug 2009
Location: DFW
Posts: 1,473
Thumbs down Don't Believe the Hype...

So...I drank the kool-Aid and tried this mod too. What a bunch of horse pucky. The system lost volume up front (mids and highs) with the speaker disconnected. The system definitely sounds more "bright" with it in.

I hooked the speaker back up and will be hooking up a 10" sub-box here in the near future.
__________________
2010 RALLY YELLOW 2SS 6M
-OBX Longtubes FTW!
Hicompression is offline   Reply With Quote
Old 11-03-2010, 06:03 PM   #144
rtcat600man
having FUN now 13.66@101
 
rtcat600man's Avatar
 
Drives: 2010 2LT IOM
Join Date: Nov 2009
Location: Clarkston, Michigan
Posts: 7,943
Quote:
Originally Posted by Hicompression View Post
So...I drank the kool-Aid and tried this mod too. What a bunch of horse pucky. The system lost volume up front (mids and highs) with the speaker disconnected. The system definitely sounds more "bright" with it in.

I hooked the speaker back up and will be hooking up a 10" sub-box here in the near future.

To each their own. You are almost all alone on this one. But everyone can decide for them self. It is an easy test. I know what I heard and my wife noticed it too.

PS: The kool-aid was good thou.
__________________
rtcat600man is online now   Reply With Quote
Old 11-03-2010, 06:36 PM   #145
Hicompression
Rumbly Bumble Bee
 
Hicompression's Avatar
 
Drives: 2010 2SS Camaro
Join Date: Aug 2009
Location: DFW
Posts: 1,473
Quote:
Originally Posted by rtcat600man View Post
To each their own. You are almost all alone on this one. But everyone can decide for them self. It is an easy test. I know what I heard and my wife noticed it too.
Almost alone but not quite...


Quote:
Originally Posted by recontango View Post
I am not exactly sure i notice a huge difference like some are stating, but the stereo effect is much better. I am curious for the guys that saw such a dramatic difference, what are your EQs set to? Mine are treble: 9, mid:7, bass: 11
Quote:
Originally Posted by CamaroDreams07 View Post
My results: Definitely not night and day quality-wise. Is it going to knock your socks off in a "night and day" fashion? Nope, but it will at least bring the music across the way it was recorded.

Anyway that's my .02, take it or leave it.
Quote:
Originally Posted by Michael_Js View Post
Drastic improvement? No, not IMO.
Quote:
Originally Posted by ClutchKargo View Post
Did it make a difference? Yes

Drastic? Not really
Quote:
Originally Posted by KMPrenger View Post
I must have spent a half hour to 45 minutes listening to various songs of different genres with and without that center speaker in place. I must be the only one here, but in the end.....I put it back in place hooked up.

In my opinion (and going with my original thoughts) I think just adding one 10" subwoofer will make the system perfect.
Sounds like my opinion...

Quote:
Originally Posted by MF2SSRS View Post
Did this and honestly there really wasn't that much of a difference.
Seriously I was listening to the ipod with the speaker out and I would unplug and plug the harness back in during the song and would not be able to tell. If somebody told me they disconnected my center speaker I never would know the difference. ..but hey if you guys think it is much better then go for it!
Agreed!
__________________
2010 RALLY YELLOW 2SS 6M
-OBX Longtubes FTW!
Hicompression is offline   Reply With Quote
Old 11-03-2010, 07:49 PM   #146
rtcat600man
having FUN now 13.66@101
 
rtcat600man's Avatar
 
Drives: 2010 2LT IOM
Join Date: Nov 2009
Location: Clarkston, Michigan
Posts: 7,943
Quote:
Originally Posted by Chief Mario View Post
I have the BA and didn't really like the sound of it. It did not compare to my Alpine with Imprint technology that I have in my SUV.

Like most, I started by adding a couple of 10" subs (kicker) that I purchased from Subthumb, great product by the way. That took care of the low end frequencies and improved the system by a ten full but I was still not happy with the overall sound.

I started to feel that my center speaker was responsible for the poor quality, in my opinion the reason is that the center takes away the stereo effect and contributes to an overall excess of high frequencies even after adjusting the treble to -9db.

Well tonight I said, enough is enough, out comes the tools and diagram. 20 minutes later the yellow wire is cut, hence no more center speaker. Wowww, I tell you, with all honesty, this was absolutely the right thing to do.

The system is 20 times better, the stereo effect is superb, the cabin is perfectly balance between the highs an the lows and i don't have to play with the tone settings anymore unless i change CD or source. i am finally happy with the BA system.

Cheers!
Quote:
Originally Posted by wolfclan View Post
I disconnected at the speaker, now the scratchy noise is gone and the system sounds a lot cleaner at higher volumes.
I also followed norty717's instructions and ended up with the treble set at +1, midrange at +2 and bass at +3. I should mention I have hearing damage from many yrs of listening to high frequency rock drills.
Quote:
Originally Posted by mdinferno View Post
i just did the disconnect and its exactly as wolfclan said "I disconnected at the speaker, now the scratchy noise is gone and the system sounds a lot cleaner at higher volumes.
Quote:
Originally Posted by bobby35ny View Post
WOW, I did that today, you are right, I can do 35 and clear as a bell!!
-bobby
Quote:
Originally Posted by CamaroDreams07 View Post
Yeah I forgot to mention I did that today too. Not sure if it was that or losing the center speaker, but I find that I need to crank it up about 2 notches higher to get to my favorite volume. But the clarity is a whole heckuva lot better. Thanks for pointing this out to us IAS. You're becoming a real Yoda for me on this forum
Quote:
Originally Posted by LS3SSRS View Post
i just disconnected my center speaker as well, and it sounds really good now! a lot better sounding, not as muffled... if that makes sense. also, my settings are 3,1,1
Quote:
Originally Posted by IndyDave View Post
Done! Great video of the removal process here:

took all of 5 minutes. Definite improvement in "stereo" sound & also my bass seems to
have increased, had to turn the EQ down a bit Love it though, now to just get a sub in the trunk & I will be set.....Thanks for all the help
Quote:
Originally Posted by Michael_Js View Post
Well, I removed mine and there is a difference, for the better. Drastic improvement? No, not IMO. You can tell stereo separation better. Such an easy thing to try though, might as well give it a shot. I disconnected the connector from the center speaker - no wire cutting in the trunk
Quote:
Originally Posted by VRMMMM View Post
Simple mod, did this in my garage in my PJs in 5 mins then listened to Rush Moving pictures Sounded SWEET!
Quote:
Originally Posted by Brownhornitt View Post
This is what I did. Don't cut it. Just take the five minutes to carefully remove.

Recommend highly.
Quote:
Originally Posted by rtcat600man View Post
Unbelievable difference. NEVER would I have thought to do this. Read about this a couple hours ago. Just came back in from testing this thread. DO IT. You will NOT believe the difference. I taped the plug to the speaker to keep the wire from rattling around. For those who want to drop another 1/2 lb from the Camaro just take the speaker out all together.

Thanks to this thread the music will be have a cleaner sound.
Quote:
Originally Posted by vuduman67 View Post
Wow wouldnt of believed it if i didnt try it myself. I actually unpluged it and replugged while it was on(Im sure not reccommended)and heard the difference immediatly. The sound is not as full but it is cleaner no doubt. I think I might look for a better speaker and replace instead of removing but for now I am leaving it out.
Quote:
Originally Posted by ClutchKargo View Post
Unpluged the center speaker and put it back in this morning. Took 5 minutes tops.

Did it make a difference? Yes

Drastic? Not really

Good? Yes, more seperation of stereo as stated before

Leave it unplugged? Yes

It does make a difference that for now I like. FM, XM and iPod all do sound better in my opinion. Probably XM the most. I do seem to notice an increase in bass. Not sure why but there does seem to be more boost.

IMO, definately pop the grill and unplug the speaker. Extremely easy and no rattle.

Clutch
Quote:
Originally Posted by rtcat600man View Post
Just to make sure I thought I could hear the difference, I had my wife come out and listen to it too. She said the same thing "noticed an increase in bass,” and a cleaner sound.
Quote:
Originally Posted by Bistem View Post
In my case this tip was Very noticeable. It may depend on what type music you listen to as to how much difference it makes. I listen to a lot of smooth jazz and the difference was very nice. Thanks you all for yet another FREE improvement.
Quote:
Originally Posted by MJOvermann View Post
I unplugged the center speaker the other day. WOW, there is a difference. Everything seems to be much clearer than before. Nice find!
Quote:
Originally Posted by ClutchKargo View Post
Three weeks now after doing this and each day I like this stereo more. The bass level has really improved and channel seperation is much more noticeable. Basically the overall sound is much,much better. And it's reversable to stock in 5 minutes or less (but you won't go back!)

I am not an "Audiophile" by any strech, but this is an awesome change/upgrade and the price is right!

Clutch
Quote:
Originally Posted by Jeanius View Post
Just did it, took about 3 minutes, I like it much better.

And to the guy who suggested turning Treble/Mid/Bass to 0 and adjusting from there...

Bravo Sir... BRAAAVOOO

Much clearer, crisper sound at high volumes by doing this. Bass sounds nice and clean
Quote:
Originally Posted by lock View Post
Did this today. SOOOO much better!
Quote:
Originally Posted by mercuryman96 View Post
No cutting just un-plugged it. Wow what a difference.
Quote:
Originally Posted by Darkone View Post
The difference is HUGE. I was very skeptical about the disabling of a tiny speaker making so much difference. Actually sounds like a premium sound system now.

Thanks!

Also, there isn't any difference in volume in call using bluetooth. Clear and loud at volume 12.
Quote:
Originally Posted by scrming View Post
less than a 5 minute job... and WOW! To me a VAST improvement in the stereo separation! To me it seems the sound stage is much more defined... And for the type of music I listen to and the way I like the front and rear balance set this no cost mod is a HUGE improvement! Sorry it took me so long to notice this thread!!! THANKS to the OP!!!
Quote:
Originally Posted by hypurone View Post
'
There are 3 tabs at the forward edge (front of the car) so you need to pop both rear tabs first, then as you lift it up it will pop the two fronts and away you go. Obviously you will need to insert the forward edge first when reinstalling...

I must say, I had my doubts but it is def worth doing. Besides destroying the stereo effect, it totally "muddies" the sound... Glad I did it for sure.
Quote:
Originally Posted by FRANK121 View Post
Well I thought this was bs. So I tried it and works! Less distortion and sounds much better. I think the center channel would be fine if there was a separate fader for it to where you could just barely have it on? Paired with the front speakers it can't handle the volume. Mine is now unplugged and 30 to 35 on the volume really sounds good now!
Quote:
Originally Posted by fastkevman View Post
My best mod yet, I really like the system now!
I mostly listen to hard rock/heavy metal so removing the center speaker and lowering my settings worked out great for me.

Thanks guys!
Since you took the time to show those who didn't think it worked, the least I good do was show the list of those who thought it did work.

Lets agree to disagree.
__________________
rtcat600man is online now   Reply With Quote
Old 11-03-2010, 10:14 PM   #147
Hicompression
Rumbly Bumble Bee
 
Hicompression's Avatar
 
Drives: 2010 2SS Camaro
Join Date: Aug 2009
Location: DFW
Posts: 1,473
Quote:
Originally Posted by rtcat600man View Post
Since you took the time to show those who didn't think it worked, the least I good do was show the list of those who thought it did work.

Lets agree to disagree.
You know what they say about opinions right? They're like...well...you know how the saying goes...everyone's got one.
__________________
2010 RALLY YELLOW 2SS 6M
-OBX Longtubes FTW!
Hicompression is offline   Reply With Quote
Old 11-04-2010, 05:07 AM   #148
Darkone
 
Darkone's Avatar
 
Drives: 2011 Camaro LT/RS SIM
Join Date: May 2010
Location: Oman
Posts: 168
Quote:
Originally Posted by fastkevman View Post
I am trying the -2, -4, and 0 right now with the center unhooked and it sounds good at the same or lower volumes than I have been using.

To me it sounds more crisp and I don't hear any crackling like I have been at higher settings and with the center hooked up.
Those settings have no bass! Ive got an ipod hooked up (no equaliser settings enabled on it).

T: +3, Mid: -4, Bass: +6. Volume 18-20. Sounds almost like the Alpine system I had in my old car with these settings
Darkone is offline   Reply With Quote
Old 11-04-2010, 10:19 AM   #149
Rcfiddy1

 
Rcfiddy1's Avatar
 
Drives: 2010 Rally Yellow 2SS/RS #37115
Join Date: Oct 2009
Location: Manalapan, New Jersey
Posts: 1,846
+1 on the speaker plug removal. Took 5 mins. Better stereo seperation for sure.
__________________
Build Thread
ECS Paxton Novi 1500 Blower Black, Alky Control Meth Injection, LS3 conversion, ECS Blower cam, Trunion upgrade, Vigilante 2800 stall, BMR suspension parts, 3.45 rear, Stainless Works LT headers, BnB fusion ZL1 exhaust, Ridetech Coilovers.
Rcfiddy1 is offline   Reply With Quote
Old 11-04-2010, 10:38 AM   #150
Duper
 
Drives: 2011 Camaro 2SS / RS
Join Date: Jul 2010
Location: Pasadena, CA
Posts: 299
Quote:
Originally Posted by Rcfiddy1 View Post
+1 on the speaker plug removal. Took 5 mins. Better stereo separation for sure.

Yeah, have you guys taken a close look at that center speaker? Probably cost BA like $0.99. The frequency range on that thing has got to be really limiting.
__________________
Duper is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
vendors....make a center speaker gauge pod! BlownSS Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum 28 04-05-2013 05:13 PM
Center console different with gauge pack vs. no gauge pack? CasopoliS Cosmetics and Lighting Modification Discussions 28 10-13-2010 10:14 AM
Anyone have an LS3 OE catback exhaust in SE MI they want to get rid of? Russell James USA - Great Lakes 1 05-19-2010 02:40 PM
Need help!! finding a center cap. MRK III Z28 General Automotive + Other Cars Discussion 0 01-27-2009 01:51 PM
Announcing GM Tech Center Fbody Show TAG UR IT Off-topic Discussions 9 08-01-2007 01:20 PM


All times are GMT -5. The time now is 05:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.