Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Grabiak Performance Center
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Regional Forums > International Regions > Middle East

Middle East The Near East

Reply
 
Thread Tools
Old 05-22-2010, 03:50 PM   #1
Camaro_AbuDhabi
It's Roar makes me giggle
 
Drives: Camaro SS2 / RS - 2010
Join Date: May 2010
Location: Abu Dhabi
Posts: 25
Camaro - Abu Dhabi - 12AM - 33C⁰

السلام عليكم

Hello fellow camaro owners !

Got this Beast a little under two weeks ago. Gave my Mercedes CLS to my Parents ... can i say mercedes cls on these boards ? and decided to give german luxury a break and go for US muscle power ! went into the dealership on a Saturday, and by Wednesday night it was mine

Photo taken a few minutes ago outside my home in the city of Abu Dhabi.







Only problem in the almost two weeks i've had this beast of a car is the warning signal you get when one of the tire sensors goes off .... ive been to the dealers , all my tires are in top shape , but they did notify me that the job takes 10 minutes max to fix one of the sensors that was damaged probably during "heavy handling?!"

I have only 1200 kilometers on it so far and i didnt try and accelerate full force yet .... after the first inspection at 1500 i will go faaaaaaaaast
Camaro_AbuDhabi is offline   Reply With Quote
Old 05-22-2010, 04:06 PM   #2
CamaroFreako
KMK
 
CamaroFreako's Avatar
 
Drives: Slow V6 Camaro
Join Date: Jan 2010
Location: kuwait
Posts: 497
gratz dude, hope u enjoy it.
CamaroFreako is offline   Reply With Quote
Old 05-22-2010, 04:13 PM   #3
Camaro_AbuDhabi
It's Roar makes me giggle
 
Drives: Camaro SS2 / RS - 2010
Join Date: May 2010
Location: Abu Dhabi
Posts: 25
Thank you
Camaro_AbuDhabi is offline   Reply With Quote
Old 05-22-2010, 11:17 PM   #4
Cyber Gray
Wind Rider
 
Cyber Gray's Avatar
 
Drives: Black 2SS/RS 2014; JK Wrangler 2011
Join Date: Jan 2010
Location: Muscat
Posts: 2,020
Welcome to the club .

Man it was 43 degrees in Muscat last (NIGHT). Do you have black vent inserts in your Camaro as a standard accessory or did you order them?

I installed mine but for only 24hr, and they started coming out from the heat. Re-installed them again with gum and hope that they will hold longer in this hell
__________________
Im not Gray any more !!
Cyber Gray is offline   Reply With Quote
Old 05-23-2010, 12:29 AM   #5
AlSuwaidi


 
AlSuwaidi's Avatar
 
Drives: BLACK LS3 GCC-Spec
Join Date: Oct 2009
Location: UAE - SHARJAH
Posts: 2,878
congratz.. is it an auto or manual...

the sensors maybe that your just too used to mercedes.. these cars can slip out real easy with not so much accelration in a low gear and trigger the traction control

I used to have an '09 x5 4.8.. and when i moved to the camaro.. in the first month under 'normal acceleration' the traction control saved my car a few times...
AlSuwaidi is offline   Reply With Quote
Old 05-23-2010, 11:43 AM   #6
alssiri

 
alssiri's Avatar
 
Drives: 2012 ZL1 A6
Join Date: Aug 2009
Location: Dubai
Posts: 957
Congrats on the beautifull ride

Ahmad
__________________
2012 ZL1 A6
alssiri is online now   Reply With Quote
Old 05-23-2010, 10:47 PM   #7
Camaro_AbuDhabi
It's Roar makes me giggle
 
Drives: Camaro SS2 / RS - 2010
Join Date: May 2010
Location: Abu Dhabi
Posts: 25
thanks everybody

@cyber gray .... they were installed at the dealership (liberty) in abu dhabi and i am facing no problems with it falling off i would go for UHO glue lol

@alsuwaidi , its an automatic and you might have a point there , ill raise my concerns once im at the dealers this weekend when i reach 1500 kilometers
Camaro_AbuDhabi is offline   Reply With Quote
Old 05-24-2010, 03:36 AM   #8
Cyber Gray
Wind Rider
 
Cyber Gray's Avatar
 
Drives: Black 2SS/RS 2014; JK Wrangler 2011
Join Date: Jan 2010
Location: Muscat
Posts: 2,020
Quote:
Originally Posted by Camaro_AbuDhabi View Post
thanks everybody

@cyber gray .... they were installed at the dealership (liberty) in abu dhabi and i am facing no problems with it falling off i would go for UHO glue lol

@alsuwaidi , its an automatic and you might have a point there , ill raise my concerns once im at the dealers this weekend when i reach 1500 kilometers
Well we are facing a harsh summer weather this time, for almost 3 days now the temp. is around 43 at night and thats why I guess the vents couldnt hold on!

Man, I couldnt even touch them with my fingers because of the heat !!

Hopefully they will hold on with mounting.

I'm facing a similar problem with my Magna Flow exhaust tips, they release too much heat too.

Enjoy the ride.
__________________
Im not Gray any more !!
Cyber Gray is offline   Reply With Quote
Old 05-24-2010, 07:17 AM   #9
Q8Y
 
Q8Y's Avatar
 
Drives: '12 F150
Join Date: Jun 2009
Location: KWT
Posts: 132
Congratz on your car
If you still have a problem with your tire sensors try to recalibrate them that might solve the problem.
put the ignition on battery engine off press menu then scroll until you reach the tire page press set to relearn the horn gonna sound twice and tire learning active message gonna show start with left front tire driver side deflate the tire until you hear a horn then go to front right tire passenger side do the same then rear right and rear left, on the last tire the horn gonna sound twice switch the ignition off inflate the tires to the required pressure found on the door of the driver (mine 36 psi cold tires )switch the ignition on and see the pressure it may take a while before the pressure reappears.
hope that's help I used to have this problem in my silverado even after changing the sensor the message still appears but after doing this problem solved.
__________________
recieved 7-10-09 2010 camaro black 2ss/RS/6m
Q8Y is offline   Reply With Quote
Old 05-24-2010, 07:40 AM   #10
MinnesotaDream
 
MinnesotaDream's Avatar
 
Drives: 2010 RS Inferno Orange
Join Date: May 2010
Location: Minnesota
Posts: 142
How cool to see that car parked in Abu Dhabi!

Awesome in fact! Good luck an have big fun in it!!

__________________

MRT V2 - FOOSE Legends
MinnesotaDream is offline   Reply With Quote
Old 05-24-2010, 01:04 PM   #11
Camaro_AbuDhabi
It's Roar makes me giggle
 
Drives: Camaro SS2 / RS - 2010
Join Date: May 2010
Location: Abu Dhabi
Posts: 25
Quote:
Originally Posted by Q8Y View Post
Congratz on your car
If you still have a problem with your tire sensors try to recalibrate them that might solve the problem.
put the ignition on battery engine off press menu then scroll until you reach the tire page press set to relearn the horn gonna sound twice and tire learning active message gonna show start with left front tire driver side deflate the tire until you hear a horn then go to front right tire passenger side do the same then rear right and rear left, on the last tire the horn gonna sound twice switch the ignition off inflate the tires to the required pressure found on the door of the driver (mine 36 psi cold tires )switch the ignition on and see the pressure it may take a while before the pressure reappears.
hope that's help I used to have this problem in my silverado even after changing the sensor the message still appears but after doing this problem solved.
thanks bro much appreciated ...... yeah im aware of this but the dealer did say i should not do it because it wont help , so lets see if he knew what he was talking about once i get there

@Dream thanks
Camaro_AbuDhabi is offline   Reply With Quote
Old 05-24-2010, 02:35 PM   #12
2010 SSRS



 
2010 SSRS's Avatar
 
Drives: 3 V8 Camaros
Join Date: May 2009
Location: The Ocean State
Posts: 123,978
congrats
__________________
Jannetty Racing JRE Street Package
2010 SSRS is offline   Reply With Quote
Old 05-25-2010, 02:46 PM   #13
BLACK
 
Drives: 2SS/RS BLACK
Join Date: Jun 2009
Location: Sharjah / UAE
Posts: 60
you'll have a lot of fun
__________________
Quote:
Originally Posted by Paperer View Post
If my parents ever ask to drive my car, I throw them the keys.

But if my brother asks, I throw a banana at him.
BLACK is offline   Reply With Quote
Old 12-03-2010, 02:11 PM   #14
Muskles
 
Drives: Camaro 1LT
Join Date: Dec 2010
Location: Dubai
Posts: 1
@ Camaro_AbuDhabi Congrats on bringing BumbleBee home!

I was wondering if you know if modification of the in built radio with a Rear View Camera screen fitting can be done somewhere reliable in the UAE (Im in Dubai) without affecting the dealer warranty.
Muskles is offline   Reply With Quote
Old 12-19-2010, 12:48 PM   #15
Darkone
 
Darkone's Avatar
 
Drives: 2011 Camaro LT/RS SIM
Join Date: May 2010
Location: Oman
Posts: 168
Quote:
Originally Posted by Muskles View Post
@ Camaro_AbuDhabi Congrats on bringing BumbleBee home!

I was wondering if you know if modification of the in built radio with a Rear View Camera screen fitting can be done somewhere reliable in the UAE (Im in Dubai) without affecting the dealer warranty.
Nothing can be done with the stock radio. There are rear-view mirrors with inbuilt screens, im sure ull be able to find them if u look around.
Honestly I think the rear sensors are good enough and give very reliable feedback. No need for rear-view camera.

Also don't worry about warranty. Just inform your service centre about what you're doing to the car. They have to PROVE that the mod u did caused any problem in the car.
Darkone is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
GM unveils Jay Leno Camaro, Camaro Synergy, Camaro Chroma, Camaro Dusk at SEMA irocnroll 5th Gen Camaro SS LS LT General Discussions 101 02-27-2012 12:25 PM
Camaro - Abu Dhabi - 12AM - 33C⁰ Camaro_AbuDhabi Camaro Photos | Spyshots | Video | Media Gallery 7 05-22-2010 04:34 PM
Drag Racing Suspension Kits Info@PeddersUSA.com Suspension / Chassis / Brakes 25 02-21-2010 08:48 PM
Answeres to questions I have stumbled on dieseldave24v 5th Gen Camaro SS LS LT General Discussions 13 02-23-2009 06:56 PM
Chevrolet Camaro Stars On Bin Hamoodah Automotive's Abu Dhabi Show Stand camaro5 5th Gen Camaro SS LS LT General Discussions 9 12-03-2008 08:33 PM


All times are GMT -5. The time now is 10:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.