Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Hines Performance (HPE)
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Members Area > Off-topic Discussions

Off-topic Discussions Discuss any off-topic subjects with other members.

Reply
 
Thread Tools
Old 06-29-2010, 09:24 PM   #1
csjcsj


 
csjcsj's Avatar
 
Drives: 2010 Camaro SS/RS 6spd
Join Date: Sep 2009
Location: Jefferson, Ga
Posts: 4,418
Help! car running erratic

I have a 04GT, Iwas on my way home, stopped at the Motorcycle Shop, needed new tires. Anyways when I started the car and left it started spitin and sputtering. Did it all the way home. Got home took off my K&N CAI filter, cleaned the maf sensor with cleaner for that cleaned the filter, drove down the road , did it again then smoothed out some not running as eratic. Anyone know why this might have happened.
__________________

Last edited by csjcsj; 06-29-2010 at 10:04 PM.
csjcsj is offline   Reply With Quote
Old 06-29-2010, 10:05 PM   #2
csjcsj


 
csjcsj's Avatar
 
Drives: 2010 Camaro SS/RS 6spd
Join Date: Sep 2009
Location: Jefferson, Ga
Posts: 4,418
Anyone!!!!!!!!!!!!!!!!!!
__________________
csjcsj is offline   Reply With Quote
Old 06-30-2010, 12:19 AM   #3
shank0668


 
shank0668's Avatar
 
Drives: 1998 Sahara
Join Date: Feb 2008
Location: Ohio
Posts: 8,573
Send a message via AIM to shank0668
Bump for ya. Not enough gas? Bad sensors?
shank0668 is online now   Reply With Quote
Old 06-30-2010, 01:30 AM   #4
Superman09
Account SNAFU
 
Superman09's Avatar
 
Drives: 2013 Tahoe 79 Scout II
Join Date: Sep 2008
Location: College Station, TX
Posts: 546
did you let your filter oil dry before you drove it if you did oil it. Is your CEL light on could potentially be O2 sensors. Reading too much air coming in and not enough going out or the other way around from a dirty MAF.
__________________
Superman09 is offline   Reply With Quote
Old 06-30-2010, 09:02 PM   #5
csjcsj


 
csjcsj's Avatar
 
Drives: 2010 Camaro SS/RS 6spd
Join Date: Sep 2009
Location: Jefferson, Ga
Posts: 4,418
Problem solved......Fuel Filter!!!!!!!!!!!!!!!!!!!!!!!
__________________
csjcsj is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 Mustang Info (Keep all threads here) RealQuickCamaro General Automotive + Other Cars Discussion 2648 04-15-2010 09:09 PM
Mustangs................ vontivonti 5th Gen Camaro SS LS LT General Discussions 4052 12-21-2009 11:42 PM
Help the Camaro win Motortrend's Championship truth411 5th Gen Camaro SS LS LT General Discussions 56 07-02-2009 06:10 AM
How many Mustang owners will switch? wjones14 Chevy Camaro vs... 39 10-07-2008 12:49 AM


All times are GMT -5. The time now is 04:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.