Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Cam Motion
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Cosmetics and Lighting Modification Discussions

Cosmetics and Lighting Modification Discussions External and Internal cosmetics modifications.

Reply
 
Thread Tools
Old 07-04-2010, 06:17 PM   #1
jagssrsbeast
 
Drives: inferno orange ssrs
Join Date: Jun 2010
Location: RGV
Posts: 87
My engine cover gone bad need helpp please

Ok so im no painter and i tried to paint my v8 engine cover i painted the the smooth silver parts chevy red orange (dupli color engine enamel) with a primer. It look real good after it was done but them i didnt like how the rough black plastic part looked dull so i tried to paint that a gloss black same type of paint. I put the primer on and it came out perfect. So then i tried the gloss black after 30 mins it started shedding and looking all messed up, but in some parts it doesnt look bad I dont know what to do now can anyone please give me some advice I would really appreciate it. thanks
jagssrsbeast is offline   Reply With Quote
Old 07-04-2010, 08:25 PM   #2
Mr_Draco


 
Mr_Draco's Avatar
 
Drives: 2SS/RS
Join Date: Sep 2008
Location: Western North Carolina
Posts: 6,285
Pics please.

If it's what I think it is then it's because you didn't let the primer cure first. Unfortunately for plastics there is a 7-10 day cure time in between colors. If you don't wait this time, when you go to apply the second color the paint will crumple up and look something like snake skin (this is very important if you are using can spray paint). Depending on how bad it is your only real option is to sand it down completely and do it again. This is why there is instructions on the paint can.
Mr_Draco is offline   Reply With Quote
Old 07-05-2010, 10:37 AM   #3
jagssrsbeast
 
Drives: inferno orange ssrs
Join Date: Jun 2010
Location: RGV
Posts: 87
i have a pic i just dont know how to put it up lol
jagssrsbeast is offline   Reply With Quote
Old 07-05-2010, 10:47 AM   #4
Mindz
E.B.A.H.
 
Mindz's Avatar
 
Drives: you wild...
Join Date: Mar 2007
Location: In the happy padded room wearing a jacket that makes me hug myself...
Posts: 18,181
When you go to make a post, hit "go advanced"
On this page towards the bottom, you can find a button called "manage attachments".
Clicking on this brings up a window where you can find the picture on your computer and select it. Then hit the upload button.
Hit "submit post" and you're done. =)

If you need more help, pm me.
__________________
Blue Rush, 2010 SS [Car of the Week 3/22/2010] Traded in on...ZLZBUBB, 2013 ZL1
Mindz is offline   Reply With Quote
Old 07-05-2010, 10:54 AM   #5
Grandeos
Automotive Designer
 
Grandeos's Avatar
 
Drives: 2011 Camaro 2SS/RS (LS3)
Join Date: Jul 2009
Location: Detroit, MI
Posts: 832
Did you sand the surfaces before you started to spray the primer? Sounds like the paint just didnt bond. OR ... perhaps you didnt clean the cover before you started spraying?? IF there was any dirt or oil on the surface, the paint wont adhere, and you will end up with paint either rolling of flaking off.

Pictures will tell us what might have went wrong.
__________________
2011 Camaro 2SS/RS LS3 (SIM/BLK)
Grandeos is offline   Reply With Quote
Old 07-05-2010, 09:40 PM   #6
jagssrsbeast
 
Drives: inferno orange ssrs
Join Date: Jun 2010
Location: RGV
Posts: 87
I didn't sand it but on the smooth silver surface of my v8 cover I painted it orange with the primer and it came out perfect. I didn't try to sand the rough black plastic parts on the sides and middle.
Attached Images
 
jagssrsbeast is offline   Reply With Quote
Old 07-05-2010, 09:41 PM   #7
jagssrsbeast
 
Drives: inferno orange ssrs
Join Date: Jun 2010
Location: RGV
Posts: 87
some parts came out smooth. and it is dirty right now bec its been sitting in the garage bec i haven't know what to do
jagssrsbeast is offline   Reply With Quote
Old 07-06-2010, 06:57 PM   #8
PieManMighty
Manual 6 Speed Tran.
 
PieManMighty's Avatar
 
Drives: 2010 2LT Camaro IOM
Join Date: May 2010
Location: Philly Area (Bristol) PA
Posts: 239
Send a message via AIM to PieManMighty
I bought the kit from Paintscratch.com and it came out perfect, never had a problem. Clean it good.... use an Adhesion Promoter first before applying any primer, basecoat, or clearcoat. Check out my link that says "Covers" in my signature
PieManMighty is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Supercharger / Turbocharger Results (INFO) Thread radz28 Forced Induction - V8 236 Yesterday 04:48 PM
Engine Cover Mod With Lights? summitSS Camaro DIY & HOW-TO instructions & discussions 66 05-14-2014 06:15 PM
Pfadt Race Engineering releases new Camaro V8 Engine Mounts PfadtRacing Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 43 06-07-2011 12:09 PM
ENGINE COVER "SS" RED & WHITE FACTORY GM EMBLEM & POLISHED STAINLESS NAMEPLATE Kirban Performance V8 Bolt-Ons & Tunes 1 05-24-2010 02:06 PM


All times are GMT -5. The time now is 08:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.