Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Emblempros
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 07-05-2010, 03:29 PM   #15
KungFuHamster
 
KungFuHamster's Avatar
 
Drives: Grabber Blue Mustang GT
Join Date: Apr 2010
Location: Fort Worth
Posts: 428
Quote:
Originally Posted by TooCool5 View Post

Are the GM engineers on crack or something?
remember the LT1 cars? opti-spark? id say the habit is hard to kick.
KungFuHamster is offline   Reply With Quote
Old 07-05-2010, 03:40 PM   #16
Number_9

 
Number_9's Avatar
 
Drives: 2010 2SS/RS L99
Join Date: Mar 2009
Location: Trophy Club, TX
Posts: 1,463
Yeah, they are putting in a new windshield as a part of this effort.... and new carpeting and floor mats too. GM is being good about this, great really, it just sucks being without the car for a week.

Quote:
Originally Posted by mfr1950 View Post
I have heard that removing the dash out of the car the windshield can crack on these Camaros, at least you got a new Avalanche to drive!!
__________________


Number_9 is offline   Reply With Quote
Old 07-30-2010, 01:30 PM   #17
welshman
 
welshman's Avatar
 
Drives: 2010 2LT, 98 vette C5, 07 CTS
Join Date: Dec 2009
Location: Barrie Ontario
Posts: 30
Mine goes in next week for exactly same problem
welshman is offline   Reply With Quote
Old 08-09-2010, 10:05 PM   #18
welshman
 
welshman's Avatar
 
Drives: 2010 2LT, 98 vette C5, 07 CTS
Join Date: Dec 2009
Location: Barrie Ontario
Posts: 30
My baby went in today for new heater core
and I have a friggin Impala as a loaner
welshman is offline   Reply With Quote
Old 08-09-2010, 10:28 PM   #19
Number_9

 
Number_9's Avatar
 
Drives: 2010 2SS/RS L99
Join Date: Mar 2009
Location: Trophy Club, TX
Posts: 1,463
I feel your pain, here's hoping it all goes well for you.
__________________


Number_9 is offline   Reply With Quote
Old 08-09-2010, 11:26 PM   #20
Sevn86


 
Sevn86's Avatar
 
Drives: 2010 Camaro 2LT/RS ABM
Join Date: Sep 2009
Location: Sugar Land, TX
Posts: 13,085
Did you take your car to the Dallas location or the Sugar Land location?
__________________
2LT, RS, AT6 ABM, Gray Leather
Quote:
Originally Posted by baclarsen View Post
Dude, you go through cars faster than I go through underware!!
1000 Initial Order 9/14/2009 - Classic Chevy Sugar Land
1100 Order accepted at dealer: 9/15/2009 - NPGV41.
2000 Order accepted by GM: 9/29/2009
3000 Accepted By Production Control: 9/30/2009 - TPW 10/26/09
3100 Sequenced:10/12/09
3300 Scheduled For Production:10/13/09
3400 Broadcast:10/22/09
3800 Produced:10/27/09
4000 Available To Ship:10/28/09
4200 Shipped:10/29/09
5000 Delivered To The Dealer:11/09/09
6000 Delivered To Customer:11/12/09
Sevn86 is offline   Reply With Quote
Old 08-10-2010, 02:17 PM   #21
Number_9

 
Number_9's Avatar
 
Drives: 2010 2SS/RS L99
Join Date: Mar 2009
Location: Trophy Club, TX
Posts: 1,463
Quote:
Originally Posted by Sevn86 View Post
Did you take your car to the Dallas location or the Sugar Land location?
Classic in Grapevine (Dallas).
__________________


Number_9 is offline   Reply With Quote
Old 08-11-2010, 12:21 AM   #22
Sevn86


 
Sevn86's Avatar
 
Drives: 2010 Camaro 2LT/RS ABM
Join Date: Sep 2009
Location: Sugar Land, TX
Posts: 13,085
Quote:
Originally Posted by Number_9 View Post
Classic in Grapevine (Dallas).
O...k cuz I havent had the best luck at the Sugarland location...Im not bashing on them cuz i bought my car from them and everything was great but I just haven't received the service and respect I expected from the service department (maybe cuz im 20 and they dont take my questions or concerns seriously)...at first it was great cuz ive been in for 2 different warranty related issues that they fixed but then when i went in for my first oil change they damaged my rim and gladly replaced it but when i got my car back it had 50 extra miles on it and half a tank of gas was gone (joyride anyone?). Then my second oil change they didnt even add air to my tires and also put in 10w30 instead of 5w30 and i had told them that they had put the wrong oil in last time i was there too (i know it doesn't make much of a difference but still id like them to put what it says on the oil cap)...so this next oil change im gonna go try a different chevy dealership for my service needs and see how that works out...im glad to hear your getting great service at the Dallas location...I know id go back to purchase another car from them but im not so sure if id go in for service though, id rather drive an extra 20 miles for that.
__________________
2LT, RS, AT6 ABM, Gray Leather
Quote:
Originally Posted by baclarsen View Post
Dude, you go through cars faster than I go through underware!!
1000 Initial Order 9/14/2009 - Classic Chevy Sugar Land
1100 Order accepted at dealer: 9/15/2009 - NPGV41.
2000 Order accepted by GM: 9/29/2009
3000 Accepted By Production Control: 9/30/2009 - TPW 10/26/09
3100 Sequenced:10/12/09
3300 Scheduled For Production:10/13/09
3400 Broadcast:10/22/09
3800 Produced:10/27/09
4000 Available To Ship:10/28/09
4200 Shipped:10/29/09
5000 Delivered To The Dealer:11/09/09
6000 Delivered To Customer:11/12/09
Sevn86 is offline   Reply With Quote
Old 08-11-2010, 08:43 AM   #23
toehead93


 
Drives: 2014 2SS/1LE
Join Date: Feb 2007
Location: wpb fl
Posts: 3,100
Well, at least you'll have a new heater core. Mine is nothing but trouble and I just know that as soon as my warranty is gone I'll be spending hundreds of dollars or even into the thousands to have it replaced. I just had my car in yesterday for the fourth time to fix my A/C. The first 3 time was for the gurgliing/bubbling noise, this time the fan level was surging. They weren't able to duplicate the probelm so I'm stuck with it for now. Hopefully it gets a little worse and more consitant so I can take it back. Very frustrating becuase I have 24,000 miles so in 8-10 months I'll be f'd. I wish there was some way to protect myself and hold GM responsible to fix it before the end of my warranty.
__________________
Used Racing Brake 2 Peice Rotors for sale:
http://www.camaro5.com/forums/showthread.php?t=344754

Summit White 2014 2SS 1LE
Recaros, NPP exhaust, Nav
2010 2SS A6 - sold.
toehead93 is offline   Reply With Quote
Old 08-11-2010, 07:16 PM   #24
Number_9

 
Number_9's Avatar
 
Drives: 2010 2SS/RS L99
Join Date: Mar 2009
Location: Trophy Club, TX
Posts: 1,463
Quote:
Originally Posted by toehead93 View Post
Well, at least you'll have a new heater core. Mine is nothing but trouble and I just know that as soon as my warranty is gone I'll be spending hundreds of dollars or even into the thousands to have it replaced. I just had my car in yesterday for the fourth time to fix my A/C. The first 3 time was for the gurgliing/bubbling noise, this time the fan level was surging. They weren't able to duplicate the probelm so I'm stuck with it for now. Hopefully it gets a little worse and more consitant so I can take it back. Very frustrating becuase I have 24,000 miles so in 8-10 months I'll be f'd. I wish there was some way to protect myself and hold GM responsible to fix it before the end of my warranty.
Maybe you can get your dealer/service to note the issue as a potential item, having been in the shop at least once before, and therefore be a little forgiving when (if) it comes time to have the work actually performed...
__________________


Number_9 is offline   Reply With Quote
Old 08-11-2010, 07:22 PM   #25
Mr. Wyndham
I used to be Dragoneye...
 
Mr. Wyndham's Avatar
 
Drives: 2014 1LE...Drove: 2012 ZL1
Join Date: Jan 2007
Location: Buffalo, NY
Posts: 28,002
Send a message via AIM to Mr. Wyndham
Quote:
Originally Posted by Number_9 View Post
Talk about a bummer... the heater core went bad on the EVIL RS last week. It was preceeded by the faint smell of dextron a day or two before, then I noticed the wet carpet on the passenger side floor board. :(

Longer story made short, I took it into Classic Chevy and they are being great about it (I've come to expect no less from these guys.) The worst part is the time for repair, roughly a week as the heater core has to be ordered along with a windshield and carpeting.

To replace it, they have to take out the dash and the front windshield to get to the heater core... and, since the carpeting got soaked with dextron and will never be the same, they have to pull out the seats and replace the all of the carpet/well (it's once big piece.) Ouch!!

I'm driving sound in a huge Avalanche now too, which they had waiting for me when I showed up... It's a really nice truck, had less then 20 miles on it when I got it, but it's a bit different to drive around than the Camaro, and no where near as fast of the line!! Haha. At least I have wheels while I wait...
Sounds like they're taking [or already took] care of you. Happy to hear it, even though it's too bad there was a problem at all.
__________________
"Keep the faith." - - Read Twice Before You Post.
...Anxiously waiting to order a silver "Z"...

Mr. Wyndham is offline   Reply With Quote
Old 08-12-2010, 01:39 PM   #26
Number_9

 
Number_9's Avatar
 
Drives: 2010 2SS/RS L99
Join Date: Mar 2009
Location: Trophy Club, TX
Posts: 1,463
Quote:
Originally Posted by Dragoneye View Post
Sounds like they're taking [or already took] care of you. Happy to hear it, even though it's too bad there was a problem at all.
Definitely. They did a great job, although they didn't replace the carpet as originally planned. Apparently, the carpet is made I'd non-absorbing plastic fibers. I dunno if it is or not, but you can't tell there was an issue do all good.
__________________


Number_9 is offline   Reply With Quote
Old 05-11-2011, 08:38 AM   #27
Moorepheus

 
Drives: 2013 Dodge Charge R/T Plus AWD
Join Date: Jul 2009
Location: Niagara Falls, NY
Posts: 1,307
I know this thread is old, but my Heater Core is going too, I think. Over last weekend, notice smell of anti-freeze when heat on. Told dealer about it, they did a pressure test and came back normal. Also, everything is DRY in the car. They did, however, say they could smell the odor I smell when the heater is on and it smells like the anti-freeze.

With that said, they me that they would have to do the following: windshield has to be removed, along with the entire dash. They also said they would need approval from the area rep first, becuase there is no visible leak inside the car and the carpets are dry.

After thinking about it, I asked the dealer to call the area rep to see if they could get approval to have this repaired. I guess it's a wait and see process now.
Moorepheus is offline   Reply With Quote
Old 05-12-2011, 06:39 PM   #28
TooCool5
Resident Gearhead
 
TooCool5's Avatar
 
Drives: 2010 Camaro 1LS 3.6 LLT V6 325 HP
Join Date: May 2009
Location: TAXED in CT
Posts: 4,055
Yikes, not another one. what is wrong with these heater cores.
__________________
2010 Camaro Auto, Inferno Orange, Titanium Interior, Gearhead Wheels AIRAID CAI
TooCool5 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What song are you listening to right now Muscle Master Off-topic Discussions 6206 Yesterday 08:47 PM
DT Shorty and DT Exhaust Good News Bad News... Synergy SATX Camaro V6 LLT Engine, Exhaust, and Bolt-Ons 21 06-20-2010 09:49 PM
How bad are burnouts? boomskeet Dragstrip and Launch Techniques Discussion 8 04-27-2010 10:10 AM
heater core exploded and the techs screwed it up worse now riverbadboy Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 18 12-16-2009 09:25 PM
bad personal news ChevyNut Off-topic Discussions 4 02-23-2007 11:36 AM


All times are GMT -5. The time now is 11:53 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.