Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
JUICEDMOTORSPORTS
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

View Poll Results: Has something broken under launch control or hard start?
Yes, and the dealer fixed it under warranty 2 28.57%
Yes, and I paid out of pocket for a new stock part 0 0%
Yes, and I paid out of pocket for an aftermarket part 0 0%
No problems here! 5 71.43%
Voters: 7. You may not vote on this poll

Reply
 
Thread Tools
Old 07-28-2010, 08:10 AM   #1
OUTATIME
 
OUTATIME's Avatar
 
Drives: 2010 IOM 2SS/RS
Join Date: Oct 2008
Location: NJ
Posts: 586
For those of you who used launch control or otherwise hard starts . . .

I'm trying to gauge the number of people who have had something break and if they were covered under warranty. I'm not sure if this is some epidemic or if it's just a small group of people.

I'm kind of worried that I might snap an axle or something trying to use launch control so maybe I should beef up the driveline as I go . . . but that voids warranty and it would be really nice to not have to pay out of pocket just to use stock power.
OUTATIME is offline   Reply With Quote
Old 07-28-2010, 08:27 AM   #2
jtzako

 
Drives: 2010 IBM Camaro SS
Join Date: Jun 2007
Location: DFW, Tx
Posts: 1,156
I believe that if you break a stock part using a feature that comes with the car from the factory they'd have to cover it. There is a video of the Corvette team talking about launch mode and how using it does NOT void warranty.. I think it would be the same for this car. Now, if you had a car that was upgraded to the point of those stock parts not being able to handle the stress that might be a different story.
__________________
2010 Camaro SS Imperial Blue | CAI Inc, CAI | Solo Hi Flow Cats | X-Pipe | Backup Camera | PDIM
jtzako is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
6l80 loss of pressure on hard launch parish8 V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) 0 04-13-2010 08:01 PM
Tried out the launch control.... rocketman 12 5th Gen Camaro SS LS LT General Discussions 59 03-16-2010 08:54 PM
Stock Injectors vs Magnuson Kit Injectors Mark-HD Forced Induction - V8 24 01-27-2010 08:04 PM
Transmission output shaft hiller72 Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 267 12-02-2009 08:39 PM
TPS Fault after a hard launch. Any ideas what I can check? 55Designs Wheels and Tires Talk Sponsored by The Tire Rack 2 11-20-2009 08:14 PM


All times are GMT -5. The time now is 06:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.