Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Bigwormgraphix
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis

Suspension / Brakes / Chassis All suspension, brakes and chassis discussions.

Reply
 
Thread Tools
Old 07-28-2010, 03:13 PM   #1
Ex-stang
 
Ex-stang's Avatar
 
Drives: "Sergeant" a 1LT/SIM/RS/CONN/BA/M6
Join Date: Feb 2010
Location: Montreal
Posts: 203
Cant beleive what the guy that installed my springs did!

soo basically 1 month ago i get my springs installed at my local midas shop.
Pick up the car and drive it home, as i get close to my house i hear a loud banging noise..im like ok spring just settled..
last week been getting a bad creaking/squeaking sound coming front front end...
this morning i go buy ramps and load her up on the ramps...i notice a sway-bar end link is unnattached on the right wheel near the top...
Soo i bring it back to the guy and he says `wel replace the whole front sway bar end link it was our mistake`
Im like , ok please elaborate....
he explains to me that when they did the initial install the guy broke the bolt on the upper end link, soo the service manager just told him to weld it on...WTF no wonder it made noise...the big bang i heard was when the weld broke and the end link came apart....
They ordered a new one and will install it this week....
Can you believe they never told me and just welded the dam piece back on !!!!!

Last edited by Ex-stang; 07-28-2010 at 03:14 PM. Reason: spehlink mysteaks
Ex-stang is offline   Reply With Quote
Old 07-28-2010, 03:16 PM   #2
2010 2-Tone


 
2010 2-Tone's Avatar
 
Drives: 2010 RY 2SS with Custom Stripes
Join Date: Mar 2009
Location: Jennings, La.
Posts: 2,287
I would raise some major hell with the OWNER!!!!
__________________

-Custom Stripes, Eibach Drop Springs
-MagnaFlow 3" Catback with X pipe
-ADM CAI-Street Version, SLP 160 T-Stat
-Ragin Racin Custom Tune
-Kooks LT Coated Headers, Heritage Grille
-Barton Short Throw Shifter
-Slotted & Dimpled Rotors
-Powercoated Calipers by Mike
-Hawk Ceramic Pads
-Painted Roof
-Painted Gills & Back Panel
-3-M Clear Bra, AAC Plasma DRL's
404rwhp and 403tq
2010 2-Tone is offline   Reply With Quote
Old 07-28-2010, 03:37 PM   #4
Apex Motorsports

 
Apex Motorsports's Avatar
 
Drives: 2000 Camaro SS
Join Date: Feb 2010
Location: Louisville, Ky.
Posts: 23,100
Wow.
__________________
Apex Motorsports is offline   Reply With Quote
Old 07-28-2010, 03:44 PM   #5
lock

 
lock's Avatar
 
Drives: 11 2SS/RS E-Force Supercharged
Join Date: Apr 2010
Location: Charlotte
Posts: 814
Terrible. Another reason to DIY or just watch them like a hawk.
__________________
11 IOM 2SS/RS E-Force Supercharged. 616 RWHP/578 RWTQ. Click link for my journal!!!


lock is offline   Reply With Quote
Old 07-28-2010, 04:21 PM   #6
Bruce@raymondsperformance
 
Bruce@raymondsperformance's Avatar
 
Drives: 2010 camaro
Join Date: Sep 2009
Location: Indy
Posts: 707
A shop is only as good as their people.
Bruce@raymondsperformance is offline   Reply With Quote
Old 07-28-2010, 04:25 PM   #7
SSOOCH
Camaro SL,UTs
 
SSOOCH's Avatar
 
Drives: 2010 Camaro SS/RS #16429
Join Date: Sep 2006
Location: South Jordan, UT
Posts: 7,430
__________________
SSOOCH is offline   Reply With Quote
Old 07-28-2010, 04:40 PM   #8
busaboy
 
busaboy's Avatar
 
Drives: Black RS/SS M6
Join Date: Jun 2009
Location: TX
Posts: 217
Its stuff like this that give mechanics a bad reputation.
busaboy is offline   Reply With Quote
Old 07-28-2010, 04:42 PM   #9
2010 SSRS



 
2010 SSRS's Avatar
 
Drives: 3 V8 Camaros
Join Date: May 2009
Location: The Ocean State
Posts: 123,978
wow
__________________
Jannetty Racing JRE Street Package
2010 SSRS is offline   Reply With Quote
Old 07-28-2010, 04:56 PM   #10
2SSRS@Gen5diy
Salt & Pepper 2014 Z/28

 
2SSRS@Gen5diy's Avatar
 
Drives: 2010 2SS IOM ,2014 Z/28, 66 Nova
Join Date: Oct 2008
Location: By the lake in AZ
Posts: 11,608
And that why no works on my car, Other the GM for warranty work......
__________________
2SSRS@Gen5diy is offline   Reply With Quote
Old 07-28-2010, 06:04 PM   #11
Info@PeddersUSA.com
 
Info@PeddersUSA.com's Avatar
 
Drives: 5th Gen Rental
Join Date: Aug 2007
Location: New England
Posts: 1,904
Oops! What did they say?

mike
Info@PeddersUSA.com is offline   Reply With Quote
Old 07-28-2010, 06:21 PM   #12
Xmicro_SS
Thank You GM
 
Xmicro_SS's Avatar
 
Drives: Sky Redline & Camaro 2SS/RS
Join Date: Mar 2009
Location: Las Vegas, NV
Posts: 2,894
WOW, why Midas and not your local Chevy dealer??

Thank God you were'nt ripping around a corner at 60+MPH
__________________
ITS HERE! : 2010 Camaro 2SS / 6 Speed Manual (No other way) / Silver Ice Metallic / Inferno Orange Interior Accent / RS Package / Polished Wheels / SOLO MACH X CAT BACK
Xmicro_SS is offline   Reply With Quote
Old 07-28-2010, 06:49 PM   #13
clg_98ta


 
clg_98ta's Avatar
 
Drives: 2010 Camaro 2SS
Join Date: Jan 2010
Location: Austin, TX
Posts: 2,701
Unbelievable... but at least they admitted what they did
__________________
Black 2SS ordered 1/4/2010, received 2/19/2010



clg_98ta is offline   Reply With Quote
Old 07-28-2010, 07:52 PM   #14
JB @ C and L Machine
 
Drives: Ordered 2011
Join Date: Feb 2010
Location: NJ
Posts: 345
Quote:
Originally Posted by Ex-stang View Post
soo basically 1 month ago i get my springs installed at my local midas shop.
Pick up the car and drive it home, as i get close to my house i hear a loud banging noise..im like ok spring just settled..
last week been getting a bad creaking/squeaking sound coming front front end...
this morning i go buy ramps and load her up on the ramps...i notice a sway-bar end link is unnattached on the right wheel near the top...
Soo i bring it back to the guy and he says `wel replace the whole front sway bar end link it was our mistake`
Im like , ok please elaborate....
he explains to me that when they did the initial install the guy broke the bolt on the upper end link, soo the service manager just told him to weld it on...WTF no wonder it made noise...the big bang i heard was when the weld broke and the end link came apart....
They ordered a new one and will install it this week....
Can you believe they never told me and just welded the dam piece back on !!!!!

Why would you let them touch it a 2nd time if they botched it the 1st time???
JB @ C and L Machine is offline   Reply With Quote
Old 07-28-2010, 07:52 PM   #15
JB @ C and L Machine
 
Drives: Ordered 2011
Join Date: Feb 2010
Location: NJ
Posts: 345
Quote:
Originally Posted by 2SSRS View Post
And that why no works on my car, Other the GM for warranty work......


JB @ C and L Machine is offline   Reply With Quote
Old 07-28-2010, 07:58 PM   #16
thesnoopster


 
thesnoopster's Avatar
 
Drives: '10 SIM SS/A6 - '12 SIM Equinox LT
Join Date: Jul 2009
Location: Northern Virginia
Posts: 3,623
damn
__________________
2010 SIM Camaro 1SS/A6

Mods: "93 Octane and a baby seat..." TunedByFrost/EFI Performance,LLC @ PAS "You gotta love me ... or leave me alone"
thesnoopster is offline   Reply With Quote
Old 07-28-2010, 08:02 PM   #17
JProberts

 
Drives: 2SS RJT RS/Sunroof
Join Date: Aug 2009
Location: Washington, DC
Posts: 871
See thats just f'ing crazy....this is the kind of crap that scares me as I have no auto mechanic skills and have to rely on others to work on my car. I Honestly don't think I would trust them with my car again even if they were fixing it for free......who's to say they won't crew something else up!

Damn dude watch those retards like a hawk and get everything in writing in case you find something down the road that was affected and maybe you haven't noticed it yet.
JProberts is offline   Reply With Quote
Old 07-28-2010, 08:19 PM   #18
97one

 
97one's Avatar
 
Drives: 1LT RS w/polished 19"rims
Join Date: Jul 2009
Location: New York
Posts: 929
Quote:
Originally Posted by 2SSRS View Post
And that why no works on my car, Other the GM for warranty work......


Actually for reasons like that and many others nobody ever works on my car period !!

__________________
97one is offline   Reply With Quote
Old 07-28-2010, 08:23 PM   #19
JusticePete
Rebel Leader
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,239
Sorry you had such a terrible experience. If you get down to the USA, feel free to bring your Camaro into any Pedders Dealer. They will do a 28 Point Suspension Inspection to make certain you have no other issues. You can find a Pedders Dealer through this link. http://www.peddersusa.com/dealer-finder
__________________
JusticePete is offline   Reply With Quote
Old 07-28-2010, 08:24 PM   #20
Unique Auto Depot

 
Unique Auto Depot's Avatar
 
Drives: Camaro 2010
Join Date: Jun 2009
Location: Arizona
Posts: 1,205
WOW Unreal
Unique Auto Depot is offline   Reply With Quote
Old 07-28-2010, 09:02 PM   #21
Ex-stang
 
Ex-stang's Avatar
 
Drives: "Sergeant" a 1LT/SIM/RS/CONN/BA/M6
Join Date: Feb 2010
Location: Montreal
Posts: 203
yahh guys i was pissed but they ordered the new sway bar end link and are installing it after that they arent seeing me ever again thats for sure...and dam i wish we had some good suspension shops here in canada ..pedders sounds awesome
Ex-stang is offline   Reply With Quote
Old 07-28-2010, 09:05 PM   #22
PennState
We are...
 
PennState's Avatar
 
Drives: 2007 Mustang GT
Join Date: Jul 2010
Location: NJ/PA
Posts: 38
hey at least there willing to fix it..
__________________

$35 Gets you your very own Custom Car Show Poster
2007 Alloy GT Premium
2006 Black V6 Premium - (R.I.P - 3.20.2010)
2001 Jeep Cherokee Sport - (Sold)
PennState is offline   Reply With Quote
Old 07-28-2010, 09:13 PM   #23
JusticePete
Rebel Leader
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,239
Quote:
Originally Posted by PennState View Post
hey at least there willing to fix it..
I am not sure if the truth in your statement makes me laugh or cry.
__________________
JusticePete is offline   Reply With Quote
Old 07-28-2010, 09:29 PM   #24
Ex-stang
 
Ex-stang's Avatar
 
Drives: "Sergeant" a 1LT/SIM/RS/CONN/BA/M6
Join Date: Feb 2010
Location: Montreal
Posts: 203
i still cant f...ing beleive they welded the dam piece !!!!!!!!!!!!
Ex-stang is offline   Reply With Quote
Old 07-28-2010, 09:38 PM   #25
The_Blur
Moderator, USN
 
The_Blur's Avatar
 
Drives: 6.2L of AWESOME! 2011 L99 2SS
Join Date: Nov 2007
Location: NAS Pensacola
Posts: 14,179
Send a message via AIM to The_Blur
The_Blur is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Installed the H&R springs!!!! kaler Suspension / Brakes / Chassis 28 09-29-2010 07:53 PM
Got my springs and sways........installed.......with VIDEO PQ Suspension / Brakes / Chassis 145 06-08-2010 05:02 PM
springs springs springs ron8879 Suspension / Brakes / Chassis 11 05-24-2010 10:00 PM
installed H&R springs and SS emblem on fenders Hector LS3 Suspension / Brakes / Chassis 9 05-23-2010 09:30 AM
The wait for Hotchkis Springs is over! Hotchkis Suspension / Chassis / Brakes 10 02-06-2010 09:31 PM


All times are GMT -5. The time now is 11:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.