Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com

Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com (https://www.camaro5.com/forums/index.php)
-   Member Car Journals (https://www.camaro5.com/forums/forumdisplay.php?f=50)
-   -   1000WHP+ GT5594 + POWERGLIDE + E85 (https://www.camaro5.com/forums/showthread.php?t=418180)

ttshovel 11-02-2019 06:59 AM

Quote:

Originally Posted by fif_gen_powa (Post 10652848)
Can you show some pics of the limiter install and do you log back pressure with your single turbo setup?

Yeah, I'll snag some pics for you shortly..

I dont log backpressure per say but I use dome pressure to figure that out. Drive pressure is right around 1.6:1 at the 31 psi mark. Which isn't bad at all

ttshovel 11-02-2019 02:51 PM

2 Attachment(s)
Here's pics of the limiters. Plenty of adjustment left either way. Just finished the other side.

ttshovel 11-02-2019 10:00 PM

1 Attachment(s)
Got the diaper all on. Theres 6 straps that hold it on total. 2 on each side, and 2 on the front. Along with a velcro strap to hold it tight to the pan by the flexplate.

I'm a little concerned with how close it is to the flexplate. But I haven't tried to start it yet with it in place.

ttshovel 11-08-2019 11:12 AM

Heard back from the machine shop about the ls2 block I dropped off. Block was already punched. 005 over. Bores looked good so he suggested just put a fresh crosshatch in the bore and sending it. Will be picking that up, getting some main studs, filling it. Then taking it back to make sure the bore didn't distort and for the line bore.

Tomorrow is the track rental. Should have done awesome air being the high is 37 degrees. Worked ok the tune some more and pulled some fuel out of after start and warmup enrichment. Starts way better cold now.

Scaled tune down to make room for 325 kpa(32.6psi) praying it holds together for me and the limiters pan out. Will report back tomorrow

ttshovel 11-09-2019 06:56 PM

3 Attachment(s)
Well she didnt like the extra boost and -1195 DA. Let go around the 600 foot area. Got it home, pulled all the plugs, they look fine, no oil in the coolant, no coolant in the oil. Thinking it just straight up snapped a rod. Will pull apart the next few days

ttshovel 11-11-2019 03:59 PM

4 Attachment(s)
Got it pulled and couldn't find anything wrong with it. Gonna throw it back in and see wtf it is. I jumped the gun by not doing a compression check first. Thinking now that by tripping overboost protection, it left something triggered in the ecm. Gonna throw it back in and get it started. Then pull it back out and start the new build

Tajefe Couple 11-11-2019 09:48 PM

Sux to do all the extra work but in the end seems like fairly good news!
Will be watching for your winter build.

ttshovel 11-14-2019 03:23 PM

Quote:

Originally Posted by Tajefe Couple (Post 10658985)
Sux to do all the extra work but in the end seems like fairly good news!
Will be watching for your winter build.

Thanks man!

Haven't finished buttoning it up yet. Ordered a jegs brand mid plate and motion raceworks front plate with the cutouts for turbo manifolds. Hoping it clears the manifolds! Really dont wanna redo the hotside.

Decided I'm going to leave this 6.0 in it for a while and do the rest of the safety stuff, clean up all the wiring,, and add the boost leash for better boost control over this pid control in ms3.

Looking to get this thing started back up this weekend

ttshovel 11-17-2019 09:31 PM

1 Attachment(s)
Got the thing to fire today. Pulled dash out. Found a tripped fuse for the crank/cam signal. Replaced it and it popped as soon as it had power to it. Traced it to a ground that had a bad connection. Recrimped it, threw a fuse in it, and it fired right up.

Since I'm going to a boost leash and no longer going to use the ms3 boost control. I moved the dome pressure sensor to the intake. Drilled a new hole in the front of the intake for it. It's an aem 5 bar so I should be good forever now.

Will work on motorplating next. Thinking I am going to move the motor back after all.

Neumatic 11-18-2019 03:07 AM

That turbo is just insane. Glad you didn't hurt the motor after all, really impressive it's holding together. Ill have to make it down there to MCR next year to check this thing out in person. Almost makes me want to gut mine....but not quite lol.

ttshovel 11-18-2019 06:46 AM

Quote:

Originally Posted by Neumatic (Post 10662699)
That turbo is just insane. Glad you didn't hurt the motor after all, really impressive it's holding together. Ill have to make it down there to MCR next year to check this thing out in person. Almost makes me want to gut mine....but not quite lol.

Thanks! I'm gonna try to compete in their no preps next season so we will see how that goes!

shibbs 11-19-2019 11:31 AM

Quote:

Originally Posted by ttshovel (Post 10662739)
Thanks! I'm gonna try to compete in their no preps next season so we will see how that goes!

Hopefully you get on 1320 video!

ttshovel 11-19-2019 05:12 PM

Quote:

Originally Posted by shibbs (Post 10663543)
Hopefully you get on 1320 video!

Thanks man. For sure I'll be on the street racing channel/ dnr auto. They are putting on the no preps I will be at!

Pulled the engine harness, gonna pull the trans and motor to cut the firewall. Right now I'm looking at setting it all back 5 inches but I may decide on more after it's all said and done.

ttshovel 11-21-2019 06:51 PM

I've made the decision to sell my current turbo setup to start over. Will be keeping the turbo and mounting it up front and center. A local shop, just starting out, is cutting me a deal. I pay for materials and put their sticker in the back window and they will build the kit for free. No brainer there


All times are GMT -5. The time now is 02:12 PM.

Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.