Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com

Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com (https://www.camaro5.com/forums/index.php)
-   Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum (https://www.camaro5.com/forums/forumdisplay.php?f=29)
-   -   New PDIM Hardware and Software Available! (https://www.camaro5.com/forums/showthread.php?t=108097)

AUS10BMX 12-21-2010 10:54 PM

Quote:

Originally Posted by DisneyEngineer (Post 2658277)
After 3 trips to the dealership this month I finally got my PDIM module upgraded to the latest revision, DA/DX. Even though my car is a 2011 and I got it in Aug it had CC/CE and the popping occurred every min or so. Originally they were going to replace it with the same type from another car but GM TAC had them check the wiring harness for a short first. I tell you it was a little unnerving seeing my dash torn apart to check the wiring. Needless to say no short was found so they sent out a new PDIM out overnight. Can you believe they told the dealership that it was specifically designed to correct the popping/static issue. The dealership commented that GM wasted my time and their time as well by not issuing a bulletin for a known issue! I no longer hear any popping while a song is playing; however, there is a slight pop when changing songs or scrolling through the playlist. That I can live with!!


I have a very early 2010 model, mine says CC/CE. Popping, problems with playlist, no device connected, ect. All the problems everyone is having. I talked to my service manager months ago about it, but I just never bothered with it, got lucky with a old iPod, and it's the only one I can use. iTouch, iPhone4, will only work for about 5 min. I still have popping with my current iPod I'm using...

So here is my question:

Hardware: 20985421 (NEW PDIM)
Dealer installed it, and updated it = DA/DX
Problems went away?


Very close friends with owners/workers at my dealership so they will do anything to help. I've just been waiting to see what others have found out, this has been bothering me for months but I thought there was no help at the time. Will be visiting them soon, and will let you all know what I find out.

SDCamaro10 12-21-2010 11:00 PM

Quote:

Originally Posted by AUS10BMX (Post 2658457)
I have a very early 2010 model, mine says CC/CE. Popping, problems with playlist, no device connected, ect. All the problems everyone is having. I talked to my service manager months ago about it, but I just never bothered with it, got lucky with a old iPod, and it's the only one I can use. iTouch, iPhone4, will only work for about 5 min. I still have popping with my current iPod I'm using...

So here is my question:

Hardware: 20985421 (NEW PDIM)
Dealer installed it, and updated it = DA/DX
Problems went away?

Very close friends with owners/workers at my dealership so they will do anything to help. I've just been waiting to see what others have found out, this has been bothering me for months but I thought there was no help at the time. Will be visiting them soon, and will let you all know what I find out.

Please keep everyone updated with what you find out. The part number you have listed is the newest hardware. Since no one that we know of has installed it yet(or confirmed they have it), we are not sure what software version will be programmed. I can only assume it will come with DA/DX and fix your issues.

KeepItGreasey 12-22-2010 08:25 AM

DA/DX is much better. Even though there are updates on Tis2Web that specifically address the issues of "No Supported Data Found" and only being able to index 2,000 songs instead of 10,000 songs...... my CC/CE does not function properly.

AUS10BMX 12-22-2010 09:04 PM

Quote:

Originally Posted by KeepItGreasey (Post 2659231)
DA/DX is much better. Even though there are updates on Tis2Web that specifically address the issues of "No Supported Data Found" and only being able to index 2,000 songs instead of 10,000 songs...... my CC/CE does not function properly.

So I guess the big question is, how do we find out what part # is the correct one for DA/DX, is it the one stated above?

Next week I'm going to my dealer for sure, and Im gonna get this crap fixed.

1FAST SS 12-22-2010 10:35 PM

Quote:

Originally Posted by AUS10BMX (Post 2661472)
So I guess the big question is, how do we find out what part # is the correct one for DA/DX, is it the one stated above?

Next week I'm going to my dealer for sure, and Im gonna get this crap fixed.

Can you post once you get the info. I am wondering if the new part number is the new version?

AUS10BMX 12-29-2010 09:24 PM

My service manager is looking into it for me, gonna talk to him more about it.

Whats even crappier is a lady just bought a 2011 from them, has the same problem, and the screen has lines going through it, and GM said they don't wanna replace it. BRAND new car, how lame is that.

mcarney 12-29-2010 11:25 PM

Im upgrading my 1ss. so the correct part number for the pdmi is 20985421 ?

ToyotaCamaro 12-30-2010 03:36 AM

After reading this thread, I decided to test the usb port for the current software listing. From my understanding, you plug in the device or usb drive and then press and hold the menu button. In my case, I'm using a standard usb drive. When I plug it in, the screen simply says something like device not supported. I have a '10 2LT delivered last May so I'm certain that its outdated but is there another way to check the software?

Off Topic: I'm new to the idea of software updates, should I be taking my car in for other updates as well? Anything in specific? I'd appreciate a PM to keep this thread on topic. Thanks.

OUR72GTO 12-30-2010 04:21 AM

Wow ....what a cluster F%*k .

How can GM call this a world class car when they have had 18 months to fix this ? What is the point of 500 or more CTF cars and this is still broken.

AUS10BMX 12-30-2010 10:05 AM

Quote:

Originally Posted by ToyotaCamaro (Post 2680640)
After reading this thread, I decided to test the usb port for the current software listing. From my understanding, you plug in the device or usb drive and then press and hold the menu button. In my case, I'm using a standard usb drive. When I plug it in, the screen simply says something like device not supported. I have a '10 2LT delivered last May so I'm certain that its outdated but is there another way to check the software?

Off Topic: I'm new to the idea of software updates, should I be taking my car in for other updates as well? Anything in specific? I'd appreciate a PM to keep this thread on topic. Thanks.

If you take it to the dealership, there is nothing they can do on the spot. This is not a computer update, it is a physical updated piece. What you are describing with your car is correct, I got my car in May of 09' so its a very early model. To find out what model your radio is, just do the following instructions as listed above. Your device has to be working in order for this to show on the screen.

Back to what I found out, it's a matter of convincing GM to pay for it. Pretty lame how they lady who got a brand new 11' with radio problems, and GM want even fix hers.

They damn well will be fixing mine though, haha. This is BS.

Don O 12-30-2010 02:56 PM

1 Attachment(s)
I took mine in today (Selman in Orange) for another reason and since it was there I asked if they could update the SW from version CC to CE. The service manager says they'd take a look it.

When it was done I was pleasantly surprised that they replaced the module with a new one that has the DA HW and DX SW. The service receipt write up states:
"Shorted module diagnosed and replaced multi-media module".

PN 20927509 - Module 9.6.8.0

And it was covered under warranty, no cost. So some dealers are willing to make it right.

Don O

AUS10BMX 12-30-2010 03:41 PM

2 Attachment(s)
Quote:

Originally Posted by Don O (Post 2681984)
I took mine in today (Selman in Orange) for another reason and since it was there I asked if they could update the SW from version CC to CE. The service manager says they'd take a look it.

When it was done I was pleasantly surprised that they replaced the module with a new one that has the DA HW and DX SW. The service receipt write up states:
"Shorted module diagnosed and replaced multi-media module".

PN 20927509 - Module 9.6.8.0

And it was covered under warranty, no cost. So some dealers are willing to make it right.

Don O

Awesome, at least now we know a confirmed part number. I'll be sure to make sure thats the one the dealer puts. Thanks for posting!

Below confirms the 2 part numbers that seem to work so far...
GM PART # 20985421
Attachment 195213
GM PART # 20927509 Conformed by Don O above.
Attachment 195212

2010CamRS 12-30-2010 03:49 PM

Don O, Can I ask if you remember the name of your service writer that you spoke with today?

Don O 12-30-2010 04:17 PM

Quote:

Originally Posted by 2010CamRS (Post 2682203)
Don O, Can I ask if you remember the name of your service writer that you spoke with today?

His name is Matt Baker, nice guy.


All times are GMT -5. The time now is 06:44 PM.

Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.