View Single Post
Old 04-11-2011, 01:46 PM   #223
themossman
Apprehensive Optimist
 
themossman's Avatar
 
Drives: '10 SS/RS SIM
Join Date: Sep 2008
Location: JAX
Posts: 1,383
Well...after digging into the car, I think I owe GM and 'thank you' for the oil pump failure.

I was able to get the oil pump out on Saturday with relatively little incident...however...I noticed that the timing chain tensioner was appeared broken. Sure enough it was broken at both the top and bottom and to my misery the top piece was MIA. After pulling the cam sprocket, I found the missing piece in one of the block voids behind the cam sprocket....PHEW! You can see in one of the pics below that if it had 'plinko'd' a little bit further it would have dropped into the cam shaft.

After realizing that I would need a replacement tensioner...I put the wrenches down and began researching. I had heard of issues with this tensioner before and there's vicious debates about what might cause it's failures. More importantly, I saw additional pictures of other failed tensioners and realized that I was missing a piece....see video below for the 'new' location of said missing piece....

if the oil pump had not failed...I could have had a another issue altogether...

I'll be switching to the LS2 dampner and NOT installing the LS3 tensioner...

Oh...and yes, it turned out the oil pump pressure valve was stuck. :P


Attached Images
   
__________________
Car is for sale --->http://www.camaro5.com/forums/showthread.php?t=158486
Current Summary:
Engine:Phase One-(All work by Vengeance Racing): Custom Cam, AR Headers, ported throttle body, ported intake, custom tune, dual valve springs, hardened push rods, under drive pulley, thermostat, Vararam CAI, C5R timing chain, Melling oil pump catch can, breather, MagnaFlow Sport Axle Back
Suspension: Pfadt Sport Sway Bars, Pfadt drop springs
Other: MGW Shifter, Custom Paint
my build journal ---->http://camaro5.com/forums/showthread.php?t=30057
themossman is offline   Reply With Quote