Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
BORLA
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Marketplace > Members Classifieds - Parts for sale or wanted > ZL1 Parts


Reply
 
Thread Tools
Old 10-06-2017, 09:32 AM   #1
2NASSTY
 
2NASSTY's Avatar
 
Drives: 14' ZL1 96' Impala SS
Join Date: Jan 2012
Location: Clearwater, Fl
Posts: 654
FS:JMS BAP

JMS PowerMAX V2 $350
Full body ZL1 trapped 138 MPH with factory pump and this BAP.
No issues. Very nice piece
Attached Images
  
__________________
14' Crystal Red Tintcoat ZL1 6M, 10.460 at 136.57 MPH
12' Opulent Blue Metallic CTS-V Sedan, 10.690 at 129.60 MPH - SOLD
06' LeMans Blue Metallic Z06, 11.726 at 127.80 MPH Motor - SOLD.
96' Impala SS LTx, 11.397 at 118.10 MPH Motor, 1st stage 10.526 at 127.46 MPH
2NASSTY is offline   Reply With Quote
Old 10-13-2017, 11:12 PM   #2
ZL1_BALDO
 
ZL1_BALDO's Avatar
 
Drives: 2013 ZL1
Join Date: May 2017
Location: CALIFORNIA
Posts: 18
can u run e85 with stock pump and running id1000? using this jms bap?

Last edited by ZL1_BALDO; 10-13-2017 at 11:18 PM. Reason: forget to mention the bap
ZL1_BALDO is offline   Reply With Quote
Old 10-14-2017, 11:36 PM   #3
2NASSTY
 
2NASSTY's Avatar
 
Drives: 14' ZL1 96' Impala SS
Join Date: Jan 2012
Location: Clearwater, Fl
Posts: 654
Yes you can. That was my E85 combo when I was putting down 740/683 with the ET and MPH in my sig. Stock fuel pump, ID1000, JMS BAP.

Car also ran fine with the addition of Meth on the same fuel system set-up putting down 775/707.
__________________
14' Crystal Red Tintcoat ZL1 6M, 10.460 at 136.57 MPH
12' Opulent Blue Metallic CTS-V Sedan, 10.690 at 129.60 MPH - SOLD
06' LeMans Blue Metallic Z06, 11.726 at 127.80 MPH Motor - SOLD.
96' Impala SS LTx, 11.397 at 118.10 MPH Motor, 1st stage 10.526 at 127.46 MPH

Last edited by 2NASSTY; 10-15-2017 at 02:04 PM.
2NASSTY is offline   Reply With Quote
Old 10-14-2017, 11:49 PM   #4
David zeljuan
 
Drives: 2013 zl1
Join Date: Jun 2017
Location: Houston
Posts: 21
Pm?
David zeljuan is offline   Reply With Quote
Old 10-16-2017, 10:02 AM   #5
2NASSTY
 
2NASSTY's Avatar
 
Drives: 14' ZL1 96' Impala SS
Join Date: Jan 2012
Location: Clearwater, Fl
Posts: 654
Quote:
Originally Posted by David zeljuan View Post
Pm?
Yes please do
__________________
14' Crystal Red Tintcoat ZL1 6M, 10.460 at 136.57 MPH
12' Opulent Blue Metallic CTS-V Sedan, 10.690 at 129.60 MPH - SOLD
06' LeMans Blue Metallic Z06, 11.726 at 127.80 MPH Motor - SOLD.
96' Impala SS LTx, 11.397 at 118.10 MPH Motor, 1st stage 10.526 at 127.46 MPH
2NASSTY is offline   Reply With Quote
Old 01-03-2018, 09:18 AM   #6
2NASSTY
 
2NASSTY's Avatar
 
Drives: 14' ZL1 96' Impala SS
Join Date: Jan 2012
Location: Clearwater, Fl
Posts: 654
Bump.
__________________
14' Crystal Red Tintcoat ZL1 6M, 10.460 at 136.57 MPH
12' Opulent Blue Metallic CTS-V Sedan, 10.690 at 129.60 MPH - SOLD
06' LeMans Blue Metallic Z06, 11.726 at 127.80 MPH Motor - SOLD.
96' Impala SS LTx, 11.397 at 118.10 MPH Motor, 1st stage 10.526 at 127.46 MPH
2NASSTY is offline   Reply With Quote
Old 01-03-2018, 03:36 PM   #7
Hellfighter


 
Hellfighter's Avatar
 
Drives: 2013 Black ZL1
Join Date: Mar 2011
Location: Sugar Land/Texas
Posts: 2,275
Where did you place this, is it turned on all the time?
Im running ID850, and changing pulleys , running stock fuel pump, trying to figure out if i need this or a new fuel pump.
__________________
Hellfighter is offline   Reply With Quote
Old 01-03-2018, 06:03 PM   #8
2NASSTY
 
2NASSTY's Avatar
 
Drives: 14' ZL1 96' Impala SS
Join Date: Jan 2012
Location: Clearwater, Fl
Posts: 654
It was mounted in the rear trunk fuse box location. I had the same combo plus e85. Thatís when I needed more fuel.
__________________
14' Crystal Red Tintcoat ZL1 6M, 10.460 at 136.57 MPH
12' Opulent Blue Metallic CTS-V Sedan, 10.690 at 129.60 MPH - SOLD
06' LeMans Blue Metallic Z06, 11.726 at 127.80 MPH Motor - SOLD.
96' Impala SS LTx, 11.397 at 118.10 MPH Motor, 1st stage 10.526 at 127.46 MPH
2NASSTY is offline   Reply With Quote
Old 01-03-2018, 06:09 PM   #9
Hellfighter


 
Hellfighter's Avatar
 
Drives: 2013 Black ZL1
Join Date: Mar 2011
Location: Sugar Land/Texas
Posts: 2,275
Quote:
Originally Posted by 2NASSTY View Post
It was mounted in the rear trunk fuse box location. I had the same combo plus e85. Thatís when I needed more fuel.

Ill be running stock 93 NA FI Gas lol, trying to hit 750 -850 range, on stock pump, is it possible with a BAP or do i need to get something stronger. Just checking my options. Easy install with this?
__________________
Hellfighter is offline   Reply With Quote
Old 01-03-2018, 06:45 PM   #10
2NASSTY
 
2NASSTY's Avatar
 
Drives: 14' ZL1 96' Impala SS
Join Date: Jan 2012
Location: Clearwater, Fl
Posts: 654
I was at 740 - 775 rwhp with the JMS BAP with no issues. Had it installed by Fasterproms with the e85 conversion. 775 bump was with the addition of Meth. JMS and injector duty cycle was still fine at that level.
__________________
14' Crystal Red Tintcoat ZL1 6M, 10.460 at 136.57 MPH
12' Opulent Blue Metallic CTS-V Sedan, 10.690 at 129.60 MPH - SOLD
06' LeMans Blue Metallic Z06, 11.726 at 127.80 MPH Motor - SOLD.
96' Impala SS LTx, 11.397 at 118.10 MPH Motor, 1st stage 10.526 at 127.46 MPH
2NASSTY is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:06 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.