Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vararam
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics


Reply
 
Thread Tools
Old 08-04-2014, 01:34 PM   #15
nxttruck2002
 
Drives: Camaro
Join Date: Aug 2013
Location: Cali
Posts: 200
Quote:
Originally Posted by LIL QIK View Post
Well....I took the car out and it seems like I have absolutely no shocks on the car. Bounces around a good bit and if I hit too much of a crown or dip.....it almost feel like it wants to bottom out. So I look down and neither of the lights for the ride control are on. I'm kind of thinking that the Suspension Control Module has taken a crap on me. Thoughts? I have no DTC's for it or anything. I'm curious as to if the dealership will still honor the suspension part of my warranty. Car is a '13 and has 17k on it....but I've pretty much modded most other aspect of the drivetrain....but haven't touched the suspension yet.... Any chance there are some service writers in here that could shine some light on that? I'm not exactly thrilled about taking my car into the dealer for anything...
Quote:
Originally Posted by davidcroft View Post
I'm a service writer in Houston.. I'd be happy to take a look at it
Quote:
Originally Posted by mlee View Post
He is at Parkway Chevrolet in Tomball

Best service adviser in Houston. Highly recommend.
David at Parkway is top notch and will take GREAT care of your vehicle. I highly recommend him.
nxttruck2002 is offline   Reply With Quote
Old 08-04-2014, 08:59 PM   #16
KLR ZL1
H-Town Camaro Club Member
 
KLR ZL1's Avatar
 
Drives: 17 Hyper Blue Metallic KLR-ZL1
Join Date: May 2009
Location: Pearland Tx.
Posts: 2,035
I also highly recommend David at Parkway. I drive from Pearland just to get great service from him. Sometimes you have to drive a ways to get good service.
__________________
KLR ZL1 is offline   Reply With Quote
Old 08-07-2014, 02:07 PM   #17
LIL QIK
 
LIL QIK's Avatar
 
Drives: 2013 ZL1 Camaro
Join Date: Dec 2010
Location: Manvel, Tx.
Posts: 115
Well...logistics on getting it there were a little of a pain in the butt....but I dropped the car off at Parkway today...
__________________
2013 ZL1 Camaro - Crystal Red Tint / A6
Best so far of 10.50 @ 134.50 w/ 1.58 60' on 20" Nitto NT05R's (Camaro5 Fest - Royal Purple Raceway)
LIL QIK is offline   Reply With Quote
Old 08-07-2014, 02:54 PM   #18
BigBoyBlue
Go NY Giants & NY Rangers
 
BigBoyBlue's Avatar
 
Drives: 2013 ZL1 M6
Join Date: Nov 2013
Location: Maryland
Posts: 782
Quote:
Originally Posted by mlee View Post
No worries with David. He will take care of you. If your mods didn't affect Mag ride then you are good to go. My car is modded and loud as hell and I just had an airbag sensor replaced there with no issues.

Depending on how far and what direction. I may be able to help with a ride if you have to leave it.
Such camaraderie on this site! That is awesome of you to offer him.
__________________
Molon Labe!
BigBoyBlue is offline   Reply With Quote
Old 08-08-2014, 11:19 AM   #19
LIL QIK
 
LIL QIK's Avatar
 
Drives: 2013 ZL1 Camaro
Join Date: Dec 2010
Location: Manvel, Tx.
Posts: 115
Just an update...

Dropped it off to David at Parkway yesterday....and within roughly 3 hours he called me back and told me it was ready. You guys were right....He got it taken care of and without any trouble. It ended up being the suspension control module....and if I'm not mistaken it somehow lost it's programming. Didn't need to get replaced....just needed to be re-programmed. Was a quick fix....but most importantly I had a good feeling about leaving my car with David. Not only because of your recommendations....but he's a very personable guy and easy to talk to. Never got the feeling he was yanking my chain like I do with a lot of other dealers. I just don't trust dealerships with my car in general...lol....But David Croft gave me an easy feeling. Much appreciated....

Thanks to everyone

Dave
__________________
2013 ZL1 Camaro - Crystal Red Tint / A6
Best so far of 10.50 @ 134.50 w/ 1.58 60' on 20" Nitto NT05R's (Camaro5 Fest - Royal Purple Raceway)
LIL QIK is offline   Reply With Quote
Old 08-08-2014, 12:37 PM   #20
SamHouseIII
I Carry!
 
SamHouseIII's Avatar
 
Drives: 2013 CRT ZL1
Join Date: Jul 2011
Location: Fletcher, Ok
Posts: 2,723
Glad to hear all went well!!
__________________
I am a Modaholic!! Please Help!! Do Not feed my addicition....See build...
http://www.camaro5.com/forums/showthread.php?t=261540

From Oklahoma, Join us on Facebook
https://www.facebook.com/groups/okcamaros/

SamHouseIII is offline   Reply With Quote
Old 08-08-2014, 03:42 PM   #21
mlee
CamaroFans.com
 
mlee's Avatar
 
Drives: 2019 Crush ZLE
Join Date: Oct 2008
Location: Conroe, TX
Posts: 36,843
Quote:
Originally Posted by LIL QIK View Post
Just an update...

Dropped it off to David at Parkway yesterday....and within roughly 3 hours he called me back and told me it was ready. You guys were right....He got it taken care of and without any trouble. It ended up being the suspension control module....and if I'm not mistaken it somehow lost it's programming. Didn't need to get replaced....just needed to be re-programmed. Was a quick fix....but most importantly I had a good feeling about leaving my car with David. Not only because of your recommendations....but he's a very personable guy and easy to talk to. Never got the feeling he was yanking my chain like I do with a lot of other dealers. I just don't trust dealerships with my car in general...lol....But David Croft gave me an easy feeling. Much appreciated....

Thanks to everyone

Dave
There you go...

BTW Davids 1LE won "Best 5th Gen" at C5 Fest V..
__________________
mlee is offline   Reply With Quote
Old 06-23-2022, 01:29 PM   #22
GoTopless
 
Drives: 2013 Camaro ZL1 Convertible
Join Date: Sep 2017
Location: midwest
Posts: 43
Had an issue with bouncy rough ride so I took it to my dealership and they said front structs are leaking and the rear shocks are locked up? Would that be a SCM failure or a failure of the shock or both?
2013 Camaro ZL1 Convertible.
Thanks
GoTopless is offline   Reply With Quote
Old 06-23-2022, 02:35 PM   #23
HDRDTD


 
Drives: 2013 Triple Black ZL1 Vert M6 ECF
Join Date: Mar 2011
Location: Trenton, Michigan
Posts: 6,901
On my 2013 ZL1, at around 52,000 miles, I noticed a large wet spot on the floor of the garage under the rear right wheel area.

The car also started riding like it had a very rigid rear suspension once in a while, but not all the time.

It seems that as the mag shocks fail (leak), some people's suspension acts like there is nothing to dampen the suspension (car bounces up and down easily)_while a few peoples suspension acts like it "locks up' as mine did.

I chose to have the rear struts replaced at my local Chevy dealer knowing the cost would be high but it's be done with all genuine GM parts.
The bad news is, because of parts shortages due to Covid, it took 3 1/2 months to locate both rear struts.

After replacing, it's like a brand new car all over again. Well worth the high cost.
HDRDTD is offline   Reply With Quote
Old 06-23-2022, 02:42 PM   #24
GoTopless
 
Drives: 2013 Camaro ZL1 Convertible
Join Date: Sep 2017
Location: midwest
Posts: 43
Yikes 3 mos
GoTopless is offline   Reply With Quote
Old 06-24-2022, 01:56 PM   #25
GoTopless
 
Drives: 2013 Camaro ZL1 Convertible
Join Date: Sep 2017
Location: midwest
Posts: 43
Here is one other question.
To me it seems odd both rears would be locked up solid at the same time. What are the chances that the SCM is either corrupt or has lost its programming even though the dealer is not showing any codes? Did the OP dealership pull codes that lead them to the issue of the SCM had lost its programming and could it be possible that the programming is corrupt?
Thanks
GoTopless is offline   Reply With Quote
Old 06-24-2022, 02:50 PM   #26
Shodown
 
Shodown's Avatar
 
Drives: 2014 ZL1
Join Date: Jun 2009
Location: Tucson, AZ
Posts: 277
Quote:
Originally Posted by GoTopless View Post
Here is one other question.
To me it seems odd both rears would be locked up solid at the same time. What are the chances that the SCM is either corrupt or has lost its programming even though the dealer is not showing any codes? Did the OP dealership pull codes that lead them to the issue of the SCM had lost its programming and could it be possible that the programming is corrupt?
Thanks
Very doubtful. Mag ride suspension is widely to known to leak and fail.

Save yourself the time, money and headache of new mag ride and go coilovers. Way better feel on the road, way cheaper, they're adjustable, and most places have them in stock right now. I have Peddars XA Extreme and they are way better than stock.
__________________
2014 ZL1 M6: Roto Fab Intake, LS3 TB, Long Tube Headers, NPP, Mild 2 Wild, JMS BAP, SMG aux pump, ID 1050X Injectors, DSX Flex Fuel Sensor, 10.00 Lingenfelter Lower Pulley, Killer Chiller, Tuned by Ted at JRE, Peddars XA Extreme coilovers, Mickey Thompson Street S/S on Weld S71s

673 rwhp.
Shodown is offline   Reply With Quote
Old 06-24-2022, 09:47 PM   #27
GoTopless
 
Drives: 2013 Camaro ZL1 Convertible
Join Date: Sep 2017
Location: midwest
Posts: 43
Does anyone know if David still works for Parkway Chevy in Houston?
GoTopless is offline   Reply With Quote
Old 06-25-2022, 08:22 PM   #28
GoTopless
 
Drives: 2013 Camaro ZL1 Convertible
Join Date: Sep 2017
Location: midwest
Posts: 43
Disregard
I found the answer.
Thank You
GoTopless is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:42 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2022, vBulletin Solutions, Inc.