Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vararam
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis


Reply
 
Thread Tools
Old 04-22-2022, 11:51 AM   #1
dma05
 
dma05's Avatar
 
Drives: 2011 Camaro 2SS/RS
Join Date: Jan 2011
Location: Azusa, CA
Posts: 307
StabiliTrak, ABS, and Brake lights all on!

I just finished upgrading all suspension parts (front and rear) on my car and then took it to get an alignment. On the way to the shop, the StabiliTrak light came on and the engine light start flashing.

After the alignment, which was REALLY needed and Robert at Chewerks did an amazing job, the light for StabiliTrak track coming back on. Ribert reset the sensor but itís still happening

Then about 30 mins later, the ABS and Brake light both come on. I pulled over and checked the brake system and it looks fine visually. Now I have all these lights on!

Any thoughts on what it could be? Could I use my HP Tuners to get the info on the issue(s)?

2011 Camaro 2SS M6

Thanks!
Attached Images
 
__________________
Allen
2011 Camaro 2SS/RS
dma05 is offline   Reply With Quote
Old 04-22-2022, 11:59 AM   #2
gtstorey

 
Drives: 2010 Camaro SS2,L99, LSA SC
Join Date: Aug 2017
Location: Huntsville, AL
Posts: 1,412
I don't think HP Tuners can pull anything but P(powertrain) codes. Those codes will be in other modules and will need other readers to pull them. In particular I think all of the ones you need are chassis codes.
gtstorey is offline   Reply With Quote
Old 04-22-2022, 12:20 PM   #3
dma05
 
dma05's Avatar
 
Drives: 2011 Camaro 2SS/RS
Join Date: Jan 2011
Location: Azusa, CA
Posts: 307
I also have a SCT x4 scanner. Would that pull the codes?

Some other notes:
I did replace all the wheel bearing hubs, so those shouldn’t be the issue.
__________________
Allen
2011 Camaro 2SS/RS
dma05 is offline   Reply With Quote
Old 04-22-2022, 12:44 PM   #4
gtstorey

 
Drives: 2010 Camaro SS2,L99, LSA SC
Join Date: Aug 2017
Location: Huntsville, AL
Posts: 1,412
"I also have a SCT x4 scanner. Would that pull the codes?"
Most of the programmers only access the ECM but I don't have any experience with the SCT.

"I did replace all the wheel bearing hubs, so those shouldn’t be the issue."
I would check the wheel speed sensors/wiring. And you could have gotten a defective hub or maybe even the wrong one.

I assume the steering wheel is centered while driving now?

I think I would try and clear it one more time by disconnecting the battery and see what happens.

About the cheapest way the read correct codes for this is a TECH 2 clone.
https://www.vxdiagshop.com/wholesale...r-gm-opel.html
gtstorey is offline   Reply With Quote
Old 04-22-2022, 12:47 PM   #5
dma05
 
dma05's Avatar
 
Drives: 2011 Camaro 2SS/RS
Join Date: Jan 2011
Location: Azusa, CA
Posts: 307
The wheel bearing hubs are the Z28 hubs. I got 4 of them and replaced each hub. This is the part number I ordered: 25954415

I’m guessing a speed sensor may be the issue, but rather guess, I would just like to pull the codes and go from there. Just need a way to do that
__________________
Allen
2011 Camaro 2SS/RS
dma05 is offline   Reply With Quote
Old 04-22-2022, 01:02 PM   #6
gtstorey

 
Drives: 2010 Camaro SS2,L99, LSA SC
Join Date: Aug 2017
Location: Huntsville, AL
Posts: 1,412
This one at Harbor Freight can read ABS codes, but I'm not sure if what you have a problem with would be considered an ABS code or is a chassis code.
https://www.harborfreight.com/automo...der-57663.html
gtstorey is offline   Reply With Quote
Old 04-22-2022, 01:21 PM   #7
gtstorey

 
Drives: 2010 Camaro SS2,L99, LSA SC
Join Date: Aug 2017
Location: Huntsville, AL
Posts: 1,412
Quote:
Originally Posted by adamphelps View Post
recommend vehicle review blogs please
Spam reported
gtstorey is offline   Reply With Quote
Old 04-22-2022, 01:37 PM   #8
dma05
 
dma05's Avatar
 
Drives: 2011 Camaro 2SS/RS
Join Date: Jan 2011
Location: Azusa, CA
Posts: 307
It may be the ABS speed sensors. There were a few times they got pulled by accident and from what I’ve read, they are sensitive.

I’m picking up a scanner from Oreilly’s and also ordering new sensors since they aren’t expensive.
__________________
Allen
2011 Camaro 2SS/RS
dma05 is offline   Reply With Quote
Old 04-22-2022, 03:26 PM   #9
dma05
 
dma05's Avatar
 
Drives: 2011 Camaro 2SS/RS
Join Date: Jan 2011
Location: Azusa, CA
Posts: 307
I ran the scanner and I pulled two codes:

P0308: Cylinder 8 misfire
U2100-00: CAN Bus communication

Not sure why there is a misfire, but I did read this will trip the StabiliTrak system.
Attached Images
  
__________________
Allen
2011 Camaro 2SS/RS
dma05 is offline   Reply With Quote
Old 04-22-2022, 03:36 PM   #10
gtstorey

 
Drives: 2010 Camaro SS2,L99, LSA SC
Join Date: Aug 2017
Location: Huntsville, AL
Posts: 1,412
Does that scanner read chassis (C) codes?
gtstorey is offline   Reply With Quote
Old 04-22-2022, 03:44 PM   #11
dma05
 
dma05's Avatar
 
Drives: 2011 Camaro 2SS/RS
Join Date: Jan 2011
Location: Azusa, CA
Posts: 307
Quote:
Originally Posted by gtstorey View Post
Does that scanner read chassis (C) codes?
No, I donít think so.
__________________
Allen
2011 Camaro 2SS/RS
dma05 is offline   Reply With Quote
Old 04-22-2022, 03:55 PM   #12
dma05
 
dma05's Avatar
 
Drives: 2011 Camaro 2SS/RS
Join Date: Jan 2011
Location: Azusa, CA
Posts: 307
Found the issue!! The spark plug wire for cylinder 8 fell down onto my headers and burned. You can see the white spot in the picture. My wires route differently as I have my coils relocated. Time to make another wire and get it back on the road!
Attached Images
  
__________________
Allen
2011 Camaro 2SS/RS
dma05 is offline   Reply With Quote
Old 04-22-2022, 04:06 PM   #13
gtstorey

 
Drives: 2010 Camaro SS2,L99, LSA SC
Join Date: Aug 2017
Location: Huntsville, AL
Posts: 1,412
Maybe that will resolve all you issues I know that the misfire can trip the stabilitrak light but I don’t know about the others. It may.
gtstorey is offline   Reply With Quote
Old 04-24-2022, 06:58 AM   #14
Joe.G
 
Joe.G's Avatar
 
Drives: 2014 2SS
Join Date: Aug 2021
Location: NY
Posts: 451
Nice find, that scanner should be able to pull ABS Codes. If the sensors are not seated 100% they don't read right, I just went though this on my daughters car. Are the Z/28 Sensors the same as the SS? Just wondering if they need to match the hub or not.
__________________
2SS/RS 6SP GM 3.91/TrueTrac Ashen Grey OEM ZL1 Rims & Side Skirts.ACST4 Splitter/Deflectors NPP Mild To Wild,Resonator Delete, GM Short Throw,Remote Clutch reservoir
Cold Air Inductions CAI, Moroso Catch Can
Stainless Works Ceramic Coated 17/8th HiFlo Cats
SCT X4 Dynosteve
Hotckis 1" Springs and Chassis Max Brace
BMR Adjustable Swaybars,Trailing Arms, Adjustable Toe Rod, LCA and Z28 UCA Bushings Hendrix Solid Cradle Bushings
Pedders Radius Rod Inserts Strut tower brace
Hero Smoked Tail and 3rd Brake Light, Diode Dynamic SL1 Fog Lights
AeroForce Dual gauge/Autometer pillar mount.
Joe.G is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:50 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2022, vBulletin Solutions, Inc.