Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vararam
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 01-06-2012, 02:39 PM   #99
Devilstrip12
 
Devilstrip12's Avatar
 
Drives: 2011 1LT RS imperial blue camaro
Join Date: Oct 2011
Location: Los Angeles
Posts: 108
i had the same problem with my 2011 camaro about a week again. At first i notice a "syrup" like smell when ever i turn the A/C on Thursday of last week when i turn the A/C on smoke started to come out and my entire window got very foggy and "oily" took it to the dealer on Friday. they told me it was the A/C core so 1 week has pass and my car is still in surgery
Devilstrip12 is offline   Reply With Quote
Old 01-06-2012, 10:03 PM   #100
ss eleanor
SS Eleanor
 
ss eleanor's Avatar
 
Drives: 2010 RS/2SS Camaro
Join Date: Oct 2011
Location: Calina Tx
Posts: 782
Well I got my car back...... They replaced the two heater hoses going to the heatercore. they pressure washed under the car and engine bay. They said they test drove the car, well I got home and I can still smell the oil like burning in the cab.. I can only smell it when the car comes to a stop not as your driving. I jacked the car up and tried to find any leaks of any fluid. Nothing but that fn smell is driving me crazy..I called the dealer and they said drive it threw the weekend and see if it goes away.. I know it wont go away. This bites I just want it to stop.
ss eleanor is offline   Reply With Quote
Old 01-08-2012, 01:50 PM   #101
USMC85
Si Vis Pacem, Para Bellum
 
USMC85's Avatar
 
Drives: 2010 Camaro 2SS
Join Date: Apr 2010
Location: Connecticut
Posts: 86
I brought my car in yesterday. I told the dealer the heater core was leaking and need to be replaced. They told me they would look to see what was causing the problem. (I was right) I even let them know that I was concerned because I normally do my own maintenanceI and dn't trust others with my car. They promised to take care of my "Baby." Later when I returned to find out what they had discovered I saw a magazine sitting on top of the roof. When the manager came over to talk to me he spotted the magazine and removed it. As he entered the office all I could say was, "I don't even put things on the paint of my car, this is a perfect example of why I don't want people touching my car." But what am I going to do? No respect other people things.
I was promised the work would be completed by Tuesday. We will see. As picky as I am about my car’s appearance if I can notice the work I wouldn’t accept it. When provoked, I can be a miserable SOB. Let's hope for the best.
USMC85 is offline   Reply With Quote
Old 01-08-2012, 02:15 PM   #102
~Stacy~


 
~Stacy~'s Avatar
 
Drives: 14 camaro 16 sentra
Join Date: Jan 2010
Location: Stevens Point, WI
Posts: 5,014
Quote:
Originally Posted by ss eleanor View Post
Well I got my car back...... They replaced the two heater hoses going to the heatercore. they pressure washed under the car and engine bay. They said they test drove the car, well I got home and I can still smell the oil like burning in the cab.. I can only smell it when the car comes to a stop not as your driving. I jacked the car up and tried to find any leaks of any fluid. Nothing but that fn smell is driving me crazy..I called the dealer and they said drive it threw the weekend and see if it goes away.. I know it wont go away. This bites I just want it to stop.
I had the smell in my camaro for close to 2 months after my heater core blew up:( It eventually went away
~Stacy~ is offline   Reply With Quote
Old 01-09-2012, 07:42 PM   #103
GUMBALL
 
Drives: 2010 Camaro 1SS M6
Join Date: May 2010
Location: Baton Rouge, LA
Posts: 19
Hello, Yet another 2010 SS that just started to smell of coolant when the heat is on. Using the heater is a rare event in Louisiana so I don't know how long it's been happening. At 60,000 miles, my carpet is still dry. Not looking forward to the dealer visit. There must be a way to just bypass the heater core for now. Thanks for all the posts. I've learned a lot.
GUMBALL is offline   Reply With Quote
Old 01-10-2012, 03:33 PM   #104
ssummit camaro

 
ssummit camaro's Avatar
 
Drives: 2013 1LE on order TPW 12/31
Join Date: Jan 2010
Location: El Paso, Texas
Posts: 883
you could disconnect the hoses that lead to the water pump and block them off or disconnect from the heater core and put a u fitting to keep water circulating.
__________________
ssummit camaro is offline   Reply With Quote
Old 01-17-2012, 03:51 PM   #105
maverick12
 
Drives: 2010 camaro rs v6
Join Date: Dec 2011
Location: myrtle beach
Posts: 1
With all the heater core problems out there. Do you think they have a recall?
maverick12 is offline   Reply With Quote
Old 01-18-2012, 11:49 AM   #106
buzzy56
buzzy56
 
buzzy56's Avatar
 
Drives: 2ss summit white L99
Join Date: Nov 2009
Location: paradise
Posts: 1,114
WHY ?

Quote:
Originally Posted by maverick12 View Post
With all the heater core problems out there. Do you think they have a recall?
Why would they do that when they can wait for each individual failure & not absorb such a big hit all at once.
I wish they would . The thought of this failure in the future on my dime haunts me also.
__________________
OLD SCHOOL / NEW SCHOOL COOL
buzzy56 is offline   Reply With Quote
Old 01-26-2012, 07:24 AM   #107
Stark
 
Stark's Avatar
 
Drives: fair to good
Join Date: Mar 2010
Location: Douglasville,Ga.
Posts: 545
Looks like my heater core is bad as well.:(

About 3 weeks ago i drove my car to work ( not my DD ), so driving home, i turn off on my exit and the dash lights up with "a/c is turning off" "Overheating" and my temp gauge is moving quickly to the right. So i pull into a strip mall and turn the car off. I open the hood, and see this...

My a/c belt has come apart, so i let the car cool off for an hour so i can drive the rest of the way to the house ( 0.9 mile )
I get home and look over the belt real good and find this...

As the a/c belt was turning to shreds, to took a few chunks out of my drive belt.
Then my neighbor walks over, gets the story, then asks, "hey, what's that?"

I check my coolant level, fine.
I check my intercooler level, fine.
So i jack up the car to find coolant leaking off the trans...



So i think about it and figure i have a hose clamp loose at the back of the intercooler (under the blower ) and it's dripping down the bell housing to the lowest point on the trans.

See those two brass fittings in the very back? That's where the intercooler hoses go, so i figured i was gonna be pulling my blower off.

But first i wanted to fix the belts.


So i install my new a/c belt, and my new drive belt.
Test drive the car around the neighborhood , no problem.
Car sits for a week.
I call my tuner John Lee at Atlanta Performance and Fabrication and ask him if i can pull the blower and replace the rubber lines with some nice SS lines with -AN fittings, he says sure, drive by next week and we'll look at it.
So yesterday i drive the car to my Dentist, within four minutes of leaving, my car starts to overheat again and i start getting coolant "misting" from the pass side vents, and drops of coolant on the pass floorboard.
So i let the car cool off for an hour, then drive to John's shop.
He puts pressure on the radiator system, and gets the car up on the lift, sure enough, coolant is leaking from right above the bell housing. He take the glove box out, and you can see the heater core, with coolant stains everywhere.

So John cuts a short hose, pulls the heater core lines off the water pump, loops the short hose, air vacs the system, adds coolant, and fires the car up.
NO MORE OVER HEATING!
So now i've got to call the dealer and talk about warranty work on the heater core. This should be fun.
Since they have to pull my dash and windshield, maybe now is a good time to upgrade to HUD....

Sorry for the long rant....
oh yeah, John also figured out my drive belt was a touch too long, so the belt number should be
1055k6 for a stock 4" pulley.
Attached Images
 

Last edited by Stark; 01-26-2012 at 05:08 PM. Reason: typo
Stark is offline   Reply With Quote
Old 04-29-2012, 11:26 PM   #108
Sarge742
 
Drives: 2010 Victory Red RS/2LT
Join Date: Sep 2011
Location: Henderson, NV
Posts: 4
The heater core in my 2010 RS also went bad just this week. The first thing that tipped me off was the windshield fogging up, then drips of hot liquid from under the glove box, then a small puddle of red liquid on the garage floor. They told me same thing about removing/replacing the windshield. I just went over 10,000 miles so this is obviously a manufacturer defect. So far Henderson Chevy has been treating me well saying that it could take 2 weeks to get her back. At least they put me in an Equinox during the wait.
Sarge742 is offline   Reply With Quote
Old 05-01-2012, 11:02 AM   #109
cbuchak2000
 
cbuchak2000's Avatar
 
Drives: 2011 Triple Black 2SS 6spd Vert,
Join Date: Aug 2011
Location: Waterford, WI
Posts: 64
Mine went bad last week on a 2011 ss with HUD. Waiting for new windshield. At least you got an equinox.....they gave me a stripped out Cruze!
cbuchak2000 is offline   Reply With Quote
Old 05-01-2012, 11:08 AM   #110
DarkFox1
 
DarkFox1's Avatar
 
Drives: 2012 2SS A6
Join Date: Mar 2012
Location: Douglasville GA
Posts: 647
Does anyone know if this is an issue with 2012s? I heard about this about 2 days after buying my car and its made me a little hesitant to do any mods that may void the warranty (tune etc.) The labor costs of this out of warranty would be in the thousands.
DarkFox1 is offline   Reply With Quote
Old 05-01-2012, 06:09 PM   #111
cbuchak2000
 
cbuchak2000's Avatar
 
Drives: 2011 Triple Black 2SS 6spd Vert,
Join Date: Aug 2011
Location: Waterford, WI
Posts: 64
I can tell you that my dealership started to give me a hassle about the warranty because of the headers on my car. I said its fine and i'd take it to another local dealership and immediately they said it wasn't a problem they'd fix it. I have headers, cat back, and a tune. In the end after discussing it with the service manager he said that GM would not cover any issues associated with the tune or headers (obviously) but all other parts of the warranty would be valid.
cbuchak2000 is offline   Reply With Quote
Old 05-01-2012, 07:42 PM   #112
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 9,328
Hello DarkFox, unfortunately I haven't heard of this happening to a 2012 model Camaro so I wouldn't know personally. I'll try to keep my ear to the ground on this one and keep you posted. Have good day!

Jeff Morris, Chevrolet Customer Service
Chevrolet Customer Svc is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What song are you listening to right now Muscle Master Off-topic Discussions 6418 05-24-2018 08:57 AM
DT Shorty and DT Exhaust Good News Bad News... Synergy SATX Camaro V6 LLT Engine, Exhaust, and Bolt-Ons 21 06-20-2010 09:49 PM
How bad are burnouts? boomskeet Dragstrip and Launch Techniques Discussion 8 04-27-2010 10:10 AM
heater core exploded and the techs screwed it up worse now riverbadboy Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 18 12-16-2009 09:25 PM
bad personal news ChevyNut Off-topic Discussions 4 02-23-2007 11:36 AM


All times are GMT -5. The time now is 03:17 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.