Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Roto-Fab
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons


Reply
 
Thread Tools
Old 06-09-2021, 05:54 PM   #1
Nutro


 
Nutro's Avatar
 
Drives: 2011 2SS Synergy Green
Join Date: Nov 2011
Location: Austin, Texas
Posts: 3,664
Did I just blow up my motor?

2011 L99 car. I pulled the supercharger off and installed a stock LS3 intake. Got it all buttoned up. Went to drive it today around the neighborhood. I made it about a 1/3 mile and the dash lit up, started making a clanking noise and went into limp mode. Stabiltrak, check engine etc. I got it home and googled the codes.

P2127
P0306
P0122
P0223

I had the ECM bench tuned (My stock tune) but with Longtubes and no cats) but I forgot to tell the tuner that I have a ZL1 fuel pump installed as well (Not sure if that matters)

I was sitting here wanting to cry and realized I forgot I had an LS2 throttle body installed on that intake when it was on my storage rack. I went outside and pulled the airbox off and yep it's an LS2 throttle body. It's obviously tuned for the stock LS3/L99 throttle body.

Would that cause this kind of carnage?
__________________
L99 With a Maggie
Nutro is offline   Reply With Quote
Old 06-09-2021, 11:39 PM   #2
InFiD3ViL


 
InFiD3ViL's Avatar
 
Drives: 2010 CGM 2SS/RS LS3 Swapped A6
Join Date: Sep 2016
Location: Spring Hill, FL
Posts: 4,191
Are you sure it's internal engine noise? Is it possible you dropped a tool or anything down one of the ports when the intake was off? These engines can make some awful noise when misfiring, so hopefully that's part of what you are hearing. Do you have an LS3 style TB to test with?

Just curious, why did you pull the blower?
__________________
2010 CGM Camaro 2SS LS3 Swapped A6 - GPI LS3 SS1 .647/.638, (224/237, 112 +4) on CamMotion 8620 core, BTR Platinum .660" Dual Spring kit w/titanium retainers, CHE bronze trunnion upgrade, stock heads milled @ .015, Melling HV 10296 oil pump, TSP 1-7/8" long tube headers (W/Catless Off-road Pipes), FlowMaster Outlaw axle back/X-Pipe, Stage 2 Ported Throttle Body, Vararam OTR CAI, Mike Norris Gen 2 catch can + GM 1LE clean side separator, 160º thermostat - Megan Racing adjustable coilovers (lowered 1.75"), MRR M017 10/11" wheels - Tuned by Ryan @ GPI via HP Tuners
InFiD3ViL is offline   Reply With Quote
Old 06-10-2021, 07:30 AM   #3
Greenhornet2

 
Greenhornet2's Avatar
 
Drives: 2011 Camaro 2SS LS3 Whipple
Join Date: May 2019
Location: Connecticut
Posts: 1,871
Highly doubt you blew it up by having the wrong throttle body on and not beating on it, if you only made is 1/3 a mile were you just driving it normal? Get the correct throttle body on it and try again.
__________________
Whipple 2.9 CAI ID1050x injectors ZL1 Pump JRE FPCM JMS Voltage booster JRE Rough Idle blower cam BTR .660 springs CHE trunnion kit 1 7/8 Speed Engineering Borla Atak JRE scoop 1.5" lowering springs BMR trailing arms and toe links Cradle inserts 704WHP 603WTQ 93 octane
Greenhornet2 is offline   Reply With Quote
Old 06-10-2021, 07:59 AM   #4
BluePhoenix


 
BluePhoenix's Avatar
 
Drives: ABM# 1878
Join Date: Jul 2013
Location: Hanover, PA
Posts: 3,051
Quote:
Originally Posted by Greenhornet2 View Post
Highly doubt you blew it up by having the wrong throttle body on and not beating on it, if you only made is 1/3 a mile were you just driving it normal? Get the correct throttle body on it and try again.
I agree with this thought and I would certainly do this first.

Other thing which may be irrelevant if it’s the same LS3 intake that initially came off your car but did you replace the gaskets on the intake with new gaskets before reinstalling? Just to make sure you don’t have a vacuum leak where the gaskets aren’t sealing properly. I’m probably totally wrong on that thought but just something to throw out there.
__________________
2010 Camaro 2SS/RS, L99/A6, ABM w/ White Rally Stripes. ABM# 1878. Mods to come!

2021 GMC Sierra 1500 CC Elevation 5.3, Quiksilver Metallic
BluePhoenix is offline   Reply With Quote
Old 06-10-2021, 08:23 AM   #5
CamaroCracka

 
CamaroCracka's Avatar
 
Drives: 2010 Turbo LS3
Join Date: Dec 2009
Location: Palm Bay, FL
Posts: 1,849
When I put my ported TB on years ago, I got on it and it went straight to limp mode, so the ECM seeing something it is not expecting in relation to the MAF and RPM can certainly put it in limp mode.
__________________
On3 kit with downpipe cutout, CTR 76/75, CompCam 239/251 620/632 122+4, and meth. 712whp@5790 717tq@4450 w/15psi boost. Z28 suspension.
CamaroCracka is offline   Reply With Quote
Old 06-10-2021, 08:25 AM   #6
Badbubba
GrINned & JUICEd
 
Badbubba's Avatar
 
Drives: 15STI, 10Expy, 10 2SS/RS M6, 47KB1
Join Date: Nov 2009
Location: Pittsburgh, PA
Posts: 1,086
Did you change the injectors? If larger injectors were installed with the supercharger, most likely, then chances are you were dumping a lot of fuel into the cylinders.
__________________
N.O. Plate(dedicated fuel tank, progressive, fuel hose upgrade, remote opener, heater, console switches), LNC2000, CTAP, ARH 1 7/8" LTs/gutted cats/X pipe/mufflers, Jet Hot coated LTs, JRE SCT Tune, CAI, Scoop, Rx Catch Can, Gates heater hose relocation, Remote clutch & auto brake res, Metco loop, Momentum Tunnel Brace, TSW Nurb 18" 555 & 05, Pfadt trailing arms & toe rods, Autometer WB, Fesler Pillar Pod, LED strips (int), Lloyds floor & trunk mats, LED DRL/front turn & license plate, DRL harness, VLEDs tail lights, Plasticoat Bowties. Ord: Oct 5, 2009 Rec: Nov 19, 2009 13.17@112.6 stock
Badbubba is offline   Reply With Quote
Old 06-10-2021, 09:46 AM   #7
Nutro


 
Nutro's Avatar
 
Drives: 2011 2SS Synergy Green
Join Date: Nov 2011
Location: Austin, Texas
Posts: 3,664
I did not replace the intake gaskets. They looked good at first glance so I just went with it. The stock injectors were still installed in the LS3 intake. I'm wondering now if the number 6 injector was clogged or something from sitting.
__________________
L99 With a Maggie
Nutro is offline   Reply With Quote
Old 06-10-2021, 11:50 AM   #8
Nutro


 
Nutro's Avatar
 
Drives: 2011 2SS Synergy Green
Join Date: Nov 2011
Location: Austin, Texas
Posts: 3,664
Pulled the injector harness and notice some slight discoloration on all of them. I checked that everything was connected and tight. Pulled the plug and it looks ok. Pulled the valve cover and nest I can tell, the springs are all intact and rockers are tight.
Attached Images
   
__________________
L99 With a Maggie
Nutro is offline   Reply With Quote
Old 06-10-2021, 07:45 PM   #9
InFiD3ViL


 
InFiD3ViL's Avatar
 
Drives: 2010 CGM 2SS/RS LS3 Swapped A6
Join Date: Sep 2016
Location: Spring Hill, FL
Posts: 4,191
Whatever you do, get some compressed air and blow the fuzz and shat out of those heads before you bolt the valve covers on. Is that the engine bay insulation in there? (3rd and 4th rocker form the left)
__________________
2010 CGM Camaro 2SS LS3 Swapped A6 - GPI LS3 SS1 .647/.638, (224/237, 112 +4) on CamMotion 8620 core, BTR Platinum .660" Dual Spring kit w/titanium retainers, CHE bronze trunnion upgrade, stock heads milled @ .015, Melling HV 10296 oil pump, TSP 1-7/8" long tube headers (W/Catless Off-road Pipes), FlowMaster Outlaw axle back/X-Pipe, Stage 2 Ported Throttle Body, Vararam OTR CAI, Mike Norris Gen 2 catch can + GM 1LE clean side separator, 160º thermostat - Megan Racing adjustable coilovers (lowered 1.75"), MRR M017 10/11" wheels - Tuned by Ryan @ GPI via HP Tuners
InFiD3ViL is offline   Reply With Quote
Old 06-10-2021, 08:17 PM   #10
Nutro


 
Nutro's Avatar
 
Drives: 2011 2SS Synergy Green
Join Date: Nov 2011
Location: Austin, Texas
Posts: 3,664
Quote:
Originally Posted by InFiD3ViL View Post
Whatever you do, get some compressed air and blow the fuzz and shat out of those heads before you bolt the valve covers on. Is that the engine bay insulation in there? (3rd and 4th rocker form the left)
Oh I absolutely will. I'm usually meticulous when it comes to this stuff. My father was helping me earlier and I think the firewall mat stuff landed there. I saw it after I took the pics and got the compressed air, shop-vac and towels and cleaned it all up.

I ordered an inspection camera today. It will be here tomorrow. I'm going to look through the spark plug hole hopefully and hope I don't see any foreign objects in the cylinder.
__________________
L99 With a Maggie
Nutro is offline   Reply With Quote
Old 06-12-2021, 11:43 AM   #11
lemontwist

 
lemontwist's Avatar
 
Drives: 12 2SS/RS L99,11 2SS/RS LS3totaled
Join Date: Jun 2019
Location: mooresville nc
Posts: 996
is there a difference between the L99 and LS3 intake??
lemontwist is offline   Reply With Quote
Old 06-12-2021, 12:05 PM   #12
George-CZ

 
George-CZ's Avatar
 
Drives: 2010 2SS LS3 and 1978 STROKER 383
Join Date: Feb 2018
Location: Czech Republic
Posts: 850
Quote:
Originally Posted by lemontwist View Post
is there a difference between the L99 and LS3 intake??
No.
It is same intake.
__________________
My life is a constant struggle with Camaro.

K&N Typhoon CAI, Stainless Power longtubes, high flow cats, modified Ragazzon High Performance axle back, Soler Performance ported throttle body, Soler Performance throttle controller, RAM clutch adjuster, modified LS7 clutch kit, Tick Performance billet bearing support, Tick Performance remote bleeder, separate clutch reservoir, BMR trailing arms, BMR toe rods, Pedders Suspension cradle bushing inserts, OEM strut tower brace, oil catch can, modified Hurst T-handle shifter, 20mm wheel spacers, DBA brakes, tune from RDP Motorsport.
George-CZ is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:45 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.