Due to a technical issue, all posts made over the past 24-48 hours have been lost. We sincerely apologize for this!!!
 
Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
JUICEDMOTORSPORTS
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > 5th Gen Camaro SS LS LT General Discussions


Reply
 
Thread Tools
Old 09-07-2010, 06:51 AM   #15
Scott@Bjorn3D


 
Scott@Bjorn3D's Avatar
 
Drives: Kami, 2013 2SS LS3 Luvin
Join Date: Oct 2008
Location: Eufaula, Alabama
Posts: 6,419
Send a message via MSN to Scott@Bjorn3D
I could be cleaning it under the flourecents in the garage that I am finding all these issues. I just had all new bulbs put in and my car has alot of dirt in the paint. Oh well fired a note off to GM they nice guy that helped us get the car when Steph was sick. Will do what he tells me.
Scott@Bjorn3D is offline   Reply With Quote
Old 09-07-2010, 07:40 AM   #16
phenixdragon

 
Drives: 2010 Camaro SS
Join Date: Mar 2010
Location: Seattle, WA
Posts: 781
I use FW1 waterless. Water never touches my baby. since I have a new bumper with clear guard on it, no imperfections yet. But once there is one somewhere I will be a bit bummed.
phenixdragon is offline   Reply With Quote
Old 09-07-2010, 09:26 AM   #17
PieNsky

 
PieNsky's Avatar
 
Drives: Victory Red 1LS
Join Date: Nov 2008
Location: Louisville,KY
Posts: 1,913
There is a lot of dirt that could have been polished out. What surprised me, they were in A rank areas, top of hood, fenders, A pillar. Don't want to freak anyone out but go out and look in the top outside corners around your headlight openings. You will have to bend down but it is so thin, you will see the black plastic. Would be very noticeable on the light colored Camaros. May no longer be an issue.
PieNsky is offline   Reply With Quote
Old 09-07-2010, 09:47 AM   #18
wylde1
I am the Stig
 
wylde1's Avatar
 
Drives: Black w/ IOM stripe 1SS
Join Date: Jan 2010
Location: Saskatoon, SK, CAN
Posts: 1,312
you know what they say. Take a good look and lots of pictures the day you pick up your car from the dealer... because it'll NEVER look that good again.

I'm noticing a few little white specs in my stripes lately, from what I can only assume is rocks hitting the vinyl. that part sucks a bit, but other than that no paint issues to speak of. Mines black though.
__________________
2010 Camaro - 1SS, Black w/ Orange stripes
wylde1 is offline   Reply With Quote
Old 09-07-2010, 10:30 AM   #19
Crowley
Okie doke
 
Crowley's Avatar
 
Drives: 2012 GT500
Join Date: Sep 2008
Location: McKinney Texas
Posts: 3,569
Every time I wash and wipe down the car .. yes ... this has the worst paint job on a new car I have ever had ...

Crowley
__________________
Crowley is offline   Reply With Quote
Old 09-07-2010, 11:29 AM   #20
ga0358

 
ga0358's Avatar
 
Drives: 2010 ABM LS
Join Date: Jan 2010
Location: Acworth, Georgia
Posts: 935
I've been washing mine about once a week, and invariably there are new dings and hair-line scratches every time due to my long commute, and the road construction going on everywhere in my neighborhood....but using the Adams method for car washing, polishing and scratch removal, I keep her looking showroom beautiful!! I never knew there was a proper way to wash a car, but now that I do it, I'm able to keep her looking new..It's a lotta work but worth it!!
ga0358 is offline   Reply With Quote
Old 09-07-2010, 11:33 AM   #21
RickyTheStorm
 
Drives: '10 Camaro 2SS,04 Colorado,06 ZX6R
Join Date: May 2008
Location: Chambersburg, PA
Posts: 524
Somewhat early build here - 5/22/09 - and no paint issues except rock chips in bumper and rock ships on rear quarter panels - should have used the 3m protective coat but too late now.
__________________
Vararam CAI, ARH Headers, Flowmaster Exhaust, Nitto NT555Rs, Custom CAM and Tune - 11.981 @ 116.27



IOM - 2SS/RS - Auto - IAP - Sunroof - Ordered 10/13 (#7 at dealer)
3000(accepted to production ): 4/19/09
3300 (scheduled for prod ): 5/11/09
3400 (broadcast ): 5/16/09
3800 (produced ): 5/22/09
4150 (invoiced ): 6/01/09
4200 (shipped ): 6/01/09
5000 (at dealer ): 6/12/09
6000 (delivery to me ): 6/12/09
RickyTheStorm is offline   Reply With Quote
Old 09-07-2010, 11:35 AM   #22
kylenewman
 
Drives: 2010 Camaro 2SS
Join Date: Jun 2010
Location: N.E
Posts: 231
I havent noticed any crazy issues with my paint a few chips like 3-4 on the rear wheel well edges mine is a Rally Yellow 2010. It has less then 2500 miles. Having crap paint jobs from the factory does suck I'm used it it with having owned a 2004 WRX in the past.

My paint job on my WRX had spider webs in the clear coat that they told me i caused?? Then the paint would chip all over the place to the primer. I'm talking 100-200 chips in a 2 foot area. They ended up selectively painting the car. I got rid of it shortly after.
kylenewman is offline   Reply With Quote
Old 09-07-2010, 04:04 PM   #23
Andro
NOICE!!! ™
 
Andro's Avatar
 
Drives: Force Fed 427
Join Date: Jan 2009
Location: GOT BOOST?
Posts: 5,214
Quote:
Originally Posted by Scott@Bjorn3D View Post
I could be cleaning it under the flourecents in the garage that I am finding all these issues. I just had all new bulbs put in and my car has alot of dirt in the paint. Oh well fired a note off to GM they nice guy that helped us get the car when Steph was sick. Will do what he tells me.
Yup! Flourecent bulbs will do that to a paint job. Sounds like your Camaro is in need for a clay job
__________________
Andro is offline   Reply With Quote
Old 09-07-2010, 04:19 PM   #24
trm0002
VIN #2G1FT1EW6A9100074
 
trm0002's Avatar
 
Drives: 2010 CAMARO 2SS/RS RJT VIN 00074
Join Date: Oct 2008
Location: Buffalo,NY 'burbs
Posts: 4,218
Send a message via AIM to trm0002
Quote:
Originally Posted by Lucky SOB View Post
Early build vin < 1000 ... no paint issues - front fascia is slightly different color in some light, but that's it. Car is a RJT 2SS/RS R6P
x2

Front fascia doesn't quite match and the car has the obligatory rock chips here and there- mostly on the fascia as opposed to the hood thank God. Other than those issues- both of which I anticipated- and the paint itself being overly soft IMO (never could scratch paint this easily with even a fingernail in any other car I've ever owned) I really can't complain about the overall paint job. RJT is just a superb color in the sunlight; absolutely gorgeous when clean and waxed.

And, no, it never gets depressing doing ANYTHING related to this car.

FWIW, Vin 00074 with just short of 12k on the odometer.

Hi Scott
__________________
trm0002 is offline   Reply With Quote
Old 09-07-2010, 04:25 PM   #25
Rogue Leader
Iatefiberglassinsulation
 
Rogue Leader's Avatar
 
Drives: 2010 Camaro 2SS M6
Join Date: Oct 2008
Location: Long Island
Posts: 3,572
I do a little but not because my paint is bad, but the fact shes not "new" anymore. I've got 17k on her and the mileage shows a bit. She still looks great but shes got some chips and scratches and stuff... it happens. But then I think of how much I've enjoyed the drive and its all worth it.
__________________
2010 Chevrolet Camaro SS - was daily driver, now toy
2014 Mercedes Benz E350 4matic Sport - Daily Driver
2008 Chevy Silverado 2500 HD LT 6.0 - Tow Vehicle
1995 Volkswagen Golf Race Car

"Like" my race team on Facebook: http://www.facebook.com/farfrumwinnin
Rogue Leader is offline   Reply With Quote
Old 09-07-2010, 04:27 PM   #26
bamaproshop
 
bamaproshop's Avatar
 
Drives: 2014 Camaro 2LT/RS
Join Date: Mar 2010
Location: Alabama
Posts: 352
Send a message via MSN to bamaproshop Send a message via Yahoo to bamaproshop
I have had my Camaro for 16 months now its black and no paint issues and im pretty picky with mine...
__________________
2014 Camaro 2LT RS with Spring Edition Package
Proud Litho Owner #28.
bamaproshop is offline   Reply With Quote
Old 09-07-2010, 04:29 PM   #27
tjbusa
Serious Sleeper
 
tjbusa's Avatar
 
Drives: 2010 CGM 2SS/RS M6
Join Date: Nov 2008
Location: Lexington,SC
Posts: 3,131
Other than a few rock dings, no
__________________
***************************************
Drive-by

Fact of Life:

After Monday and Tuesday
even the calendar reads...
W T F
***************************************
tjbusa is offline   Reply With Quote
Old 09-07-2010, 04:32 PM   #28
Bell040


 
Bell040's Avatar
 
Drives: 2SS/RS - Black - GFX
Join Date: Nov 2008
Location: B'ham, Alabama
Posts: 2,458
I've got almost 50,000 miles on mine already (47,000 i think).

paint still looks pretty good to me... considering.

I did the Zaino thing (claybar and multiple layers of stuff... twice now) ... others may not be so fortunate.
__________________
Ordered: 10-13-08
Built: 3-30-09 (#1691)
Recieved: 6-12-09

Blacked out, Cammed (Lunati Voodoo 233/245, .578/.598 @114°, +4°), ARH LTs, VR OTR CAI, Cutouts, and lots of other fun mods.
Bell040 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What is the difference between a Sports car and a Muscle car (whats your opinion) Camaro Man 5th Gen Camaro SS LS LT General Discussions 33 02-16-2011 12:15 AM
Do you want the Z28? ChrisB Camaro ZL1 Forum - ZL1 Specific Topics 1616 09-05-2010 12:49 AM
Think about this and the Z28 5th gen 13F20 Camaro ZL1 Forum - ZL1 Specific Topics 41 09-04-2010 01:59 AM
Good News For The QC Cars - ALL cars in QC hold to ship within 10 days CWI Camaro Price | Ordering | Tracking | Dealers Discussions 64 06-09-2009 07:10 PM
Some thoughts on "recent" developments on this site.... fbodfather 5th Gen Camaro SS LS LT General Discussions 258 05-08-2009 11:24 PM


All times are GMT -5. The time now is 07:55 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.