Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Bigwormgraphix
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 01-24-2020, 03:13 PM   #1
krimzonwolf
 
Drives: 1978 Camaro LT, 1973 Camaro Base.
Join Date: Sep 2018
Location: Dothan, AL
Posts: 6
Ticking noise from engine



Is this normal?
krimzonwolf is offline   Reply With Quote
Old 01-27-2020, 03:12 PM   #2
seang2340
 
Drives: 2012 Chevy Camaro 2SS
Join Date: Sep 2019
Location: El Paso, TX
Posts: 14
Probably a lifter going bad.
seang2340 is offline   Reply With Quote
Old 01-28-2020, 10:56 AM   #3
RankSS
 
Drives: 2010 Camaro SS
Join Date: Oct 2013
Location: Saskatoon SK Can. Eh
Posts: 312
You really have to ask if that is normal? Hell no!!! Shut it off.
__________________
2010 Camaro SS RS, Maggie with 3.4" pulley, 60# injectors, ADM dual fuel pumps, ADM Stage 2 Cam with Brian Tooley springs and pushrods, black CAI intake, Stainless Works long tube headers w/gutted cats, ZL1 Diff w/offset bushings, Pfadt lowering springs, Pfadt sway bars, Pfadt solid sub frame mounts, BMR trailing arms and toe rods, Hurst short throw shifter, Painted on Hugger Orange stripes, Forgestar F14 Piano Black wheels, Nitto NT05 rubber.
RankSS is offline   Reply With Quote
Old 01-28-2020, 11:03 AM   #4
Risingson05
 
Drives: 2015 zl1
Join Date: Jan 2020
Location: Anchorage
Posts: 41
Quote:
Originally Posted by RankSS View Post
You really have to ask if that is normal? Hell no!!! Shut it off.
Haha
Risingson05 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:55 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.