Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Roto-Fab
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Other Generations > 4th Generation Camaros


Reply
 
Thread Tools
Old 01-08-2024, 01:07 PM   #1
The_bald_eagle_machine
Anthony S
 
The_bald_eagle_machine's Avatar
 
Drives: 2011 chevrolet camaro 2ss/rs
Join Date: Apr 2021
Location: Chiefland, FL
Posts: 879
1995 camaro z28 project

Yet another fix and flip project that Sinacola Salvage will be tackling. This one is a 1995 Camaro Z28 with the LT1 and a 4l60e transmission. The car had a really rough start on the day that I looked at it. Running rough, throwing a misfire code. Has a random popping sound when idling. I assumed it was an opti related issue as the opti is covered in oil, and all the plugs and wires looked new. Took the gamble and offered him $1500 for it and I drove it on the trailer. It's got some really nice looking headers on it, flowmasters exhaust, some kind of aftermarket throttle body, bmr strut tower brace and torque arm. Interior is decent and it looks like heat and ac both work. Transmission looks to be brand new, not rebuilt. The cork transmission pan gasket is leaking though. Also the driveshaft pinion seal is leaking. Need to replace a bunch of gaskets but overall excited to tackle this one. Anyone have experience with pin drive opti? Any tips and tricks before I dive in the rabbit hole?
Attached Images
          
__________________
Follow me on instagram @The_bald_eagle_machine
https://www.camaro5.com/forums/showthread.php?t=600181

Mods: Texas Speed 2 inch headers, high flow cats, and X-pipe. Custom mid-pipe, Borla Xr1 mufflers. Torqstorm Supercharger, 3.1" pulley, ZL1 fuel pump. MGW Shifter, Mcleod RST clutch, Tick master cylinder and Tick Billet bushing reinforced slave cylinder. DSS One-piece 3.5" Driveshaft, Metco Driveshaft safety loop, BCRacing Coilovers. BMR Poly Diff bushings, Poly Rear cradle bushings, Sub-frame connectors, Lower control arms, camber arms, and toe links.
The_bald_eagle_machine is offline   Reply With Quote
Old 01-08-2024, 01:10 PM   #2
The_bald_eagle_machine
Anthony S
 
The_bald_eagle_machine's Avatar
 
Drives: 2011 chevrolet camaro 2ss/rs
Join Date: Apr 2021
Location: Chiefland, FL
Posts: 879
Second pic of the engine bay is after I pressure washed everything off and swapped out that cheap ebay intake tube for a trickflow plenum that I found new on ebay. Cleans it up nice, just need to drill a hole in it for the opti vent.

Also the last Pic there is my tune up kit that I purchased. All new felpro gaskets fro the front cover seal, water pump and valve cover gaskets. New opti, plugs, wires, ignition coil, and ICM. New water pump, hoses and even radiator. For that added measure I even bought a new harmonic balancer. This thing should be purring when I am done with it!
__________________
Follow me on instagram @The_bald_eagle_machine
https://www.camaro5.com/forums/showthread.php?t=600181

Mods: Texas Speed 2 inch headers, high flow cats, and X-pipe. Custom mid-pipe, Borla Xr1 mufflers. Torqstorm Supercharger, 3.1" pulley, ZL1 fuel pump. MGW Shifter, Mcleod RST clutch, Tick master cylinder and Tick Billet bushing reinforced slave cylinder. DSS One-piece 3.5" Driveshaft, Metco Driveshaft safety loop, BCRacing Coilovers. BMR Poly Diff bushings, Poly Rear cradle bushings, Sub-frame connectors, Lower control arms, camber arms, and toe links.
The_bald_eagle_machine is offline   Reply With Quote
Old 01-08-2024, 04:45 PM   #3
NiteProwlerSS
 
NiteProwlerSS's Avatar
 
Drives: 2012 Camaro SS
Join Date: May 2023
Location: KY
Posts: 84
I was gonna say you need to get a 1lE elbow but you already solved that issue.

It's been awhile since I've worked on a LT1, I traded my 95 Z28 in 2012. But from what I remember the 95-97 models have a longer dowel on the cam that slides into the opti.
__________________
2012 Camaro 2SS LS3 M6
NiteProwlerSS is offline   Reply With Quote
Old 01-18-2024, 12:37 PM   #4
The_bald_eagle_machine
Anthony S
 
The_bald_eagle_machine's Avatar
 
Drives: 2011 chevrolet camaro 2ss/rs
Join Date: Apr 2021
Location: Chiefland, FL
Posts: 879
So I pulled the front timing cover off to replace the leaking seals... and this happened.
1. The oil pan gasket which is originally a 1 piece, is now a 2 piece. Cool.
2. The front timing cover chipped where the gasket wraps around the oil pan seal. Question is, can I goop up some rtv here? Or do I need a new cover. I'm thinking I need a new cover.
Attached Images
    
__________________
Follow me on instagram @The_bald_eagle_machine
https://www.camaro5.com/forums/showthread.php?t=600181

Mods: Texas Speed 2 inch headers, high flow cats, and X-pipe. Custom mid-pipe, Borla Xr1 mufflers. Torqstorm Supercharger, 3.1" pulley, ZL1 fuel pump. MGW Shifter, Mcleod RST clutch, Tick master cylinder and Tick Billet bushing reinforced slave cylinder. DSS One-piece 3.5" Driveshaft, Metco Driveshaft safety loop, BCRacing Coilovers. BMR Poly Diff bushings, Poly Rear cradle bushings, Sub-frame connectors, Lower control arms, camber arms, and toe links.
The_bald_eagle_machine is offline   Reply With Quote
Old 02-26-2024, 09:58 AM   #5
The_bald_eagle_machine
Anthony S
 
The_bald_eagle_machine's Avatar
 
Drives: 2011 chevrolet camaro 2ss/rs
Join Date: Apr 2021
Location: Chiefland, FL
Posts: 879
Anyone familiar with these cars? I replaced the entire ignition system, cooling system to chase a misfire... Now the car STILL has a misfire. The same exact misfire that I was chasing.

Using a stethoscope I can hear all the injectors firing, I can hear the spark plugs firing through the header tubes, and the car has spark and good fuel pressure. If I pull the MAF while the car is running, it dies immediately. The only thing I didn't replace was the o2 sensors, but i can't imagine that is the issue. The car is a 95 so you need an obd1 adapter to read the codes and the paperclip method doesn't work flashing codes so I can't pull them.

Car has headers, egr delete, CAI, cat delete, aftermarket throttle body, and I don't see any signs of a tuner, so I imagine its a stock tune/ECU. Any insight? I know that finding guys who know anything about LT1 stuff is few and far between since they were made for such a short time and so problematic. Hoping someone can chime in on some information that may help me chase the issue. The car idles, drives and shifts strong. but it has a lean popping misfire and I don't know what to do at this point. CEL is kinda sporadic, and turns on and off. It also, doesn't turn on right away, on cold start it idles for a good 30 seconds before the code pops up, then you hear the dual fans kick into high gear and it pretty much stays that way.
__________________
Follow me on instagram @The_bald_eagle_machine
https://www.camaro5.com/forums/showthread.php?t=600181

Mods: Texas Speed 2 inch headers, high flow cats, and X-pipe. Custom mid-pipe, Borla Xr1 mufflers. Torqstorm Supercharger, 3.1" pulley, ZL1 fuel pump. MGW Shifter, Mcleod RST clutch, Tick master cylinder and Tick Billet bushing reinforced slave cylinder. DSS One-piece 3.5" Driveshaft, Metco Driveshaft safety loop, BCRacing Coilovers. BMR Poly Diff bushings, Poly Rear cradle bushings, Sub-frame connectors, Lower control arms, camber arms, and toe links.
The_bald_eagle_machine is offline   Reply With Quote
Old 02-26-2024, 08:54 PM   #6
NiteProwlerSS
 
NiteProwlerSS's Avatar
 
Drives: 2012 Camaro SS
Join Date: May 2023
Location: KY
Posts: 84
First thing I would check is plug wire routing, may have a plug wire crossed, especially on the passenger side because the wires go behind the alternator bracket. Its easy for them to get flipped. Been there and done that, lol.

What brand optispark did you put on? I always heard horror stories about the parts store optis. I changed optis a couple times but always went with gm.

I do remember putting an Advance Auto Parts coil on my old LT1 car and it would break up at higher rpms, put a new gm coil on and never had the issue again.
__________________
2012 Camaro 2SS LS3 M6
NiteProwlerSS is offline   Reply With Quote
Old 02-28-2024, 09:25 AM   #7
The_bald_eagle_machine
Anthony S
 
The_bald_eagle_machine's Avatar
 
Drives: 2011 chevrolet camaro 2ss/rs
Join Date: Apr 2021
Location: Chiefland, FL
Posts: 879
I wired the opti 1 wire at a time, so I really don't think i crossed a wire. Its a Jegs optispark because nowadays you can't find an oem Optispark. They sell rebuilt ones...

I started checking everything i possibly could. Eventually I started pulling injectors while the car was idling, and I pulled 3 off of 1 side of the motor and the idle didn't change at all. I pulled the 4th and idle dropped drastically. The other side only 2 of the injectors are working properly. So I am 90% sure that the car needs new injectors. Which makes sense, because this car had the same issue BEFORE i changed the opti and all the ignition related parts. So I am going to change the injectors which hopefully fixes the issue, and then probably throw another set of clean plugs in her and hopefully be done. This LT1 has been a nightmare to work on.
__________________
Follow me on instagram @The_bald_eagle_machine
https://www.camaro5.com/forums/showthread.php?t=600181

Mods: Texas Speed 2 inch headers, high flow cats, and X-pipe. Custom mid-pipe, Borla Xr1 mufflers. Torqstorm Supercharger, 3.1" pulley, ZL1 fuel pump. MGW Shifter, Mcleod RST clutch, Tick master cylinder and Tick Billet bushing reinforced slave cylinder. DSS One-piece 3.5" Driveshaft, Metco Driveshaft safety loop, BCRacing Coilovers. BMR Poly Diff bushings, Poly Rear cradle bushings, Sub-frame connectors, Lower control arms, camber arms, and toe links.
The_bald_eagle_machine is offline   Reply With Quote
Old 03-11-2024, 02:15 PM   #8
The_bald_eagle_machine
Anthony S
 
The_bald_eagle_machine's Avatar
 
Drives: 2011 chevrolet camaro 2ss/rs
Join Date: Apr 2021
Location: Chiefland, FL
Posts: 879
I have officially given up on this car... I swapped out the injectors, with new reman injectors, swapped out to new spark plugs, even went as far as putting in a new fuel pump. I have put a infared heat gun on all the cylinders and they are all firing. Car has 40ish psi fuel pressure... I give up. Still has a lean pop misfire, Thinking maybe I got a faulty optispark, or bad fuel injectors... I give up. Selling the car as is, or stripping it for parts in the next few weeks.
__________________
Follow me on instagram @The_bald_eagle_machine
https://www.camaro5.com/forums/showthread.php?t=600181

Mods: Texas Speed 2 inch headers, high flow cats, and X-pipe. Custom mid-pipe, Borla Xr1 mufflers. Torqstorm Supercharger, 3.1" pulley, ZL1 fuel pump. MGW Shifter, Mcleod RST clutch, Tick master cylinder and Tick Billet bushing reinforced slave cylinder. DSS One-piece 3.5" Driveshaft, Metco Driveshaft safety loop, BCRacing Coilovers. BMR Poly Diff bushings, Poly Rear cradle bushings, Sub-frame connectors, Lower control arms, camber arms, and toe links.
The_bald_eagle_machine is offline   Reply With Quote
Old 03-14-2024, 08:23 AM   #9
The_bald_eagle_machine
Anthony S
 
The_bald_eagle_machine's Avatar
 
Drives: 2011 chevrolet camaro 2ss/rs
Join Date: Apr 2021
Location: Chiefland, FL
Posts: 879
I am going to replace the Optispark again with one from Petris Enterprises which supposedly is the #1 standard for these things and uses the stronger, more reliable Mitsubishi optical sensor. The car is running worse and worse the more I try to drive it so I think I got a faulty Optispark unit from Jegs. Which is supposedly a very common thing... Go figure.
__________________
Follow me on instagram @The_bald_eagle_machine
https://www.camaro5.com/forums/showthread.php?t=600181

Mods: Texas Speed 2 inch headers, high flow cats, and X-pipe. Custom mid-pipe, Borla Xr1 mufflers. Torqstorm Supercharger, 3.1" pulley, ZL1 fuel pump. MGW Shifter, Mcleod RST clutch, Tick master cylinder and Tick Billet bushing reinforced slave cylinder. DSS One-piece 3.5" Driveshaft, Metco Driveshaft safety loop, BCRacing Coilovers. BMR Poly Diff bushings, Poly Rear cradle bushings, Sub-frame connectors, Lower control arms, camber arms, and toe links.
The_bald_eagle_machine is offline   Reply With Quote
Old 03-20-2024, 10:01 AM   #10
The_bald_eagle_machine
Anthony S
 
The_bald_eagle_machine's Avatar
 
Drives: 2011 chevrolet camaro 2ss/rs
Join Date: Apr 2021
Location: Chiefland, FL
Posts: 879
Got this car fully sorted. Turns out it WAS a bad optispark. The $500 Petris Enterprise Optispark completely solved the issue. She runs like a bat out of hell. Definitely has a shift kit in the trans. Here is the for sale ad that I have posted in case anyone is interested.

1995 Camaro Z28, with an LT1 motor, lots of new parts. Previously listed as misfiring, put in a brand new Petris Enterprise Opti-Spark and she runs great now! She is pretty quick, shifts are aggressive, a real runner. No joyride without proof of funds. If you put it in a ditch, you bought it!

Pros
-New Opti-Spark, plugs, wires, ignition coil, and ICM.
-New Radiator, hoses, coolant temp sensor and water pump.
-New oil pan, valve covers, and front timing cover gaskets.
-New diff gasket and fresh fluid.
-Headers, aftermarket throttle body, egr and cat delete, full exhaust and a K&N cold air intake.
-BMR torque arm, poly bushing and poly trans mount.
-New fuel filter, fuel pump and injectors.
-All black panels are freshly painted matte black.
-New transmission with shift kit, new gaskets, fluid and speed sensor.

Cons
-Paint is not great, faded clearcoat. No body damage though.
-AC doesn't blow cold.
-Needs tires
-Suspension needs some TLC, maybe an alignment.
-No radio
-Interior
Attached Images
         
__________________
Follow me on instagram @The_bald_eagle_machine
https://www.camaro5.com/forums/showthread.php?t=600181

Mods: Texas Speed 2 inch headers, high flow cats, and X-pipe. Custom mid-pipe, Borla Xr1 mufflers. Torqstorm Supercharger, 3.1" pulley, ZL1 fuel pump. MGW Shifter, Mcleod RST clutch, Tick master cylinder and Tick Billet bushing reinforced slave cylinder. DSS One-piece 3.5" Driveshaft, Metco Driveshaft safety loop, BCRacing Coilovers. BMR Poly Diff bushings, Poly Rear cradle bushings, Sub-frame connectors, Lower control arms, camber arms, and toe links.
The_bald_eagle_machine is offline   Reply With Quote
Old 04-02-2024, 12:15 PM   #11
The_bald_eagle_machine
Anthony S
 
The_bald_eagle_machine's Avatar
 
Drives: 2011 chevrolet camaro 2ss/rs
Join Date: Apr 2021
Location: Chiefland, FL
Posts: 879
Price adjusted to $5000. Would entertain trades for a thirdgen F body, or a full size Chevy truck, or SUV.
__________________
Follow me on instagram @The_bald_eagle_machine
https://www.camaro5.com/forums/showthread.php?t=600181

Mods: Texas Speed 2 inch headers, high flow cats, and X-pipe. Custom mid-pipe, Borla Xr1 mufflers. Torqstorm Supercharger, 3.1" pulley, ZL1 fuel pump. MGW Shifter, Mcleod RST clutch, Tick master cylinder and Tick Billet bushing reinforced slave cylinder. DSS One-piece 3.5" Driveshaft, Metco Driveshaft safety loop, BCRacing Coilovers. BMR Poly Diff bushings, Poly Rear cradle bushings, Sub-frame connectors, Lower control arms, camber arms, and toe links.
The_bald_eagle_machine is offline   Reply With Quote
Old 04-18-2024, 08:49 AM   #12
The_bald_eagle_machine
Anthony S
 
The_bald_eagle_machine's Avatar
 
Drives: 2011 chevrolet camaro 2ss/rs
Join Date: Apr 2021
Location: Chiefland, FL
Posts: 879
Sold this car. Man, I knew that LT1 cars were tempermental, and a PITA to work on but... This car was a whole different beast. I have no desire to work on one of these ever again. I ended up selling it for a loss at $3000, i couldn't give this car away. Anyways, on to the next one.
__________________
Follow me on instagram @The_bald_eagle_machine
https://www.camaro5.com/forums/showthread.php?t=600181

Mods: Texas Speed 2 inch headers, high flow cats, and X-pipe. Custom mid-pipe, Borla Xr1 mufflers. Torqstorm Supercharger, 3.1" pulley, ZL1 fuel pump. MGW Shifter, Mcleod RST clutch, Tick master cylinder and Tick Billet bushing reinforced slave cylinder. DSS One-piece 3.5" Driveshaft, Metco Driveshaft safety loop, BCRacing Coilovers. BMR Poly Diff bushings, Poly Rear cradle bushings, Sub-frame connectors, Lower control arms, camber arms, and toe links.
The_bald_eagle_machine is offline   Reply With Quote
Old 04-18-2024, 09:54 AM   #13
SlowLS1

 
SlowLS1's Avatar
 
Drives: 2010 Camaro SS , 2011 Colorado LS1
Join Date: Jan 2022
Location: Greenville, SC
Posts: 864
LT1 cars were either love or hate. Not a lot of “middle of the road”. When the gen 3 dropped, there was a lot of division in the community. I personally embraced the newer gens. I had 1 of those LT1 cars and it was enough to never have one again. They were cramped to work on, had all the gen 1 leak issues, and water pump/optispark problems.

Hate that you had to take a loss. Those are a tough sell and haven’t aged well imo.
__________________
SlowLS1 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:00 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2024, vBulletin Solutions, Inc.