Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
dave@hennessey
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 03-26-2023, 07:14 PM   #29
Camaro2ss2010

 
Camaro2ss2010's Avatar
 
Drives: 2010 Camaro 2SSRS M6
Join Date: Jan 2019
Location: Alabama
Posts: 1,249
Best bet is to find someone that can read live data. It can also be caused by a short in the wiring harness. One of the common spots is on the left side of the engine bay just below the head. It tends to be rub into the metal clamp holding the harness in place. I would be willing to bet there are more codes than just an O2.
__________________
ECS supercharger, custom ground cam, ported throttle body, long tube headers, aeromotive fuel pump, fic injectors, ATI super damper, Corsa Extreme exhaust, elite engineering catch can and many other things.
Camaro2ss2010 is offline   Reply With Quote
Old 07-08-2023, 09:22 PM   #30
Ksanders6226
 
Drives: Chevrolet camaro ss/Silverado 1500
Join Date: Mar 2023
Location: Huntsville alabama
Posts: 4
I'm having the reduced power issue. I've replaced pedal and TPS inside the TB. I'm running a fast lsx 102 intake and BBK 102mm TB. It's very intermittent though. It's done it once in about a month. Before that 2+ months. Code thrown today was p2101. Any luck on fixing it?
Ksanders6226 is offline   Reply With Quote
Old 01-02-2024, 02:38 AM   #31
Miami_SS
 
Drives: 2011 Camaro SS LS3
Join Date: Jan 2022
Location: Miami
Posts: 37
Quote:
Originally Posted by Ksanders6226 View Post
I'm having the reduced power issue. I've replaced pedal and TPS inside the TB. I'm running a fast lsx 102 intake and BBK 102mm TB. It's very intermittent though. It's done it once in about a month. Before that 2+ months. Code thrown today was p2101. Any luck on fixing it?
I had a similar issue after installing a Soler Ported TB. It threw P2101 and P1516 (they are related). According to HP Tuners member forums, you have to reinstall the stock TB or adjust the tolerances (%) for the 2101 and 1516 channels by using their software. I have HP Tuners software and have access to these channels. I will tweak the % and see if it keeps me out of REP. In the meantime, I put my stock TB back on. These are your only options. There is no other solution unless you purchase a stand-alone ECM and custom software.
Miami_SS is offline   Reply With Quote
Old 04-18-2024, 02:49 PM   #32
rmacgowan
 
Drives: 2010 Camaro 2 SS
Join Date: Mar 2016
Location: Pasadena, TX
Posts: 5
2010 SS with Reduced Power message on DIC

Quote:
Originally Posted by Camaro2ss2010 View Post
Today as I was sitting at a red light and the light turned green I took off and all of my dash lights came on(reduced engine power, stabilitrac and all other lights). My oil pressure gauge did not have a reading. I pull over and turn my car off. Let us sit for a few minutes and crank it back up. All lights gone except check engine light. Oil pressure was reading correctly again. Took off and within 1 minute it said reduced engine power again but the oil pressure read correct. I have a 2010 SS with the LS3. It has the list of mods in my signature. Haven’t taken it to get the codes read yet as I am waiting on the performance shop to call me back that built it less than two months ago. Any ideas on what could cause it.
We have a 2010 SS that has the same message on the DIC. The PCV valve failed causing the engine to flood with oil where it wasn't supposed to be. That was just part of the problem. We also have a 5-volt reference to ground on the oil pressure switch. Now... the switch has been replaced, but the message still shows on the DIC after a few miles. The oil pressure switch was disconnected and the problem went away. There seems to be a short to ground on the oil pressure switch. Now to find someone who won't charge an arm and a leg to fix it. Good luck!
rmacgowan is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:03 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2024, vBulletin Solutions, Inc.