Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Roto-Fab
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6)


Reply
 
Thread Tools
Old 03-19-2024, 08:42 PM   #1
FasNuf

 
FasNuf's Avatar
 
Drives: 2014 Camaro ZL1
Join Date: Jul 2019
Location: Oregon
Posts: 1,632
GulfCoast Driveshaft Loses It

Yep, If you're considering buying one you want to see this short 2 minute video of my issue today.

https://youtu.be/aYLrN2kBnWI?si=H84Hg9ng-JM2CiJC

.
.
.
.
.

Last edited by FasNuf; 03-19-2024 at 08:56 PM.
FasNuf is offline   Reply With Quote
Old 03-20-2024, 05:10 AM   #2
tartagliazl1

 
tartagliazl1's Avatar
 
Drives: 2013 zl1 vert
Join Date: Dec 2018
Location: Rochester, New york
Posts: 966
was this the first ride out from winter storage?
__________________
22% lower/ 2.5 upper/ 2” headers/ cat delete/ x-pipe/ 2 gallon x tank/ 100-3 pump/ fic 1300/ dsx aux kit/ 103mm throttle body/ RPM 5” intake/ meth kit/ prometh lid injection/FI interchiller/ 160* stat/ ngk-7/ msd wires/ elite catch can/ tsp cam/ Che trunnions/ ported supercharger/ 1/2” lid spacer/ brick mod/BMR toe and trailing arms/ 751hp 757 tq SAE @17.3lb on a loaded dyno.
tartagliazl1 is online now   Reply With Quote
Old 03-20-2024, 05:18 AM   #3
0stones0
It don’t come easy.
 
0stones0's Avatar
 
Drives: 2010 2SS RS M6
Join Date: May 2014
Location: WI
Posts: 2,238
Imho, this is on their end, plain and simple.
__________________
0stones0 is offline   Reply With Quote
Old 03-20-2024, 06:32 AM   #4
FasNuf

 
FasNuf's Avatar
 
Drives: 2014 Camaro ZL1
Join Date: Jul 2019
Location: Oregon
Posts: 1,632
Quote:
Originally Posted by tartagliazl1 View Post
was this the first ride out from winter storage?
No, I've had it out 2 other times and I've driven this over 130mph at the drags on 100° days with no issue. My guess is their glue is junk and got weak over time even with normal temps and probably didn't prep the weights for gluing.
FasNuf is offline   Reply With Quote
Old 03-20-2024, 07:11 AM   #5
FasNuf

 
FasNuf's Avatar
 
Drives: 2014 Camaro ZL1
Join Date: Jul 2019
Location: Oregon
Posts: 1,632
Quote:
Originally Posted by 0stones0 View Post
Imho, this is on their end, plain and simple.
Talked to Jordan just now over there and it's getting handled so far. Melissa wasn't in yet due to an appointment. He said they had a couple failures of the glue due to shaft flexing under load weakening the glue bond. They've gone to a different 3M glue that's got some flexing properties to solve the issue.

Last edited by FasNuf; 03-20-2024 at 05:49 PM.
FasNuf is offline   Reply With Quote
Old 03-20-2024, 11:21 AM   #6
tartagliazl1

 
tartagliazl1's Avatar
 
Drives: 2013 zl1 vert
Join Date: Dec 2018
Location: Rochester, New york
Posts: 966
Quote:
Originally Posted by FasNuf View Post
Talked to Jeff just now over there and it's getting handled so far. Melissa wasn't in yet due to an appointment. He said they had a couple failures of the glue due to shaft flexing under load weakening the glue bond. They've gone to a different 3M glue that's got some flexing properties to solve the issue.
So are they sending you a new shaft or do you have to send yours back first. That would annoy me.
__________________
22% lower/ 2.5 upper/ 2” headers/ cat delete/ x-pipe/ 2 gallon x tank/ 100-3 pump/ fic 1300/ dsx aux kit/ 103mm throttle body/ RPM 5” intake/ meth kit/ prometh lid injection/FI interchiller/ 160* stat/ ngk-7/ msd wires/ elite catch can/ tsp cam/ Che trunnions/ ported supercharger/ 1/2” lid spacer/ brick mod/BMR toe and trailing arms/ 751hp 757 tq SAE @17.3lb on a loaded dyno.
tartagliazl1 is online now   Reply With Quote
Old 03-20-2024, 11:40 AM   #7
dreksnot
Served USN - Atomic Chimp
 
dreksnot's Avatar
 
Drives: 2021 Camaro ZL1 1LE A10
Join Date: Jul 2012
Location: Fort Collins, CO
Posts: 1,609
I've not had this happen with my DSS CF but I know of others who have. Having to send it back in kinda sucks to have it rebalanced, with all the uninstall and reinstall involved. I feel for you!
__________________

In excess of 1,000WHP
LSX434 | AGP 65/65 TT | BTR Equalizer Intake | Trickflow 245cc cathedral | BTR custom cam | Cortex EBC | n2mb WOT | ID-1700x | Brisk GR12S | RPM Lv 7 TR6060 | AGP's Triple 525LPH Fore Fuel | Monster LT1-S Triple | 4.11 DSS Proform 9", CF driveshaft, 1400hp axles | Hurst Line Lock | MGW Retro Short Throw w/old skool Hurst T-handle | ADM solid subframe mounts | Prothane Motor Mounts | Revshift Poly Trans insert | Moreno camber/caster plates
dreksnot is offline   Reply With Quote
Old 03-20-2024, 11:48 AM   #8
FasNuf

 
FasNuf's Avatar
 
Drives: 2014 Camaro ZL1
Join Date: Jul 2019
Location: Oregon
Posts: 1,632
Quote:
Originally Posted by tartagliazl1 View Post
So are they sending you a new shaft or do you have to send yours back first. That would annoy me.
No, it sounds like I'll have to send it in for rebalance. The shaft was balanced well before so I kinda rather have them just fix it. My concern is damage from the flying weights. I'll be doing an inspection once it's pulled for dings in the CF. If there are any, I'll have a talk with them for a full replacement.
FasNuf is offline   Reply With Quote
Old 03-20-2024, 11:49 AM   #9
FasNuf

 
FasNuf's Avatar
 
Drives: 2014 Camaro ZL1
Join Date: Jul 2019
Location: Oregon
Posts: 1,632
Quote:
Originally Posted by dreksnot View Post
I've not had this happen with my DSS CF but I know of others who have. Having to send it back in kinda sucks to have it rebalanced, with all the uninstall and reinstall involved. I feel for you!
Is your DSS glued too? I thought others riveted to the CF.
The labor definately is the sucky part and now dealing with the hardware issue I had all over again.
FasNuf is offline   Reply With Quote
Old 03-20-2024, 03:04 PM   #10
1JEWLDSSRS


 
1JEWLDSSRS's Avatar
 
Drives: 2011 SS-RS
Join Date: May 2011
Location: FLORIDA
Posts: 11,485
Wow Mark, that just totally bites the big one!! I hope it didn't damage the shaft in any way! Man that just sucks. What ever happened to quality in workmanship??
__________________
TSP STAGE 3 CAM,231/246 @112 LSA 614/641 LIFT, CIRCLE D 5C-4200-4500 CONVERTER,LOD INTAKE.CORSA EXHAUST. DSS 1 PC DS. PEGASUS SOLID CRADLE MOUNTS. 486RWHP/475RWTQ.LOTS MORE.
1JEWLDSSRS is offline   Reply With Quote
Old 03-20-2024, 03:35 PM   #11
dreksnot
Served USN - Atomic Chimp
 
dreksnot's Avatar
 
Drives: 2021 Camaro ZL1 1LE A10
Join Date: Jul 2012
Location: Fort Collins, CO
Posts: 1,609
Quote:
Originally Posted by FasNuf View Post
Is your DSS glued too? I thought others riveted to the CF.
The labor definately is the sucky part and now dealing with the hardware issue I had all over again.
Glued on the DSS CF shaft with that same looking epoxy. It's been awhile since I had an aluminum shaft and I thought those were tack/spot welded, but the recent pictures I've seen they have some kind of fastener (screw/rivet).
__________________

In excess of 1,000WHP
LSX434 | AGP 65/65 TT | BTR Equalizer Intake | Trickflow 245cc cathedral | BTR custom cam | Cortex EBC | n2mb WOT | ID-1700x | Brisk GR12S | RPM Lv 7 TR6060 | AGP's Triple 525LPH Fore Fuel | Monster LT1-S Triple | 4.11 DSS Proform 9", CF driveshaft, 1400hp axles | Hurst Line Lock | MGW Retro Short Throw w/old skool Hurst T-handle | ADM solid subframe mounts | Prothane Motor Mounts | Revshift Poly Trans insert | Moreno camber/caster plates
dreksnot is offline   Reply With Quote
Old 03-20-2024, 04:32 PM   #12
FasNuf

 
FasNuf's Avatar
 
Drives: 2014 Camaro ZL1
Join Date: Jul 2019
Location: Oregon
Posts: 1,632
Quote:
Originally Posted by 1JEWLDSSRS View Post
Wow Mark, that just totally bites the big one!! I hope it didn't damage the shaft in any way! Man that just sucks. What ever happened to quality in workmanship??
Well I talked to the owner and he did say they changed to a different 3M glue and temperature controlled storage of the glue as well as different preps on the shaft and weights since a previous shaft lost theirs before me.
Looks like they’re taking care of me. Sent a label to ship back and said they’ll inspect for damage.
Now the fun part, disassembly.
FasNuf is offline   Reply With Quote
Old 03-20-2024, 05:07 PM   #13
Joe.G

 
Joe.G's Avatar
 
Drives: 2014 2SS/RS 6SP Ashen Grey
Join Date: Aug 2021
Location: NY
Posts: 1,270
That sucks, I have had my aluminum one in and out 4 or 5 times because of vibration issues, GC did send me a new shaft but I have not installed it yet. I would say if there are any nicks they owe you a new shaft.
__________________
GM 3.91/TrueTrac OEM ZL1 Rims, Brakes & Side Skirts.ACST4 Splitter/Deflectors NPP M2W,GM Short Throw,Remote Clutch reservoir
GPI Ported Rod Mod,BO White PTB,CAI/JRE Scoop, Moroso Catch Can GC Aluminum DS
Stainless Works Ceramic LTH/HiFlo Cats
SCT X4 Dynosteve,
Hotckis 1" Springs & Chassis Max Brace
BMR Adjustable Swaybars,Trailing Arms, Adjustable Toe Rod, LCA & Z28 UCA Bushings Hendrix Solid Cradle Bushings
Pedders Radius Rod Inserts Strut tower brace
Hero Smoked Tail and 3rd Brake Light, Diode Dynamic SL1 Fog Lights
AeroForce Dual gauge/Autometer pillar mount.
Joe.G is offline   Reply With Quote
Old 03-20-2024, 05:48 PM   #14
FasNuf

 
FasNuf's Avatar
 
Drives: 2014 Camaro ZL1
Join Date: Jul 2019
Location: Oregon
Posts: 1,632
Quote:
Originally Posted by dreksnot View Post
Glued on the DSS CF shaft with that same looking epoxy. It's been awhile since I had an aluminum shaft and I thought those were tack/spot welded, but the recent pictures I've seen they have some kind of fastener (screw/rivet).
I like aluminum but wanted the safety of CF. I'm weird but I like the reverb ping from the headers off the aluminum.
FasNuf is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:39 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2024, vBulletin Solutions, Inc.