Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
JUICEDMOTORSPORTS
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V6 LFX Engine, Exhaust, and Bolt-Ons


Reply
 
Thread Tools
Old 06-21-2018, 04:49 PM   #1
Jc_SourPatch
 
Drives: 2014 2LT Camaro RS
Join Date: Sep 2016
Location: Uvalde
Posts: 46
P228c code

Hello everyone Iíve recently switched to e-85 with tune and sensor from will and have been having a problem when I only run e-85 anything over 65% ethanol it throws a code p228c and Will said itís my fuel pump but when I took it to my guy to get fixed he said itís the high pressure pump not the in tank pump due to code itís throwing
My question does anyone who ran e-85 have this problem and was it in tank pump or high pressure pump
Iíd rather not spend the money on one and it turns out to be the other one
Jc_SourPatch is offline   Reply With Quote
Old 06-21-2018, 06:47 PM   #2
Mike J
 
Mike J's Avatar
 
Drives: 2015 Topless Btch RS
Join Date: Mar 2016
Location: Montreal...Land of mostly Mustangs
Posts: 509
Probably due to it being low on fuel + e85. e85 makes the pump work harder. Running the tank too low gave it fuel pressure issues. I don't think it's the e85 itself.
Mike J is offline   Reply With Quote
Old 06-21-2018, 07:52 PM   #3
Jc_SourPatch
 
Drives: 2014 2LT Camaro RS
Join Date: Sep 2016
Location: Uvalde
Posts: 46
But is it the pump in the tank or the high fuel pressure pump
Jc_SourPatch is offline   Reply With Quote
Old 06-21-2018, 08:05 PM   #4
Mike J
 
Mike J's Avatar
 
Drives: 2015 Topless Btch RS
Join Date: Mar 2016
Location: Montreal...Land of mostly Mustangs
Posts: 509
Quote:
Originally Posted by Jc_SourPatch View Post
But is it the pump in the tank or the high fuel pressure pump
Possibly neither..how low do you let the gas tank go before filling up?
Mike J is offline   Reply With Quote
Old 06-21-2018, 09:01 PM   #5
DSX_Camaro

 
DSX_Camaro's Avatar
 
Drives: 2013 Summit White 2LT/RS
Join Date: Feb 2013
Location: Orlando, FL
Posts: 1,529
Do you have the stock fuel pump or the ZL1 fuel pump for the tank? The HPFP (mechanical pump) should supply more than enough fuel N/A with E85.
__________________
K&N CAI, 1LE Strut Tower Brace, Elite Engineering Catch Can and Clean Side Separator, Apex Scoop w/ Washer Relocation Kit, CTS Front Calipers and Rotors, JacFab Ported Intake Manifold, JacFab Intake Manifold Spacer, 80mm Overkill Throttle Body, SS Brake Lines, Ideal Garage Master Cylinder, Monster Twin Disc Clutch, NPP Retrofit w/ Magnaflow Resonated X, ARH Catless Downpipes, JRE Built 3.45 Diff, 1LE Axles, 1LE Hubs, Overkill Tuned, BMR Anti Wheel-hop Kit Stage I, ACS TL1 Hood Insert, ZL1 Spoiler
DSX_Camaro is offline   Reply With Quote
Old 06-21-2018, 10:51 PM   #6
Jc_SourPatch
 
Drives: 2014 2LT Camaro RS
Join Date: Sep 2016
Location: Uvalde
Posts: 46
The stock pump but I know guys running the e85 on camaro no problems
Jc_SourPatch is offline   Reply With Quote
Old 06-21-2018, 10:52 PM   #7
Jc_SourPatch
 
Drives: 2014 2LT Camaro RS
Join Date: Sep 2016
Location: Uvalde
Posts: 46
And it does it with a full tank, half tank it does it all the time
Jc_SourPatch is offline   Reply With Quote
Old 06-25-2018, 02:15 AM   #8
Jazzzed
 
Jazzzed's Avatar
 
Drives: 2015 Camaro LT
Join Date: Sep 2016
Location: Fox Lake, IL
Posts: 384
It would be the high pressure pump if it is indeed the pump causing the problem. It looks like that P228c code can occur anytime the fuel pressure is lower than the PCM expects though. Could be an injector that isn't closing fully, a faulty fuel pressure regulator, or any other leak in the system after the pump. What did you take apart in order to install the kit? I'd review all of that. Have you tried running gasoline since installing the kit, and does the error throw when running on gas?
__________________
Jazzzed is offline   Reply With Quote
Old 06-27-2018, 02:52 AM   #9
Jc_SourPatch
 
Drives: 2014 2LT Camaro RS
Join Date: Sep 2016
Location: Uvalde
Posts: 46
That’s what I’m saying when running gasoline it runs perfectly fine even if I put a blend of gas and e-85 it works fine. It’s only when I run over 65% percent ethanol
Jc_SourPatch is offline   Reply With Quote
Old 07-20-2018, 05:55 AM   #10
Jc_SourPatch
 
Drives: 2014 2LT Camaro RS
Join Date: Sep 2016
Location: Uvalde
Posts: 46
Ok so update had high pressure pump replaced and issue continues
Jc_SourPatch is offline   Reply With Quote
Old 07-20-2018, 09:58 AM   #11
DSX_Camaro

 
DSX_Camaro's Avatar
 
Drives: 2013 Summit White 2LT/RS
Join Date: Feb 2013
Location: Orlando, FL
Posts: 1,529
Injector issue?
__________________
K&N CAI, 1LE Strut Tower Brace, Elite Engineering Catch Can and Clean Side Separator, Apex Scoop w/ Washer Relocation Kit, CTS Front Calipers and Rotors, JacFab Ported Intake Manifold, JacFab Intake Manifold Spacer, 80mm Overkill Throttle Body, SS Brake Lines, Ideal Garage Master Cylinder, Monster Twin Disc Clutch, NPP Retrofit w/ Magnaflow Resonated X, ARH Catless Downpipes, JRE Built 3.45 Diff, 1LE Axles, 1LE Hubs, Overkill Tuned, BMR Anti Wheel-hop Kit Stage I, ACS TL1 Hood Insert, ZL1 Spoiler
DSX_Camaro is offline   Reply With Quote
Old 07-21-2018, 07:10 PM   #12
Jc_SourPatch
 
Drives: 2014 2LT Camaro RS
Join Date: Sep 2016
Location: Uvalde
Posts: 46
But only throwing code when on e85
Jc_SourPatch is offline   Reply With Quote
Old 07-23-2018, 03:54 AM   #13
Jc_SourPatch
 
Drives: 2014 2LT Camaro RS
Join Date: Sep 2016
Location: Uvalde
Posts: 46
So to anyone who has this problem in the future some things to check
There is a service bulletin about this for the e85 impalas and all other flex fuel lfx engines about checking connections to pcm. I will be checking these tomorrow, might even been a bad tank of e85 as ive ran 5 plus tanks thru it before the code came back.
Also my mechanic said in older gm vehicles that code was thrown due to the throttle body going out, since i have the 80mm one ill be switching it out with the stock and see if that doesn anything. And of all else fails i will have entire fuel system checked for any clogs and any bad parts.
Jc_SourPatch is offline   Reply With Quote
Old 09-26-2018, 11:20 AM   #14
Pvppi
 
Drives: 2015 Rs
Join Date: Sep 2018
Location: Cali
Posts: 4
Same problem

Hey there i have the same exact problem barely installed my kit about a month ago and my stabilitrak comes with reduction of engine power, throwing the code p288c. Anyone know why or what i can Do ? I got same e85 kit from Will at overkill
Pvppi is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:37 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.