Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Roto-Fab
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Cosmetics and Lighting Modification Discussions


Reply
 
Thread Tools
Old 09-19-2019, 12:08 AM   #85
Ulises Alvarez
 
Drives: Chevy Camaro SS
Join Date: Sep 2019
Location: Los Angeles
Posts: 1
HELP! Halo ring is not working :(

Hi guys! I’m having a problem with my 2010 Camaro SS . My passengers headlight is not working and by that I mean my halo ring is out! Any ideas on what i can do to solve this problem ?
Ulises Alvarez is offline   Reply With Quote
Old 09-19-2019, 11:49 PM   #86
Leo72793

 
Drives: 2011 2SS/RS
Join Date: Feb 2016
Location: Jacksonville FL
Posts: 754
Quote:
Originally Posted by Ulises Alvarez View Post
Hi guys! I’m having a problem with my 2010 Camaro SS . My passengers headlight is not working and by that I mean my halo ring is out! Any ideas on what i can do to solve this problem ?
time for a replacement kit. diodedynamics rgbw or find an oem helo led.
__________________
•2011 Camaro SS 2SS/RS A6
•MRR M017 1le Replica Wheels
•Vararam Ram Air Intake
•Speed Engineering Longtube Headers
•Magnaflow HF Cats
•Bo White PnP Stage 2 TB
•Xpipe w/ Res Delete and NPP Exhaust
•Tuned By Anonymous Calibrations
•Gen5DIY Mylink Conversion W/ Backup Cam
•Morel 3 way custom speakers, Morel Subwoofers
•Audio control LC-6.1200 6ch amp
•Audio control LC-1.1500 sub amp
•Helix DSP Pro
Leo72793 is offline   Reply With Quote
Old 09-24-2019, 01:42 PM   #87
Lacpac
 
Lacpac's Avatar
 
Drives: 2012 Crystal Red Tintcoat RS
Join Date: Apr 2013
Location: Northern Illinois
Posts: 424
I have the same problem. I've tried different Kelvin ratings, 4300, 5000, 6000, they are all dimmer than new. I replaced my DRL with Bright LED but it only marginally helps.
Thought about going LED in the main RS housing but I hear the ballast controls the flap for the high beam, so you cant bypass that. The only other option is to add quality after market lights behind the grill so they are not visible during the day, but can help with night visibility. Not sure how practical that is, or if there is a product that will work.
Lacpac is offline   Reply With Quote
Old 09-24-2019, 02:49 PM   #88
lionssfan

 
lionssfan's Avatar
 
Drives: 2010 2ss camaro
Join Date: Nov 2010
Location: mi
Posts: 1,141
I run morimoto drls that stay on all the time . And somtimes run with high beams on all the time. It doesnt bother on coming traffic.
__________________
TVS2300, BTR cam PD stage 3, ID1050 injectors, CHE bronze trunnions, 7.400" pushrods,.660" lift platinum springs, Titanium ret, Zl1 fuel pump, Kooks LT headers, High flow cats, Roto Fab CAI, Corsa exhaust, Mellings oil pump, HD chain, ls2 damper, all synthetic, BMR control arms, zl1 toe link, BMR body cradle mounts, washer bottle relocation, air scoop deflector, Hennessy wheels, two piece rotor, morimoto fogs, DRL harness, coilovers, Heads up display install, mgw shifter, slps splitter, slp spoiler, zl1 side skirts, painted strips, debadged, tinted, 2018 emblems.
lionssfan is offline   Reply With Quote
Old 10-01-2019, 09:55 AM   #89
SIXJAK


 
SIXJAK's Avatar
 
Drives: MO's only SC'd LLT.
Join Date: Feb 2010
Location: Branson MO
Posts: 2,574
2010 2LT RS Passenger side head light just turned purple. I am the only owner of this vehicle and it has 84k miles on it. This is the OEM set up from factory. Is my ballast getting ready to take a dump?
__________________
IPF supercharger kit, IPF tune, SW LT's, R. Tech HFC's, ARK DT-S catback, SS Brembo brake upgrade, BC Racing adjustable coilovers, Hurst STS, Pfadt rear arm package, Pfadt adjustable sways & end links, Pfadt diff bushings, BMR rear cradle full kit blk bezels,SS diffuser, Innovate gauges.
SIXJAK is offline   Reply With Quote
Old 10-01-2019, 12:50 PM   #90
camguynj


 
camguynj's Avatar
 
Drives: '13 SS/RS LS3 NPP BRM
Join Date: Jan 2013
Location: NJ
Posts: 2,961
Quote:
Originally Posted by SIXJAK View Post
2010 2LT RS Passenger side head light just turned purple. I am the only owner of this vehicle and it has 84k miles on it. This is the OEM set up from factory. Is my ballast getting ready to take a dump?
Sounds like could be ballast issue. Worth replacing before going for new a new lamp. Check this thread for info https://www.camaro5.com/forums/showthread.php?t=539523

Post a follow up if you windup replacing it.
camguynj is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:00 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.