Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Emblempros
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Cosmetics and Lighting Modification Discussions


Reply
 
Thread Tools
Old 10-03-2019, 02:20 PM   #1
SL33P3R
 
SL33P3R's Avatar
 
Drives: 2013 Camaro SS Vert
Join Date: Apr 2019
Location: Otsego, MI
Posts: 22
Diode Dynamics Grill Lights

Reaching out for some more help. While Diode Dynamics has been great trying to fix my issue we are running out of ideas so I decided to try the forum as I know several of you have these kits.

I installed their multi-color grill LED kit. Great kit. Easy install. But after 3 LED strips and 2 controllers I still can't work out the gremlins. I get the solid green light which indicates a polarity issue. I flip the 4 wire connector and I get nothing. For power I used a fuse tap in the driver's side fuse box and tapped one of the 20 amp accessory fuses so the LEDs are on/off with the ignition. For the ground on the controller I cleaned up the extra mounting stud for the stock air box since it was available after switching to a RotoFab. Last night I tried the hot direct to the positive post under the hood and the ground to the ground stud on the driver's inner fender. Same issue. Solid green one way and nothing when I flip the connector. The LED strip to 4 way splitter is the only connector that could be flipped.

Anyone else run into this? Suggestions? Going to try bypassing the switch tonight but I can't believe that would cause a polarity issue but both my contact at DD and I are out of ideas. Before I try a whole new kit I am hoping someone has an "you idiot. you need too....." solution for me.
SL33P3R is offline   Reply With Quote
Old 10-03-2019, 05:31 PM   #2
Sparko
 
Sparko's Avatar
 
Drives: 2010 Chevy Camaro SS
Join Date: May 2019
Location: Rochester, NY
Posts: 34
If this is an RGB LED setup and the 4-wire connector goes to the LED strip, flipping the connector won't work because 1 wire should be constant hot (or ground) and the other three would be opposite. This would depend on the type of diodes they designed it with whether it's common + or common -. If you have the LED strip disconnected you should be able to figure out this with a volt meter. What exactly did they say regarding the light indicating a polarity issue? That could mean different things, control module polarity or POU device polarity.

Sent from my Pixel 2 using Tapatalk
__________________
2010 Camaro 2SS
2018 Charger GT+
2005 Cavailer LS S/C - Retired (for now?)
Sparko is offline   Reply With Quote
Old 10-04-2019, 09:26 AM   #3
SL33P3R
 
SL33P3R's Avatar
 
Drives: 2013 Camaro SS Vert
Join Date: Apr 2019
Location: Otsego, MI
Posts: 22
Electricians confuse this carpenter. LOL. I will borrow a volt meter and find what wire in the strip plug is the "hot". Then if I find the "hot" on the controller I should be good??

I don't know the details on the green light being controller or POU. If I had to guess (not knowing much about LEDs) is that their plugs have the hot on one side and the green on the other side. If you reverse the plug you are feeding the hot direct into the green circuit causing the solid green. And if you reverse it you have the hot to hot, red to red, etc. Just a theory but makes sense to me.

Good news is that Diode Dynamics is sending me a whole new kit and are determined to make sure I a happy customer. That is stand up IMO. We hear of too many companies that just say "your problem" and move on.

Hopefully I get something figured out.
SL33P3R is offline   Reply With Quote
Old 10-04-2019, 10:27 AM   #4
Mike14bumblebee
 
Mike14bumblebee's Avatar
 
Drives: 2014 yellow 2SS/RS
Join Date: Apr 2015
Location: Stoney Creek, Ontario
Posts: 469
Double check all your connections are good and use dieletric grease. I have been having an issue with my halos that I will be correcting over the winter. Rewiring and soldering them and connecting inside the car instead of under the hood. Cant believe for the cost of these lights these companies cant put connectors on that will only connect one way. Simple and would eliminate probably a ton of their warranties. Thumbs up to DD though, love their products. too bad they dont make the coloured halos for 14-15s
__________________
K&N, Borla ATAK axle back, resonator delete, Speed Engineering headers,Vitesse, Zl1 wheels, ACS rocker panels, 1LE splitter
Mike14bumblebee is offline   Reply With Quote
Old 10-05-2019, 05:09 PM   #5
Sparko
 
Sparko's Avatar
 
Drives: 2010 Chevy Camaro SS
Join Date: May 2019
Location: Rochester, NY
Posts: 34
This is why you can't just flip the connector to fix the polarity. This is also the two different ways this could be made from the factory, common + or common -.

__________________
2010 Camaro 2SS
2018 Charger GT+
2005 Cavailer LS S/C - Retired (for now?)
Sparko is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:22 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.