Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vararam
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Other Generations > 3rd Generation Camaros


Reply
 
Thread Tools
Old 02-13-2020, 12:40 PM   #15
Rfrancis8
 
Drives: 2013 RS Camaro
Join Date: Feb 2020
Location: MT Vernon NY
Posts: 1
hey all, just wanted to shed some light on this camaro issue that just happened to me...The car would sit for long periods of time and i would come back to a dead battery.

I changed the batter numerous times and even changed the alternator but nothing. Eventually i took the car to aamco that discovered the parastic drain that came from the onstar connection which would turn on overnight causing the power drain and never shut off.

I was told i needed a communication interface replacement. Now aamco tried to order it from GM who refused to sell it and said i had to bring the car to a local GM...(so suspect considering GM purchased onstar then bankrupted it and kept the tech)

in any case i took the car to GM and they discovered the same thing and did a replacement which i got don on 2/12/2020 so waiting now to see if the issue arises again. Outside of all the money spent for battery changes and alternator changes the replacement with parts and labor was around $870

to be honest i think there should of been a recall for this or atleast some heads up from GM
Rfrancis8 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:38 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.