Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Solo Performance
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons


Reply
 
Thread Tools
Old 09-14-2018, 06:45 PM   #1
BT96SS
 
Drives: 2012 Camaro RS/SS
Join Date: Sep 2016
Location: Texas
Posts: 37
Still having trouble with SLP ud pulley

As the title states I am still having trouble with my SLP ud pulley. Ever since installed it squeals real bad when I turn the ac on. The belt that it calls for in the instructions is not a stretch fit belt and seems to be too long. If any of you have one on your car could you see what belt number you have and from what manufacturer. The belt i have is the gates belt it calls out for. It seems to loose to me. I have checked to make sure the pulleys are not misaligned and they look good. It used to just squeal for a few seconds when I turned the ac on but not its constant. I almost wish I would have just left enough alone. My car is a 2012 if that matters. Might be different from the 2010 that the instructions are for.
BT96SS is offline   Reply With Quote
Old 09-15-2018, 11:31 AM   #2
GONIF


 
GONIF's Avatar
 
Drives: 73 VETTE ,, 05 2500hd diesel,14 1LE
Join Date: Feb 2014
Location: The Left lane PHOENIX AZ
Posts: 2,369
Call SLP and tell them about it , pretty sure they have run into this B4.
__________________
OLD GUY FLYING FAST AND LOW
GONIF is offline   Reply With Quote
Old 09-16-2018, 01:35 AM   #3
alaskacamaro
 
alaskacamaro's Avatar
 
Drives: 2012 2SS 45TH Anniversary
Join Date: Mar 2012
Location: Kentucky
Posts: 715
Mine started squealing after 1200 miles. Turned out the underpulley bent inward sometime after install and the tech was amazed the belt hadnít completely ripped or pulled off. Called SLP of course but since itís had been past the 90 day mark, they were not going to do anything about it. Put the stock one back on and no issues since. Kept the bent pulley as a reminder to myself that just because a company buys a name doesnít mean you will be getting the same quality parts and service as the original. I hope your issue is not the same as mine....
__________________
PFADT stage 3 suspension kit, SW LTH, SW cat less retro exhaust, MGW short throw, 3.91 gears, MRR Z28 wheels, Roto Fab CAI, SLP underpully, 255cc ported heads, TSP 229/236 Cam, ZL1 pump, Street Slayer Twin Carbon clutch, ID850 injectors, Snow Stage III Meth kit
480whp/460wtq tuned by Dynosty
alaskacamaro is offline   Reply With Quote
Old 09-16-2018, 07:37 AM   #4
Chris49066SS
 
Chris49066SS's Avatar
 
Drives: 2010 Camaro SS
Join Date: Sep 2018
Location: TN
Posts: 42
Fluidampr is very reputable for their dampers. Pro Stock John on here uses the Powerbond and hasn't had any issues for many K miles, so i just went with the Powerbond damper off of GPIs website. Installing it this Friday!
__________________
GPI SS4 VVT Cam, Circle D 4k converter, 3.91 gears, Custom made Cold Air kit, TSP Longtube Headers, Powerbond damper, ADM trans cooler, 18" wheel, NTO5R drag radials, BMR trailing arms, Pegasus Solid Subframe Bushings
Chris49066SS is online now   Reply With Quote
Old 09-16-2018, 09:49 AM   #5
christianchevell
old school chevy rodder
 
christianchevell's Avatar
 
Drives: 2013 2SS/RS Manual,DM exhaust,CRT
Join Date: Jul 2012
Location: Oregon
Posts: 4,994
There were reported cases of the SLP underdrive pulleys falling apart just like stock pulleys and IMO they look cheap and as if they have no net effect dampening vibrations like a Fluidampr or ATI etc....so good luck there. Many just stay stock as the money for a good dampener is often overlooked in their budget ;short term need budget. Once on my last engine I bought a TSP underdrive; myself and my tuner looked at it and decided to not install it as it was just a couple hunks of metal separated by a rubber ring kind of old school junk which would do nothing really to stop harmful vibrations from being radically cammed with a rocking engine being hard on the timing chain and bearings...…


And BTW I do not underdrive the A/C fluidampr does not do that, the electric with my idle of 950 takes care of itself and truthfully Underdrives net like ZERO 0 nul zilch usually HP..... I got mine for the longevity of the engine. And BTW the directions for the Fluidampr even came with the wrong Gates belt # but had the right length WTF is up with stupid instructions monkey typing mofo's huh?
__________________
2013 2SS/RS LS3 M6 ,CRT, NPP, Forged 428 ls3 stroker, GMPP ported heads, Katech chain, Mast windage, Cam Motion Cam, trunnion upgrade, Stainless Power headers HFC, CAI w/kit, Vmax PTD, Fluidampr25% udp, LPW diff cover, BMR strut brace,trailing arms, toes, bushings, Rocket racing wheels,Toyo Proxes 4+, elite catch can, clutch reservoir, dash/body LED, DRL rewire, Sparks billet badges, Forza 3way, tint, MRT louvers, ZL1 spoiler, MGW short throw, Monster dual LT1S clutch, bleeder, support, high vol pump, Speed hut shift light, ACC flames stripes, Driven ls30 oil, NGK TR6IX , Granatelli wires.
christianchevell is offline   Reply With Quote
Old 09-16-2018, 10:49 AM   #6
Chris49066SS
 
Chris49066SS's Avatar
 
Drives: 2010 Camaro SS
Join Date: Sep 2018
Location: TN
Posts: 42
Thats like the 3rd instance I've heard of the wrong belt size for the Fluidampr.
__________________
GPI SS4 VVT Cam, Circle D 4k converter, 3.91 gears, Custom made Cold Air kit, TSP Longtube Headers, Powerbond damper, ADM trans cooler, 18" wheel, NTO5R drag radials, BMR trailing arms, Pegasus Solid Subframe Bushings
Chris49066SS is online now   Reply With Quote
Old 09-16-2018, 07:11 PM   #7
xc_SS/RS


 
Drives: 2010 Camaro SS/RS
Join Date: Mar 2014
Location: somewhere in MD
Posts: 4,042
Get an ATI super damper or fluidampr pulley and don't look back
__________________
2010 2SS/RS
vr-drx, ported TB, vr wedge, rod-mod intake, speed engineering LT's, 3" exhaust, ATI -10% pulley, MGW shifter, 160* t-stat, HP Tuners, some suspension work, stickers and a little weight loss. 12.72 @112.36 - improvements coming
xc_SS/RS is offline   Reply With Quote
Old 09-17-2018, 09:32 PM   #8
WHAMMO

 
WHAMMO's Avatar
 
Drives: 13' 1LE
Join Date: Apr 2012
Location: Canada
Posts: 2,248
Yeah my car developped a belt problem with my UD; got a squeaky AC belt. I changed it and tried some different lenghts and now the belts are noisy, like if theyre not aligned properly. It doesnt squeak anymore.

Mine is ASP . Im losing voltage when using AC, but I run a 18.5lbs clutch it might affect it more than before idk. Still I didnt have the clutch when it started, 1 year after the cam install. I have it since 2014, so its a good product imo.

Next is going to be either ATI or Fluid damper.
__________________
TSP 231/236 111 cammed 1LE
WHAMMO is offline   Reply With Quote
Old 09-19-2018, 09:32 AM   #9
BT96SS
 
Drives: 2012 Camaro RS/SS
Join Date: Sep 2016
Location: Texas
Posts: 37
I may just have to bite the bullet and have the factory one put back on. Sucks as I have to buy the belts over again. I looked at it again yesterday and it looked aligned correctly. When the ac kicked on I actually saw it stop turning and squeal. I would blame the ac but I was messing around with water under the hood and the belt was wet. So at this point I'm stumped.
BT96SS is offline   Reply With Quote
Old 09-19-2018, 11:50 AM   #10
charles71
 
charles71's Avatar
 
Drives: 2011 Camaro SS
Join Date: Aug 2015
Location: Southern Maryland
Posts: 84
I had the same issue when I had a SLP 25% under drive pulley installed. At parking lot speeds the steering wheel was all but impossible to turn and the car would stall repeatedly. I don't know how the shop did it but the belt was routed incorrectly. Once I noticed and corrected it never had a problem since.
__________________
Livernois Stage II Heads & Cam, LS7 Lifters, Ported Intake & Throttle Body, Rotofab CAI, BBK High Flow Fuel Rail @ Guage, Eaton Tru Trac Posi with 3.91 gears, 1200 HP Axels, Kooks Long tubes & full Corsa Exhaust, GM Hurst Short Throw Shifter, Mcleod Twin Disc, Vitesse Throttle Controller, 1.25" Lowering Springs, Strut Tower Brace, SLP 25% Underdrive Pulley, Apex reservoir relocation kit and air scoop.
charles71 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:10 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.