Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Solo Performance
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 01-11-2018, 02:05 AM   #1
rebelyell22


 
rebelyell22's Avatar
 
Drives: 2011 SIM 2SS/RS LS3
Join Date: Sep 2013
Location: Tupelo, MS
Posts: 5,702
PITA

On 12/29, exactly 2yrs after my original engine decided to grenade itself, a CEL popped up. I call the dealer, take it to them, and they diagnose and order parts. Not positive on the codes, but he said one of the banks was lean, crank sensor, and MAF sensor. Not sure how those correlate at all, but he’s the expert I guess. They get the parts and install, (plus canister vent solenoid??) and I got it back on Monday. I’ve literally driven 5 miles and I have a CEL again.

Glad I haven’t put those long tubes sitting in the garage on yet.
Attached Images
 
__________________
2011 2SS/RS built 8/24/10
rebelyell22 is offline   Reply With Quote
Old 01-11-2018, 08:24 AM   #2
frankwjr

 
frankwjr's Avatar
 
Drives: 2010 SS 2SS M6
Join Date: Aug 2016
Location: Smithsburg, Md.
Posts: 2,109
either have them give you the codes or go out and get an inexpensive OBDII reader...presume this is not a warranty?
__________________
2010 SS 2SS M6-Spectre CAI-JET TBS-JBA Shorty Headers-ARH H/F Cats-Doug Thorley axle back-MSD 12v coil harness mod-PAC 1218's-BTR 3/8 7.4 push rods-Powell Machine bronze rocker bushings-Prothane motor mounts-Prothane rear sub-frame inserts-BMR Trailing Arms & bushings-1LE 3.91's-1LE axles-Ford S-spring posi-mod-Tune by RDP dynoSteve!(Woot)-Daily Driver-120K!-12.7 at 112-1.9 60'(3.45's)-BFG Comp-2 Street Tire-stock size on ZL1 reps(20x8.5)(20x9.5)-DR's Nitto NT05R(305/45) on Motegi MT120 18x9.5-12.1 at 114-1.7 60'(3.91's) All work by me...
frankwjr is offline   Reply With Quote
Old 01-11-2018, 03:50 PM   #3
rebelyell22


 
rebelyell22's Avatar
 
Drives: 2011 SIM 2SS/RS LS3
Join Date: Sep 2013
Location: Tupelo, MS
Posts: 5,702
My scanner says P0446 and P0451. Any ideas?
__________________
2011 2SS/RS built 8/24/10
rebelyell22 is offline   Reply With Quote
Old 01-11-2018, 05:01 PM   #4
bayarea408
 
bayarea408's Avatar
 
Drives: 10' 2SS RS L99
Join Date: Mar 2015
Location: CA
Posts: 527
Quote:
Originally Posted by rebelyell22 View Post
My scanner says P0446 and P0451. Any ideas?
P0446 is a evap code. it may be the evap system. The system takes the vapors that evaporate from the gas in the tank and directs it to the engine. A valve or something in the mix is faulty.

First thing i would do is double check the gas cap is sealed tight from air leakage. I would reset the light, if you do not own a OBD scanner go get one. Take off the cap inspect it for anything wierd, tighten her on go reset the check engine. It may not return.

P0451 is a sensor inside your gas tank that talks to the computer and lets it know pressures in the gas tank. A leaky gas cap or evap system will trigger these 2.

ENJOI!
__________________
2010 2SS/RS -Huron Single Turbo Precision 76/75 cea
bayarea408 is offline   Reply With Quote
Old 01-11-2018, 05:35 PM   #5
rebelyell22


 
rebelyell22's Avatar
 
Drives: 2011 SIM 2SS/RS LS3
Join Date: Sep 2013
Location: Tupelo, MS
Posts: 5,702
Quote:
Originally Posted by bayarea408 View Post
P0446 is a evap code. it may be the evap system. The system takes the vapors that evaporate from the gas in the tank and directs it to the engine. A valve or something in the mix is faulty.

First thing i would do is double check the gas cap is sealed tight from air leakage. I would reset the light, if you do not own a OBD scanner go get one. Take off the cap inspect it for anything wierd, tighten her on go reset the check engine. It may not return.

P0451 is a sensor inside your gas tank that talks to the computer and lets it know pressures in the gas tank. A leaky gas cap or evap system will trigger these 2.

ENJOI!
It's one of the valves. I was putting gas in it earlier and it dumped fuel all over the ground. Zero went in the tank. It took me a minute to notice, because it is raining, but luckily I did.
__________________
2011 2SS/RS built 8/24/10
rebelyell22 is offline   Reply With Quote
Old 01-11-2018, 05:56 PM   #6
frankwjr

 
frankwjr's Avatar
 
Drives: 2010 SS 2SS M6
Join Date: Aug 2016
Location: Smithsburg, Md.
Posts: 2,109
Holy crap! pray tell which "valve" you speak of..except for over filling and having it come back up the fill pipe there should no way for gas to exit the tank. Has the tank been dropped before for any work?
__________________
2010 SS 2SS M6-Spectre CAI-JET TBS-JBA Shorty Headers-ARH H/F Cats-Doug Thorley axle back-MSD 12v coil harness mod-PAC 1218's-BTR 3/8 7.4 push rods-Powell Machine bronze rocker bushings-Prothane motor mounts-Prothane rear sub-frame inserts-BMR Trailing Arms & bushings-1LE 3.91's-1LE axles-Ford S-spring posi-mod-Tune by RDP dynoSteve!(Woot)-Daily Driver-120K!-12.7 at 112-1.9 60'(3.45's)-BFG Comp-2 Street Tire-stock size on ZL1 reps(20x8.5)(20x9.5)-DR's Nitto NT05R(305/45) on Motegi MT120 18x9.5-12.1 at 114-1.7 60'(3.91's) All work by me...
frankwjr is offline   Reply With Quote
Old 01-11-2018, 06:13 PM   #7
rebelyell22


 
rebelyell22's Avatar
 
Drives: 2011 SIM 2SS/RS LS3
Join Date: Sep 2013
Location: Tupelo, MS
Posts: 5,702
Quote:
Originally Posted by frankwjr View Post
Holy crap! pray tell which "valve" you speak of..except for over filling and having it come back up the fill pipe there should no way for gas to exit the tank. Has the tank been dropped before for any work?
You have to drop the tank for replace the vent solenoid. I think it’s a faulty part, they didn’t put a gasket in, or it’s the purge solenoid. I’m not taking it back until they fix this shit.

To answer your question, it’s under extended warranty. It’s saved my ass so far. Whole new engine and now this.
__________________
2011 2SS/RS built 8/24/10
rebelyell22 is offline   Reply With Quote
Old 01-11-2018, 06:29 PM   #8
bayarea408
 
bayarea408's Avatar
 
Drives: 10' 2SS RS L99
Join Date: Mar 2015
Location: CA
Posts: 527
Quote:
Originally Posted by rebelyell22 View Post
You have to drop the tank for replace the vent solenoid. I think it’s a faulty part, they didn’t put a gasket in, or it’s the purge solenoid. I’m not taking it back until they fix this shit.

To answer your question, it’s under extended warranty. It’s saved my ass so far. Whole new engine and now this.
i'd make the dealership tow it and fix it. sounds sketchy leaking gasoline. shit happens

When i cut a access door under the passenger rear seat to swap pumps i notice the "lock ring" is VERY TOUGH to get on and OFF. It also has a O ring that needs replacement when you do the job. I had a little leakage the first time out broke out the ring tool and a breaker bar and sinched it down made a pop! never leaked since.

Hopefully its no big deal and just something small, keep us updated.
__________________
2010 2SS/RS -Huron Single Turbo Precision 76/75 cea
bayarea408 is offline   Reply With Quote
Old 01-11-2018, 06:33 PM   #9
rebelyell22


 
rebelyell22's Avatar
 
Drives: 2011 SIM 2SS/RS LS3
Join Date: Sep 2013
Location: Tupelo, MS
Posts: 5,702
Quote:
Originally Posted by bayarea408 View Post
i'd make the dealership tow it and fix it. sounds sketchy leaking gasoline. shit happens
That’s where it is now. I was like, “I don’t want it back until it’s fixed” lol
__________________
2011 2SS/RS built 8/24/10
rebelyell22 is offline   Reply With Quote
Old 01-15-2018, 06:44 PM   #10
rebelyell22


 
rebelyell22's Avatar
 
Drives: 2011 SIM 2SS/RS LS3
Join Date: Sep 2013
Location: Tupelo, MS
Posts: 5,702
Got it back on Saturday and drove it for the first time since. Drove 10 miles and I have another CEL P0455
__________________
2011 2SS/RS built 8/24/10
rebelyell22 is offline   Reply With Quote
Old 01-16-2018, 07:21 PM   #11
TheFlyingBananaSS

 
TheFlyingBananaSS's Avatar
 
Drives: 2013 Camaro 2SS
Join Date: Feb 2017
Location: Long Island, NY
Posts: 964
__________________
TheFlyingBananaSS is offline   Reply With Quote
Old 01-16-2018, 09:48 PM   #12
rebelyell22


 
rebelyell22's Avatar
 
Drives: 2011 SIM 2SS/RS LS3
Join Date: Sep 2013
Location: Tupelo, MS
Posts: 5,702
Quote:
Originally Posted by TheFlyingBananaSS View Post
Yep. Headers are sitting in the trunk waiting on them to fix this. They tried to say the fuel trims were all over the place because of my CAI and muffler delete and it has had a tune on it before. I was like those mods would have zero effect on the evap system, and if I had a tune it wouldn’t be running so rich. I just wish they’d suck it up and fix my shit lol
__________________
2011 2SS/RS built 8/24/10
rebelyell22 is offline   Reply With Quote
Old 01-17-2018, 12:26 AM   #13
bayarea408
 
bayarea408's Avatar
 
Drives: 10' 2SS RS L99
Join Date: Mar 2015
Location: CA
Posts: 527
ok that makes sense now, you have a modified second hand car. God knows what was done to it. thank god you have a warranty.
__________________
2010 2SS/RS -Huron Single Turbo Precision 76/75 cea
bayarea408 is offline   Reply With Quote
Old 01-17-2018, 01:44 AM   #14
rebelyell22


 
rebelyell22's Avatar
 
Drives: 2011 SIM 2SS/RS LS3
Join Date: Sep 2013
Location: Tupelo, MS
Posts: 5,702
Quote:
Originally Posted by bayarea408 View Post
ok that makes sense now, you have a modified second hand car. God knows what was done to it. thank god you have a warranty.
No. I kept it bone stock for the longest, then did the muffler delete a few years ago (before the new engine was put in in late 2015.Oil pump failed—warranty company doesn’t cover oil pumps, so they put a whole new crate motor in). The ECU hasn’t been touched unless they had to when they put the new engine in....idk how that works. Not sure why they would think a stock M6 Camaro would be tuned, vs a bad sensor or something somewhere. I just got the headers and I’m not putting them on until they get this fixed, so they CANT use a tune as an excuse.
Attached Images
 
__________________
2011 2SS/RS built 8/24/10
rebelyell22 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:58 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.