Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Bigwormgraphix
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Other Generations > 3rd Generation Camaros


Reply
 
Thread Tools
Old 08-01-2011, 05:44 AM   #1
BARRYJAPAN
 
Drives: 85 CAMARO BERLINETTA
Join Date: Jul 2011
Location: WINTER HAVEN, FLORIDA
Posts: 6
85 BERLINETTA

I just got an 85, and it doesn't want to stay idling, also, when I changed the plugs, the 2 front ones had oil on them, but not any others. Any ideas would be greatly appreciated.
BARRYJAPAN is offline   Reply With Quote
Old 08-01-2011, 09:17 AM   #2
Nvincent4708
1st State Camaro
 
Nvincent4708's Avatar
 
Drives: 2014 1SS M6
Join Date: Nov 2010
Location: Cecil County, MD
Posts: 25,812
If it was sitting for a while it's likely oil seeped down the valve guide seals..that could cause oil to get in the cylinders on the plugs.

Which engine is in it?

I know the 2.8's were good for clogging the fuel filters after sitting and that would cause it to not idle.

How long was the car sitting?
Nvincent4708 is offline   Reply With Quote
Old 08-01-2011, 11:55 AM   #3
BARRYJAPAN
 
Drives: 85 CAMARO BERLINETTA
Join Date: Jul 2011
Location: WINTER HAVEN, FLORIDA
Posts: 6
The gent I got it from said it had been sitting for about 2 months, prior to that it was his daily driver. He has owned it for 15 yrs. It is a 2.8.
BARRYJAPAN is offline   Reply With Quote
Old 08-01-2011, 01:21 PM   #4
Nvincent4708
1st State Camaro
 
Nvincent4708's Avatar
 
Drives: 2014 1SS M6
Join Date: Nov 2010
Location: Cecil County, MD
Posts: 25,812
2.8.. there should be a filter in the back of the carb where the fuel line screws in.. bet it needs replaced
Nvincent4708 is offline   Reply With Quote
Old 08-01-2011, 01:33 PM   #5
BARRYJAPAN
 
Drives: 85 CAMARO BERLINETTA
Join Date: Jul 2011
Location: WINTER HAVEN, FLORIDA
Posts: 6
Ok i found the filter right underneath the rear passenger seat, i will go and buy a new filter later today and hope that fix's the problem. thank you very much for your help. I will post whether it works or not. Fingers crossed.
BARRYJAPAN is offline   Reply With Quote
Old 08-01-2011, 01:45 PM   #6
Nvincent4708
1st State Camaro
 
Nvincent4708's Avatar
 
Drives: 2014 1SS M6
Join Date: Nov 2010
Location: Cecil County, MD
Posts: 25,812
filter under the seat?

maybe it changed from 82 to 85. I remember back of carburetor.
Nvincent4708 is offline   Reply With Quote
Old 08-01-2011, 03:13 PM   #7
BARRYJAPAN
 
Drives: 85 CAMARO BERLINETTA
Join Date: Jul 2011
Location: WINTER HAVEN, FLORIDA
Posts: 6
Mine is FI, well just put a new filter on it and it was idling for about 8 mins before it shut off, which is 7.9 mins longer then what it was doing. it is still running a little rough but it does need an oil change and it is probably still running on the old fuel that was left in the tank. Thank you ever so much for helping me, because a lot of other people said that it was the idle air control valve and the MAF, and a bunch of other parts that cost a lot so u just saved me a lot of money thank you again
BARRYJAPAN is offline   Reply With Quote
Old 08-01-2011, 11:46 PM   #8
Supercamaro64
Right, right.
 
Supercamaro64's Avatar
 
Drives: 79 Z28, 86 Camaro, 94 Burb 4x4
Join Date: Dec 2008
Location: Fond du Lac, Wisconsin
Posts: 1,351
i have an 86 berli with the 2.8. i have had extremely few problems with this car, especially considering i got it for really cheap. treat them right, and these little engines wont let you down! new oil/oil filter/gas can go a long way!! good luck with the car!!
__________________
"You wanna lay the fate of the world on the kids camaro? Thats cool."
"When reporters asked what it was, one official stated, 'It's a small, vicious animal that eats Mustangs.'"
The Creampuff Fleet-
Supercamaro64 is offline   Reply With Quote
Old 08-02-2011, 07:21 AM   #9
Nvincent4708
1st State Camaro
 
Nvincent4708's Avatar
 
Drives: 2014 1SS M6
Join Date: Nov 2010
Location: Cecil County, MD
Posts: 25,812
Quote:
Originally Posted by BARRYJAPAN View Post
Mine is FI, well just put a new filter on it and it was idling for about 8 mins before it shut off, which is 7.9 mins longer then what it was doing. it is still running a little rough but it does need an oil change and it is probably still running on the old fuel that was left in the tank. Thank you ever so much for helping me, because a lot of other people said that it was the idle air control valve and the MAF, and a bunch of other parts that cost a lot so u just saved me a lot of money thank you again
Try to drain the tank and put fresh fuel. Then see if it'll start and idle. If not, check the fuel pressure if you access to a gauge. I'm sure it is something fairly simple.
Nvincent4708 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Berlinetta Control Pods Supercamaro64 3rd Generation Camaros 32 02-23-2015 09:42 PM
FOR SALE - 1984 BERLINETTA B2k4E 3rd Gen Marketplace 3 07-31-2011 12:49 AM
Got A Berlinetta Digital Dash F/S Motorhead79 3rd Gen Marketplace 14 02-24-2011 01:03 AM
79' BERLINETTA Camarino 1st & 2nd Generation Camaros 34 04-19-2009 11:10 PM
1986 Berlinetta. Help? Supercamaro64 3rd Generation Camaros 4 02-13-2009 01:00 PM


All times are GMT -5. The time now is 06:11 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.