Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Bigwormgraphix
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 07-15-2021, 11:00 PM   #1
niceguy
 
Drives: 2013 Camaro
Join Date: Jan 2015
Location: Torrance, California
Posts: 24
Can you guys help. No sound turn signals

Hi I have a 2013 camaro that intermittently will not play the tick sound for its turn signals and also the unbuckled seat belt alarm audio. Researching the problem seem to indicate a bad BCM module.

Is there anyone out there who has had this problem. How much does the dealer charge for repairs.
niceguy is offline   Reply With Quote
Old 07-16-2021, 12:10 AM   #2
Ponchonutty
 
Ponchonutty's Avatar
 
Drives: 2012 SS L99 Converible
Join Date: Mar 2016
Location: New Washington, Ohio
Posts: 606
Have factory stereo and sound out of your front speakers? If not, rplace front door speakers. They are junk. Your chimes work through them. Don’t buy $500 speakers either unless you are upgrading the stereo.
__________________
2012 L99 Convertible SS
Tooley Racing Stage 2 DOD delete, 3,200 stall converter, Shorty headers and custom stainless exhaust, CAI, and tune as mods
Ponchonutty is offline   Reply With Quote
Old 07-16-2021, 12:27 AM   #3
niceguy
 
Drives: 2013 Camaro
Join Date: Jan 2015
Location: Torrance, California
Posts: 24
Quote:
Originally Posted by Ponchonutty View Post
Have factory stereo and sound out of your front speakers? If not, rplace front door speakers. They are junk. Your chimes work through them. Don’t buy $500 speakers either unless you are upgrading the stereo.
Where are the front speakers. I assuming you don't mean the door speakers.

Edit: You said front door speaker, I missed that because I had a brain fart. But still do you mean the small tweeter speaker correct.

Last edited by niceguy; 07-16-2021 at 01:03 AM.
niceguy is offline   Reply With Quote
Old 07-16-2021, 01:56 AM   #4
Rob3D

 
Rob3D's Avatar
 
Drives: Car
Join Date: Jan 2013
Location: Alabama
Posts: 1,166
The problem is my bad BCM module symptoms can be very different than yours. Codes didnít show on my diagnostic/code reader, but when the dealership hooked up his diagnostic thingy, it lit up like a xmas tree. That OEM BCM took a while to get inÖback ordered due to covid I reckon.
Rob3D is offline   Reply With Quote
Old 07-16-2021, 02:35 AM   #5
niceguy
 
Drives: 2013 Camaro
Join Date: Jan 2015
Location: Torrance, California
Posts: 24
Quote:
Originally Posted by Rob3D View Post
The problem is my bad BCM module symptoms can be very different than yours. Codes didnít show on my diagnostic/code reader, but when the dealership hooked up his diagnostic thingy, it lit up like a xmas tree. That OEM BCM took a while to get inÖback ordered due to covid I reckon.
I just put my head up to the speakers in my driver door while the turn sounds were working and discovered the chimes come from BOTH speakers in the door.

I am going to have to pull over and troubleshooting the damn thing when the audio cuts out again. I pray it's the speaker because a 1k repair for the BCM will most likely convince me to get rid of the car.

Quick history lesson my camaro AC died 5mths and cost 3k to fix, luckily the warranty was still good to pay for that repair but as of now my warranty is expired.
niceguy is offline   Reply With Quote
Old 07-16-2021, 05:13 AM   #6
Ponchonutty
 
Ponchonutty's Avatar
 
Drives: 2012 SS L99 Converible
Join Date: Mar 2016
Location: New Washington, Ohio
Posts: 606
Quote:
Originally Posted by niceguy View Post
Where are the front speakers. I assuming you don't mean the door speakers.

Edit: You said front door speaker, I missed that because I had a brain fart. But still do you mean the small tweeter speaker correct.
Yup. The radio door speakers
__________________
2012 L99 Convertible SS
Tooley Racing Stage 2 DOD delete, 3,200 stall converter, Shorty headers and custom stainless exhaust, CAI, and tune as mods
Ponchonutty is offline   Reply With Quote
Old 07-17-2021, 06:52 PM   #7
niceguy
 
Drives: 2013 Camaro
Join Date: Jan 2015
Location: Torrance, California
Posts: 24
OK guys after further troubleshooting I have discovered this much. My turn signal chime died again while driving so I pulled over for some probing.

I turned my turn signal on and nothing. So I then turned on my radio and proceeded to route all audio output through the driver door and as soon as I did the audio from the radio just went completely silent. I then proceeded to max the volume out and bam both the turn signal chime and radio came back.

Now considering this information is it more highly probable that like Ponchonutty told me it is indeed the speaker or could this still point to a a bad BCM. Also if it is a speaker issue which should I replace the woofer or tweeter since sound comes from both simultaneously.
niceguy is offline   Reply With Quote
Old 07-17-2021, 11:34 PM   #8
Ponchonutty
 
Ponchonutty's Avatar
 
Drives: 2012 SS L99 Converible
Join Date: Mar 2016
Location: New Washington, Ohio
Posts: 606
Quote:
Originally Posted by niceguy View Post
OK guys after further troubleshooting I have discovered this much. My turn signal chime died again while driving so I pulled over for some probing.

I turned my turn signal on and nothing. So I then turned on my radio and proceeded to route all audio output through the driver door and as soon as I did the audio from the radio just went completely silent. I then proceeded to max the volume out and bam both the turn signal chime and radio came back.

Now considering this information is it more highly probable that like Ponchonutty told me it is indeed the speaker or could this still point to a a bad BCM. Also if it is a speaker issue which should I replace the woofer or tweeter since sound comes from both simultaneously.
1000% speaker. Iím telling ya Iíve replaced enough of them. Just had a 17 Silverado that EVERY SINGLE SPEAKER except the a pillar ones were bad!!!!
__________________
2012 L99 Convertible SS
Tooley Racing Stage 2 DOD delete, 3,200 stall converter, Shorty headers and custom stainless exhaust, CAI, and tune as mods
Ponchonutty is offline   Reply With Quote
Old 07-18-2021, 02:27 AM   #9
niceguy
 
Drives: 2013 Camaro
Join Date: Jan 2015
Location: Torrance, California
Posts: 24
Quote:
Originally Posted by Ponchonutty View Post
1000% speaker. Iím telling ya Iíve replaced enough of them. Just had a 17 Silverado that EVERY SINGLE SPEAKER except the a pillar ones were bad!!!!
Thanks man, which speaker though woofer or tweeter
niceguy is offline   Reply With Quote
Old 07-19-2021, 07:23 AM   #10
Ponchonutty
 
Ponchonutty's Avatar
 
Drives: 2012 SS L99 Converible
Join Date: Mar 2016
Location: New Washington, Ohio
Posts: 606
Woofer. The tweets rarely go bad
__________________
2012 L99 Convertible SS
Tooley Racing Stage 2 DOD delete, 3,200 stall converter, Shorty headers and custom stainless exhaust, CAI, and tune as mods
Ponchonutty is offline   Reply With Quote
Old 11-04-2021, 03:34 PM   #11
niceguy
 
Drives: 2013 Camaro
Join Date: Jan 2015
Location: Torrance, California
Posts: 24
Quote:
Originally Posted by Ponchonutty View Post
Woofer. The tweets rarely go bad
That wasn't the problem, I replaced both the woofer and tweeter and the problem is still tbere.
niceguy is offline   Reply With Quote
Old 11-30-2021, 04:44 PM   #12
Ponchonutty
 
Ponchonutty's Avatar
 
Drives: 2012 SS L99 Converible
Join Date: Mar 2016
Location: New Washington, Ohio
Posts: 606
Quote:
Originally Posted by niceguy View Post
That wasn't the problem, I replaced both the woofer and tweeter and the problem is still tbere.
What did you replace them with? If you replaced them with the wrong ohm size that can cause it not to play. Iíve seen corrosion inside the speaker plugs too. Could also be bad wiring inside door boot.
__________________
2012 L99 Convertible SS
Tooley Racing Stage 2 DOD delete, 3,200 stall converter, Shorty headers and custom stainless exhaust, CAI, and tune as mods
Ponchonutty is offline   Reply With Quote
Old 12-04-2021, 11:23 AM   #13
Moto-Mojo
Fast Cars and Old Guitars
 
Moto-Mojo's Avatar
 
Drives: 2015 2SS RS (L99, baby!)
Join Date: Apr 2012
Location: N. CA
Posts: 3,652
Iím half (or more) deaf. I havenít heard a turn signal clicking since 1995! Or birds, crickets, wife, etc. No problem!
__________________
ďI donít want to belong to any club that would have me as a member.Ē - Groucho Marx
Moto-Mojo is offline   Reply With Quote
Old 10-02-2022, 08:32 PM   #14
niceguy
 
Drives: 2013 Camaro
Join Date: Jan 2015
Location: Torrance, California
Posts: 24
Quote:
Originally Posted by Ponchonutty View Post
What did you replace them with? If you replaced them with the wrong ohm size that can cause it not to play. Iíve seen corrosion inside the speaker plugs too. Could also be bad wiring inside door boot.
I replaced it with a OEM part. 2 ohm 50 watt
niceguy is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:50 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2022, vBulletin Solutions, Inc.