Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Rick@Livernois
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics > Engine | Exhaust | Bolt-On | Drivetrain Modifications


Reply
 
Thread Tools
Old 01-24-2018, 01:52 PM   #1
Slvr-camaro15
 
Slvr-camaro15's Avatar
 
Drives: 2010 SS /RS L99
Join Date: Sep 2017
Location: Long Island ,Ny
Posts: 256
Help ! CEL !! P507 code

Hello there guys . Just had the check engine light go on today . I'm a way -moderate pace driver . Took it to AutoZone to get the read on the code. It's P0507 . Air control system RPM Higher than expected. I am in no way mechanically savy so this kind of threw a curve ball at me . Looking for any explanations or solutions . Thank you in advance.
__________________
Borla atak catback , Cold air inductions CAI , BO WHITE ported TB , 1-7/8 speed engineering Longtubes with cat delete , DYNO STEVE TUNED .
Slvr-camaro15 is offline   Reply With Quote
Old 01-24-2018, 02:18 PM   #2
hammdo
'It's an experiment'
 
hammdo's Avatar
 
Drives: [COTW 2/09/15] '11 GPI LSA SC Z/LE
Join Date: May 2014
Location: Dallas TX
Posts: 7,347
Quote:
Originally Posted by Slvr-camaro15 View Post
Hello there guys . Just had the check engine light go on today . I'm a way -moderate pace driver . Took it to AutoZone to get the read on the code. It's P0507 . Air control system RPM Higher than expected. I am in no way mechanically savy so this kind of threw a curve ball at me . Looking for any explanations or solutions . Thank you in advance.
Double post?

-Don
__________________
747 RWHP 794 RWTQ
"Horsepower sells cars, torque wins races." - Enzo Ferrari
See My Build: http://www.camaro5.com/forums/showthread.php?t=385577
hammdo is offline   Reply With Quote
Old 01-24-2018, 02:20 PM   #3
Slvr-camaro15
 
Slvr-camaro15's Avatar
 
Drives: 2010 SS /RS L99
Join Date: Sep 2017
Location: Long Island ,Ny
Posts: 256
Yes .my apologies.i wasn't sure if I had posted it in the right forum the first time .
__________________
Borla atak catback , Cold air inductions CAI , BO WHITE ported TB , 1-7/8 speed engineering Longtubes with cat delete , DYNO STEVE TUNED .
Slvr-camaro15 is offline   Reply With Quote
Old 01-24-2018, 02:33 PM   #4
JB'sZL1
 
Drives: 2013 ZL1
Join Date: May 2017
Location: Milwaukee
Posts: 737
I would first suspect the cai or sensor.
JB'sZL1 is offline   Reply With Quote
Old 01-24-2018, 03:02 PM   #5
Slvr-camaro15
 
Slvr-camaro15's Avatar
 
Drives: 2010 SS /RS L99
Join Date: Sep 2017
Location: Long Island ,Ny
Posts: 256
Yes .my apologies.i wasn't sure if I had posted it in the right forum the first time .
__________________
Borla atak catback , Cold air inductions CAI , BO WHITE ported TB , 1-7/8 speed engineering Longtubes with cat delete , DYNO STEVE TUNED .
Slvr-camaro15 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:24 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.