Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Bigwormgraphix
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Member Car Journals


Reply
 
Thread Tools
Old 12-08-2013, 05:03 PM   #155
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 397
Today I installed some oracle ghost side markers that I picked up at a h-town Camaro club gathering last night.







__________________
PMJ is offline   Reply With Quote
Old 12-24-2013, 10:54 AM   #156
Cool AirZ28
 
Cool AirZ28's Avatar
 
Drives: 2013 Black Camaro 2SS/RS Convert.
Join Date: Jun 2013
Location: Sauk Village, Illinois
Posts: 506
Nice build man
__________________
2013 Camaro 2SS/RS-Smoked tail lights and side markers, HID log lights, & LED lighting inside/outside the car, SJM LED Cupholder, SJM full dashboard ABL lighting, ZL1 Rockers, 1LE Splitter, Showstopper LED Mirrors, Showstopper LED Side Markers, & Showstopper Heat Extractor Hood, 20" Niche Concourse ZL1 Styled wheels 20X8.5 & 20X10 with 275/40/20 & 315/35/20 Nitto Invos, Black Gorilla Lug Nuts/Locks, Black Billet Elite Camaro License Plate Holder, and Hydro Dipped Speedo/Shifter/AC-Heat Bezels.
Cool AirZ28 is offline   Reply With Quote
Old 12-27-2013, 09:35 AM   #157
TrekGTO

 
TrekGTO's Avatar
 
Drives: 05 GTO / JETTA TDI
Join Date: Jan 2012
Location: St Pete Fl
Posts: 624
Did you ever get a Chiller that works?
TrekGTO is offline   Reply With Quote
Old 12-27-2013, 01:53 PM   #158
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 397
Quote:
Originally Posted by Cool AirZ28 View Post
Nice build man

Thanks.

Quote:
Originally Posted by TrekGTO View Post
Did you ever get a Chiller that works?

So Tracy at RX sent me a bigger chiller (30 plate vs 20 plate). I have not had time to change it out yet. I'm still little worries about the competition switch. Haven't had any luck with it. Going to try and fix it when I change out the chiller. I hope to do it next week. I'll post up results.

I definitely appreciate Tracy working with me on this. He gets a bad wrap, but I think he means well. Just hard for these performance shops to go from local to national overnight.
__________________
PMJ is offline   Reply With Quote
Old 12-31-2013, 07:18 PM   #159
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 397
Road race at NOLA Motorsports park

I went road racing again Sunday. I'm really liking this. I have my StopTech rotors and cobalt friction brake pads on the way. Unfortunately I may have needed them Sunday...I ran off the track going into turn a little hot... There was minor damage...you can see in the video the back panel peeled off a bit. However, as I was trying to clean off the mud and grass from underneath...I wasn't paying attention and jack slid off and punctured my radiator... What a dumb ass...

Video of my fasted lap and when I slid off track (from rear and front):
http://youtu.be/eDSs2GJabEQ


I installed my custom RPM transmission last week...it worked fine, but I still can't shift to 5th over 6K rpm...wth?

I'll be working on my new nitrous kit, brake upgrades, and bigger chiller between now and my next drag race event on Jan 26th at Royal Purple raceway (Home of Camaro Fest 2014 ).
__________________
PMJ is offline   Reply With Quote
Old 01-01-2014, 11:50 AM   #160
TrekGTO

 
TrekGTO's Avatar
 
Drives: 05 GTO / JETTA TDI
Join Date: Jan 2012
Location: St Pete Fl
Posts: 624
Quote:
Originally Posted by PMJ View Post

I'm still little worries about the competition switch. Haven't had any luck with it. Going to try and fix it when I change out the chiller. I hope to do it next week. I'll post up results.
All the RX kits I removed had the wrong switch, he is still using my idea but an On/Off switch so if yours is wired the same you need to get an ON/ON switch. This gives the Freon solenoid ground in one position and the LED ground in the other. I could send you an old diagram or you could go to my new setup that has 2 relays primarily for ¼ mile. Let me know if I can hook you up, one of my wiring harnesses would not fit, things are in a different location but the diagram still applies.
TrekGTO is offline   Reply With Quote
Old 01-01-2014, 06:42 PM   #161
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 397
Quote:
Originally Posted by TrekGTO View Post
All the RX kits I removed had the wrong switch, he is still using my idea but an On/Off switch so if yours is wired the same you need to get an ON/ON switch. This gives the Freon solenoid ground in one position and the LED ground in the other. I could send you an old diagram or you could go to my new setup that has 2 relays primarily for ¼ mile. Let me know if I can hook you up, one of my wiring harnesses would not fit, things are in a different location but the diagram still applies.
Sure. Please send me the diagram and i'll check it out when I get around to testing it.

Thanks!
__________________
PMJ is offline   Reply With Quote
Old 01-02-2014, 06:01 AM   #162
Kartashian
SoCal HT5
 
Kartashian's Avatar
 
Drives: The Punisher
Join Date: Oct 2012
Location: Lebanon
Posts: 647
Happy New Year!!
Best wishes...
__________________
Kartashian is offline   Reply With Quote
Old 01-04-2014, 05:22 PM   #163
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 397
Quote:
Originally Posted by Kartashian View Post
Happy New Year!!
Best wishes...
thanks, Happy New Year to you too!
__________________
PMJ is offline   Reply With Quote
Old 01-05-2014, 01:37 PM   #164
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 397
PMJ's 2SS/RS Whipped 416 M6 aka BlackWidow [COTW 6/10/13]

So I didn't get to install my Nitrous and brake upgrades over the holidays like I hoped, but I did get my RPM transmission installed and repaired my radiator from stupid incident at NOLA Motorsports park last Sunday.

Anyway, I made it out to RPR (hope of the next C5 Fest) Friday night and set a new personal best 10.72 @ 137. It was ridiculously busy...I was there 7 hours never got out of line and got 3 runs in. Here are some videos:

My first 2 runs...lots of angles:
http://youtu.be/MxYy2s7IUfE

Just my 10.72 run...
http://youtu.be/k8T2E-Mij2U

Here is the video of my 3rd run. I paired up with Jaime in BeaSSt...he took the hole shot, but he missed 3rd gear. It would have been a great finish. I ran a 10.8.
http://youtu.be/Y3jTB8ZgvKI
__________________

Last edited by PMJ; 01-05-2014 at 05:15 PM.
PMJ is offline   Reply With Quote
Old 01-30-2014, 12:26 AM   #165
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 397
I raced last Sunday at Royal Purple again at the Texas Speed Syndicates Fast 30 event... I just got my nitrous system installed and was excited.

Turns out I brought a broken car...my whipple belt tensioner pin broke and I wasn't getting any boost. Made a new pin from a bolt. Drilled hole there the original pin was and was back in business.

Nitrous increased my trap 7 mph...to 144. And lowered my et .3. But I think there's more to be gained.

http://youtu.be/NM4WKl2PWSc
__________________
PMJ is offline   Reply With Quote
Old 01-30-2014, 08:26 AM   #166
10 2SS/RS 6M
 
10 2SS/RS 6M's Avatar
 
Drives: 2010 Camaro 2SS/RS 6M Black-s/s
Join Date: Oct 2010
Location: Philadelphia, PA
Posts: 390
Looking good!
I see your getting your 60 foot times to 1.5's! that's not bad at all!
What gear are you running for the 1/4 mile, the 4.11's still?
I was thinking if I ran a 1.5 60 foot I'd be at 12.2's! Man I can't wait to I really dig in mine! Track opens in a couple months.
Can't wait to try my new twin disc clutch!
Have fun be safe.
George.
__________________
SLP- long tube headers, hi flow cats w/full SLP 3'' PowerFlo exhaust incl/X-pipe, 160 degree stat, SLP Blackwing CAI. Dyno tuned by ECS-407/409RWHP&TQ. BMR- trailing arms w/poly knuckle bushings, toe links, cradle bushings and differential bushings. QA1 rear lower control arms. Hurst short throw shifter, DSS- level 4 axles, DSS- aluminum driveshaft, Pfadt- sport 1.5" rear sway-bar. SPOHN 1.25" front sway-bar. Monster LT1-S twin clutch. Prothane motor mounts. Best 1/4 mile so far- 12:70ET @ 112.24 MPH w/ 2.06 60', 2010.
10 2SS/RS 6M is offline   Reply With Quote
Old 01-30-2014, 08:54 AM   #167
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 397
Quote:
Originally Posted by 10 2SS/RS 6M View Post
Looking good!
I see your getting your 60 foot times to 1.5's! that's not bad at all!
What gear are you running for the 1/4 mile, the 4.11's still?
I was thinking if I ran a 1.5 60 foot I'd be at 12.2's! Man I can't wait to I really dig in mine! Track opens in a couple months.
Can't wait to try my new twin disc clutch!
Have fun be safe.
George.
Thanks George! I'm running a ZL1 driveline with the 3.73 rear gear. I'm crossing the 1/4 at 6500 rpm in 4th. I think the slicks give me more confidence on my launches, so i'm launching harder. But i drove a friends car on drag radials and pulled a 1.6 60'...so i think it has more to improving technique then necessarily the tires. Although i'm still happy with the purchase of the slicks.

It was at an event last April that i was talking to a guy (friend now) describing his launch technique...i've been trying to master ever since. Definitely helped. He runs 9s in a manual (Corevette)! The first time i tried it that night, i broke a stock axel . Ironic thing is i had my ZL1 driveline at home...just didn't have time to install yet.

THe ZL1 seems to hold up (and my RXT clutch). THe technique is simply on the launch to slowly release the clutch as you slowly move to open throttle. Feathers the clutch and keeps the engine power up. My biggest problem is a mental block concerned with spinning the tires....i very rarely get to WOT in 1st gear. That's something i'm going to concentrate on my next trip to the track!
__________________
PMJ is offline   Reply With Quote
Old 01-30-2014, 02:10 PM   #168
10 2SS/RS 6M
 
10 2SS/RS 6M's Avatar
 
Drives: 2010 Camaro 2SS/RS 6M Black-s/s
Join Date: Oct 2010
Location: Philadelphia, PA
Posts: 390
Quote:
Originally Posted by PMJ View Post
Thanks George! I'm running a ZL1 driveline with the 3.73 rear gear. I'm crossing the 1/4 at 6500 rpm in 4th. I think the slicks give me more confidence on my launches, so i'm launching harder. But i drove a friends car on drag radials and pulled a 1.6 60'...so i think it has more to improving technique then necessarily the tires. Although i'm still happy with the purchase of the slicks.

It was at an event last April that i was talking to a guy (friend now) describing his launch technique...i've been trying to master ever since. Definitely helped. He runs 9s in a manual (Corevette)! The first time i tried it that night, i broke a stock axel . Ironic thing is i had my ZL1 driveline at home...just didn't have time to install yet.

THe ZL1 seems to hold up (and my RXT clutch). THe technique is simply on the launch to slowly release the clutch as you slowly move to open throttle. Feathers the clutch and keeps the engine power up. My biggest problem is a mental block concerned with spinning the tires....i very rarely get to WOT in 1st gear. That's something i'm going to concentrate on my next trip to the track!
That's even better with 3.73's, did you try a 4.11 gear? I thought you did? My mistake if not.
I'm thinking of putting the 3.91's in my stock diff untill I can get the HammerHead, I already got the axles installed, just have to change the stubs that go into the diff to use my axles. I was going to go with the ZL1 diff, but I wanted to piece it together.
I broke a axle at the line too, I even got a video (in car) of it I will post when I get home from work.
I love the twin disc Monster clutch, I'm hoping I can slip it a little better then the single. I leave the line at only 2500 RPM, due to stock tires & gears, my average is about a 2.3 without killing it, wheel hop is violent if any better, with the stock low profile tires!
I'm used to an auto at the track so this is a learning experience with me too, but you got a whole lot more POWER then me, I'll get there soon enough!

Here's the video link when I broke an axle-


Here's one spinning 1st-


Here's one of my stock decent runs-
__________________
SLP- long tube headers, hi flow cats w/full SLP 3'' PowerFlo exhaust incl/X-pipe, 160 degree stat, SLP Blackwing CAI. Dyno tuned by ECS-407/409RWHP&TQ. BMR- trailing arms w/poly knuckle bushings, toe links, cradle bushings and differential bushings. QA1 rear lower control arms. Hurst short throw shifter, DSS- level 4 axles, DSS- aluminum driveshaft, Pfadt- sport 1.5" rear sway-bar. SPOHN 1.25" front sway-bar. Monster LT1-S twin clutch. Prothane motor mounts. Best 1/4 mile so far- 12:70ET @ 112.24 MPH w/ 2.06 60', 2010.

Last edited by 10 2SS/RS 6M; 01-30-2014 at 08:19 PM. Reason: Added video's
10 2SS/RS 6M is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:41 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.