Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Roto-Fab
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > 5th Gen Camaro SS LS LT General Discussions


Reply
 
Thread Tools
Old 05-26-2022, 11:09 PM   #1
SSVictor
 
Drives: 2010 Camaro 2SS
Join Date: Jan 2019
Location: Alabama
Posts: 26
Car bogging and stuttering around 2,200 Rpm

Just got Corsa Sport zl1 quad exhaust installed on a 2010 camaro ss automatic about 2 weeks ago and the car is starting to bog and stutter around 2,200 rpm and I can feel vibration under the floorboard when idling. The car has TSP 1-7/8” catless headers, JLT intake, BTR Stage 2 cam and a 3,200 converter Stall.
SSVictor is offline   Reply With Quote
Old 05-27-2022, 03:50 AM   #2
Wizard1183

 
Wizard1183's Avatar
 
Drives: ABM SS2/RS M6
Join Date: Apr 2011
Location: Lafayette,LA
Posts: 2,099
Send a message via Yahoo to Wizard1183
Is it throwing codes? Check engine on?
__________________


Life is short, drive it like you stole it!
Wizard1183 is offline   Reply With Quote
Old 05-27-2022, 08:48 AM   #3
SSVictor
 
Drives: 2010 Camaro 2SS
Join Date: Jan 2019
Location: Alabama
Posts: 26
There’s not any codes or check engine light
SSVictor is offline   Reply With Quote
Old 05-27-2022, 10:39 AM   #4
SSVictor
 
Drives: 2010 Camaro 2SS
Join Date: Jan 2019
Location: Alabama
Posts: 26
It’s idling a little rough and smells like gas
SSVictor is offline   Reply With Quote
Old 05-27-2022, 11:19 AM   #5
Wizard1183

 
Wizard1183's Avatar
 
Drives: ABM SS2/RS M6
Join Date: Apr 2011
Location: Lafayette,LA
Posts: 2,099
Send a message via Yahoo to Wizard1183
Might be a bad injector
__________________


Life is short, drive it like you stole it!
Wizard1183 is offline   Reply With Quote
Old 05-27-2022, 11:24 AM   #6
tartagliazl1
 
tartagliazl1's Avatar
 
Drives: 2013 zl1 vert
Join Date: Dec 2018
Location: Rochester, New york
Posts: 491
You sure your tuner didn’t turn off any of the mil lights in the tune. If you have hp tuners you should check it out.
__________________
22% lower/ 2.5 upper/ 1-7/8” headers/ cat delete/ x-pipe/ AFCO with fans/ prospeed tank/ fic 850/ dsx aux kit/ 103mm throttle body/ RPM 5” intake/ meth kit/ prometh lid injection/ 160* stat/ ngk-7/ msd wires/ elite catch can/ tsp cam/ Che trunnions/ ported supercharger/ 1/2” lid spacer/ brick mod/BMR toe and trailing arms/ 751hp 757 tq SAE @17.3lb on a loaded dyno.
tartagliazl1 is offline   Reply With Quote
Old 05-27-2022, 12:20 PM   #7
SSVictor
 
Drives: 2010 Camaro 2SS
Join Date: Jan 2019
Location: Alabama
Posts: 26
I don’t think the tuner turned off any lights I just recently had a couple for a bad alternator.
SSVictor is offline   Reply With Quote
 
Reply

Tags
cam, engine, exhaust, help me, tune

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:57 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2022, vBulletin Solutions, Inc.