Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Roto-Fab
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V8


Reply
 
Thread Tools
Old 07-04-2020, 02:31 PM   #1
Rob3D

 
Drives: Car
Join Date: Jan 2013
Location: Here
Posts: 819
*SOLVED* Need help solving Methanol injection issue please.

If this is something simple and right in front of my eyes...Iím gonna give up cars and try bicycles or some shit.


Hereís the problem, the red light on the left of the indicator panel doesnít turn green, itís either red or blinking rapidly from red to green. I donít increase the revs or speed, but I know Iím reaching the correct boost.

Hereís the facts:

LS3 Whipple

ALKYcontrol system, dual nozzle, wiper reservoir is the methanol reservoir. Less than a year old.

Yes itís been tuned..

Yes I purge it...purge the hell out of it.

Thereís no clogs that I can tell. I removed the air filter main line and looked at the spray and got perfect spray from the nozzles.***I did notice the pump reving up and down, and the spray acted accordingly, but there was still a steady spray for the most part****

Thereís no leaks...I took a week to check this because as you all know methanol evaporates pretty fast and I thought mine was going to fast....so I thought Iíd triple dog check for leaks.

I think thatís it. Thank you for reading...

Last edited by Rob3D; 07-06-2020 at 02:30 PM.
Rob3D is offline   Reply With Quote
Old 07-04-2020, 03:10 PM   #2
Vegas Bound

 
Drives: 2013 Sparkly Red One
Join Date: Dec 2018
Location: Landed in Vegas
Posts: 1,771
Sounds like an ongoing issue. Have you contacted Julio?
__________________
Lots of bolt on stuff
Bests in each category
1.36 - 60'
6.29 - 1/8 mile
10.18 - 1/4 mile
Vegas Bound is offline   Reply With Quote
Old 07-04-2020, 03:32 PM   #3
Rob3D

 
Drives: Car
Join Date: Jan 2013
Location: Here
Posts: 819
Quote:
Originally Posted by Vegas Bound View Post
Sounds like an ongoing issue. Have you contacted Julio?
Iím gonna call him.
Rob3D is offline   Reply With Quote
Old 07-04-2020, 04:09 PM   #4
Vegas Bound

 
Drives: 2013 Sparkly Red One
Join Date: Dec 2018
Location: Landed in Vegas
Posts: 1,771
Quote:
Originally Posted by Rob3D View Post
Iím gonna call him.
I'd offer advice, but the only issue I have had in 5+ years is leaking pumps. I'm on my 3rd and have the 4th ready on the shelf.
__________________
Lots of bolt on stuff
Bests in each category
1.36 - 60'
6.29 - 1/8 mile
10.18 - 1/4 mile
Vegas Bound is offline   Reply With Quote
Old 07-04-2020, 04:17 PM   #5
Rob3D

 
Drives: Car
Join Date: Jan 2013
Location: Here
Posts: 819
Quote:
Originally Posted by Vegas Bound View Post
I'd offer advice, but the only issue I have had in 5+ years is leaking pumps. I'm on my 3rd and have the 4th ready on the shelf.
The process of elimination has me thinking itís the pump. This one is a year old and honestly I donít care for the way it was spraying. I went ahead and ordered one...if thatís the issue then so be it...Iíll also order a spare...

You helped me out a lot... Thanks..
Rob3D is offline   Reply With Quote
Old 07-04-2020, 04:21 PM   #6
Vegas Bound

 
Drives: 2013 Sparkly Red One
Join Date: Dec 2018
Location: Landed in Vegas
Posts: 1,771
Quote:
Originally Posted by Rob3D View Post
The process of elimination has me thinking itís the pump. This one is a year old and honestly I donít care for the way it was spraying. I went ahead and ordered one...if thatís the issue then so be it...Iíll also order a spare...

You helped me out a lot... Thanks..
Don't order 2. Order 1 new pump and send your old pump back in the same box to be rebuilt.
__________________
Lots of bolt on stuff
Bests in each category
1.36 - 60'
6.29 - 1/8 mile
10.18 - 1/4 mile
Vegas Bound is offline   Reply With Quote
Old 07-04-2020, 04:26 PM   #7
Rob3D

 
Drives: Car
Join Date: Jan 2013
Location: Here
Posts: 819
Quote:
Originally Posted by Vegas Bound View Post
Don't order 2. Order 1 new pump and send your old pump back in the same box to be rebuilt.
Thanks..Iíll do that...
Rob3D is offline   Reply With Quote
Old 07-05-2020, 06:21 PM   #8
Rob3D

 
Drives: Car
Join Date: Jan 2013
Location: Here
Posts: 819
Thanks again for the help Vegas....I have an update just in case anyone ever searches for this...

It turns out when I purged the system for air I did not purge enough...turns out ya gotta purge about 16oz (one water bottle)

Hereís the message from Julio
ďDisconnect hose from T, turn key on, place gain on 8, push and hold test button until you fill a small bottles worth like 12-16 ounces
Then reconnect hose to t, start engine, rev to 1500 and push and hold the test button should go red to green or you may have a pump problemď

Still gonna get that pump and have it on standby. 😂
Rob3D is offline   Reply With Quote
Old 07-05-2020, 11:03 PM   #9
Vegas Bound

 
Drives: 2013 Sparkly Red One
Join Date: Dec 2018
Location: Landed in Vegas
Posts: 1,771
Glad it worked out.
__________________
Lots of bolt on stuff
Bests in each category
1.36 - 60'
6.29 - 1/8 mile
10.18 - 1/4 mile
Vegas Bound is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:29 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.