Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Bigwormgraphix
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V8


Reply
 
Thread Tools
Old 04-18-2013, 01:28 PM   #15
sscamaro


 
sscamaro's Avatar
 
Drives: 2010 2SS, 2017 Silverado LTZ
Join Date: Jan 2007
Location: Denver,PA
Posts: 2,882
Quote:
Originally Posted by 2SSCAMARO View Post
If you're running a centri and/or meth, it's possible. If you're doing street only driving with a PD and avoiding redline pulls then you're probably correct but I have to ask the question, how many people go to the trouble and cost of making 546 rwhp and totally avoid WOT pulls?
After I installed the Edelbrock S/C, with LT headers and CAI, I had a dyno tune and it was running out of fuel at 6500 rpm. After installing the ZL1 fuel pump and 72# injectors and another dyno tune it was running fine. I don't drag race, I just wanted the extra power for when I wanted it on the street.
__________________
2010 2SS/RS Victory Red, MN6, 1-7/8 Kooks LT Headers, SLP Axle Back, Edelbrock E-Force S/C, ZL1 Fuel Pump, 72# Injectors, JRE fuel rail upgrade, Roto-Fab CAI, Elite Catch Can, Billet Hurst Shifter, DSS 1000HP axles, Spohn Trailing Arms, Toe Links, Lower Control Arms. Chrome Torq-Thrust wheels. 546/rwhp & 522/rwtq Tune by Jeremy Formato.
sscamaro is offline   Reply With Quote
Old 04-18-2013, 01:34 PM   #16
Iam Broke
PHAT B33
 
Iam Broke's Avatar
 
Drives: 2012 TF3 Camaro 2SS/RS M6
Join Date: Jun 2012
Location: Dark of the Moon
Posts: 1,472
Quote:
Originally Posted by patternpilot View Post
I just got the car running and am working on the tune, but I am seeing 70psi at the rail at idle with it climbing as the boost goes up. Have not done any full boost runs yet but looking promising. 65 lib injectors with ZL1 pump and ADM FPCM.
The ECU can be programmed to raise the fuel pressure with flow. I run the ZL1 setting of 50 psi at idle and command 67 psi at high flow. Just an FYI.
__________________
Another 1 of 371 '12 T3 LS3 M6's built.
Iam Broke is offline   Reply With Quote
Old 04-18-2013, 01:35 PM   #17
ITGuy11
Burning up tires
 
ITGuy11's Avatar
 
Drives: 2010 Camaro 1SS/RS
Join Date: Jul 2010
Location: Macomb Twp, MI
Posts: 716
Quote:
Originally Posted by patternpilot View Post
I just got the car running and am working on the tune, but I am seeing 70psi at the rail at idle with it climbing as the boost goes up. Have not done any full boost runs yet but looking promising. 65 lib injectors with ZL1 pump and ADM FPCM.
You should be at 58psi fuel pressure at idle.
__________________
Blower, cam, supporting mods 644RWHP 615RWTQ
My Build Thread COTW 11/19/12
Detroit 5th Gen Camaro Club
ITGuy11 is offline   Reply With Quote
Old 04-18-2013, 03:00 PM   #18
2SSCAMARO

 
2SSCAMARO's Avatar
 
Drives: 2010 Camaro Auto
Join Date: Mar 2010
Location: Fl
Posts: 1,161
Quote:
Originally Posted by sscamaro View Post
After I installed the Edelbrock S/C, with LT headers and CAI, I had a dyno tune and it was running out of fuel at 6500 rpm. After installing the ZL1 fuel pump and 72# injectors and another dyno tune it was running fine. I don't drag race, I just wanted the extra power for when I wanted it on the street.
Well if your set up is providing proper fueling that can be verified by logging the data, that's cool because the engine does not know the difference if your cranking 6500 rpm on the street or at the strip. You don't want to lean out either place. I was running out of fuel by the top of first gear with the ZL-1 pump, ID850 injectors, and a MSD BAP.
2SSCAMARO is offline   Reply With Quote
Old 04-18-2013, 11:35 PM   #19
gnturboray

 
gnturboray's Avatar
 
Drives: SIM 2010 2SS/RS LS3 LPE750
Join Date: Feb 2012
Location: Mckinney, Texas
Posts: 765
Quote:
Originally Posted by Iam Broke View Post
My setup works well on 9psi.
Same here!!
gnturboray is offline   Reply With Quote
Old 04-19-2013, 12:12 AM   #20
Jayrcr3

 
Jayrcr3's Avatar
 
Drives: 2011 IOM 2SS/RS
Join Date: Dec 2010
Location: Chatham, Illinois
Posts: 757
My ADM FPCM and ZL1 pump with BAP is supplying 656hp at 10psi and holds 62 psi at redline.

Measured by EFI Live. Have not measured at the rail. Before Andy's controller it was falling into the upper 40's.

Edit: I have the 63lb injectors that came with my Whipple. Andy said bigger injectors would let the pressure stay higher because they stay closed longer allowing the pump to keep up. My injectors are at the limit for my setup.

This is my experience. Yours may vary.

Sent from my HTC One X using Tapatalk 2
__________________
American Racing 1 7/8" Headers and Hi-Flow Cats, CAI cold air intake, Flowmaster AT exhaust, Vengeance Racing Stage 2 cam, VMax ported throttle body, TEA valve springs and titanium retainers, Trick Flow hardened pushrods, 180* T-stat, Comp Trunion kit, ZL1 Fuel Pump, ADM Fuel Pump Control Module, 20% window tint, Whipple Supercharger. Tuned by Mike Norris Motorsports. 656rwhp/584rwtq @10 PSI.
Jayrcr3 is offline   Reply With Quote
Old 04-19-2013, 01:38 AM   #21
Chris82xx
Make your peace with God!
 
Chris82xx's Avatar
 
Drives: 2011 Camaro SS/RS M6 Convertible
Join Date: Dec 2011
Location: Dirty Jersey
Posts: 1,595
Not for nothing, but have you talked to your tuner, assuming you have one, and asked them what they think?
__________________
ECS base supercharger (NOVI 1500SL), ECS AlKY control kit, 92mm TB, ARH 1 7/8" LT's non-catted, Borla 3" exhaust, ID850 injectors, Squash fuel system, ECS Big Blower Cam, MGW short throw shifter, DSS 1000hp axles, LGW differential cover, billet caps, Tech AFX heater hoses, Pedders differential bushings, Eaton TrueTrac differential, PRC dual valve springs, Katech C5R timing chain, ATI balancer, Meilings oil pump, Pfadt Trailing Arms, Pfadt Tie Rods, Pfadt Sway Bars, Pfadt End Links, DSS Aluminum Driveshaft

811RWHP/719RWTQ


UNDER MAJOR OVERHAUL!!
Chris82xx is offline   Reply With Quote
Old 04-19-2013, 05:47 AM   #22
Iam Broke
PHAT B33
 
Iam Broke's Avatar
 
Drives: 2012 TF3 Camaro 2SS/RS M6
Join Date: Jun 2012
Location: Dark of the Moon
Posts: 1,472
There are tables in the E38 that can raise voltage at boost like a BAP. Recently posted in the HPT forums, trying them soon with my setup.

The ZL-1, ZR-1 & CTS-V tunes use this table stock. Fuel system Minimum Voltage on the System tab if you are familiar with HPTuners.

http://www.hptuners.com/forum/showth...tage-min-table
__________________
Another 1 of 371 '12 T3 LS3 M6's built.
Iam Broke is offline   Reply With Quote
Old 04-20-2013, 01:07 AM   #23
RED BARON
F1X bringing the pain!
 
RED BARON's Avatar
 
Drives: CTS V of the Centri
Join Date: Aug 2011
Location: Cin City
Posts: 54
I have the CTS V/ZL1 pumps out of my V and just posted them in the sale section. Make me a reasonable offer fellas!

I did close to 700hp on them with no BAP and ran 10.5 @ 134.5
RED BARON is offline   Reply With Quote
Old 04-25-2013, 10:22 AM   #24
BAMFSS
 
BAMFSS's Avatar
 
Drives: '10 IBM 1SS/RS
Join Date: Jan 2011
Location: Destin
Posts: 128
Send a message via Skype™ to BAMFSS
I bought the ZL1 pump and put it in, and thats all. Fixed my fuel pressure issues from spraying.
__________________
K&N CAI, VMAX TB, LG SuperPro 3" exhaust, ZL1 fuel pump, "juicey-juice", John Weeks tune.
Hotchkis 1" drops springs, Heritage grille, Granatelli ProStock spoiler.
Make It Rain TRENT!!
BAMFSS is offline   Reply With Quote
Old 04-29-2013, 05:21 PM   #25
Birm
 
Birm's Avatar
 
Drives: Florida Speed & Power
Join Date: Jan 2011
Location: Pinellas Park, FL
Posts: 3,188
Quote:
Originally Posted by BAMFSS View Post
I bought the ZL1 pump and put it in, and thats all. Fixed my fuel pressure issues from spraying.
This
Birm is offline   Reply With Quote
Old 04-29-2013, 06:04 PM   #26
2SSCAMARO

 
2SSCAMARO's Avatar
 
Drives: 2010 Camaro Auto
Join Date: Mar 2010
Location: Fl
Posts: 1,161
The thing that many posters are not aware of is the fact that adequate fuel pressure for a given horsepower level is not across the board same for top mount blowers, centri's, turbos, and any of these FI units when coupled with meth. Below is a log of a run on my no meth maggie car utilizing a ZL-1 pump, ID850 injectors, AND a MSD BAP, but no ADM FPCM. This is not internet myth, cheap talk, or a figment of my imagination, it's a logged fact.
Attached Images
 
2SSCAMARO is offline   Reply With Quote
Old 04-29-2013, 07:54 PM   #27
Camper
Banned
 
Drives: 10' 2SS LS3 M6
Join Date: May 2012
Location: Phoenix,AZ
Posts: 1,370
Going cheap on fuel = boom
Camper is offline   Reply With Quote
Old 04-29-2013, 09:54 PM   #28
Nitroman28

 
Nitroman28's Avatar
 
Drives: 2010 Camaro SS 416/4L80
Join Date: Oct 2010
Location: Arkansas
Posts: 1,835
All I have to add is don't just log it on a dyno, Take it to an open road or the track and run it thru the gears at WOT. Mines fine on a dyno, but takes a crap at the track.
Nitroman28 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:58 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.