Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Roto-Fab
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > 5th Gen Camaro SS LS LT General Discussions


Reply
 
Thread Tools
Old 05-16-2019, 02:08 PM   #1
Texas_craig
 
Drives: 2010 Camaro SS
Join Date: Oct 2018
Location: Yoakum
Posts: 9
Low oil pressure

I have a 2010 Camaro ss with 90,000 miles with DOD delete and Stage 1 Texas Speed cam and SLP 2300 supercharger that I recently installed tuned to right at 600hp.. I just noticed today that HWY driving and Idle it seemed to be running low oil pressure ? around 15-18 psi but close to 30psi at 2000 rpm and on up to around 45psi at WOT. Should I be worried at the idle pressure ? I should have replace the oil pump when i did cam and lifters and delete but did not.

Any suggestion ? I plan on checking it manually soon to verify that the gauge is correct but lets assume it is for now.
Texas_craig is offline   Reply With Quote
Old 05-16-2019, 04:17 PM   #2
hunter1660

 
hunter1660's Avatar
 
Drives: 2011ss/rs camaro
Join Date: Sep 2011
Location: florida
Posts: 1,216
The pump in the L99 isn't prone to fail...there are exceptions to every rule....id say your ok.
__________________
. OBX LTH,Rotofab,Magnuson Heartbeat.AEM wideband, HP Tuners
hunter1660 is offline   Reply With Quote
Old 05-16-2019, 04:31 PM   #3
PepeLePew
 
PepeLePew's Avatar
 
Drives: 2010 2SS Coupe; 2011 2LT Vert
Join Date: Dec 2018
Location: Prosper, TX
Posts: 459
A manual gauge will tell you for sure if it is that low. Its not your pump if you have that much PSI at WOT. Do you remember what the pressure was before the cam and the SC? If it is significantly lower at idle after the cam, I'd be a little concerned about cam bearings. If it was like this before the install, you are probably ok. A worn cam bearing can cause low oil pressure at idle for sure. Do you do the install yourself or did a shop do it? If it was a shop, I'd be questioning them and let them know the idle pressure is low after the swap. They could have been a little aggressive jamming the cam in there and nicked them up. My LS3 is at 30psi at idle after warm up with 130K miles.
__________________
2010 2SS/RS LS3 - K&N, GM Performance Axle Back, Hurst Shifter, TSP 1 7/8ths long tubes no cats, TSP Stage 2 "Bald Eagle" cam, GM 3.91, 466whp/429tq
PepeLePew is offline   Reply With Quote
Old 05-18-2019, 08:54 AM   #4
christianchevell
old school chevy rodder
 
christianchevell's Avatar
 
Drives: 2013 2SS/RS Manual,DM exhaust,CRT
Join Date: Jul 2012
Location: Oregon
Posts: 5,582
Well for one with a stock block your about double the boost you most likely should be running if your 15-18 psi.....?, your not doing well in the oil pressure may mean the screen is clogged by the sensor behind the manifold, or other things that are not so friendly. Just for example..my fully forged N/A runs with a high volume pump which the l99 comes with stock...maybe not so ported as mine etc....anyway I never get to 30 at idle I am more like 40 PSI running very hot, I am up about 70 on cold start and it goes down slowly. I do not know what oil your running or what idle you have...…..
I use driven racing oil ls30 made for a modified engine...…..you may have seen it on some vendors sites. Of course the way you wrote it I don't know if your boost is 15-18 psi or that's your very low oil pressure at what idle? I would say the 30 psi at 2000 rpm I am more like 40-50... And I would say the idle should be about 950 with most aftermarket cams though yours is mild. The numerous things that can affect oil pressure are so many to list....not knowing who installed the cam and how long its been in there, the state of the lifters and their age, the state of the springs, the Preload, etc etc......its not worth hazarding a guess. here a old article still true I have posted over and over...…….

https://www.hotrod.com/articles/hrdp...parts-failure/
__________________
2013 2SS/RS LS3 M6 ,CRT, NPP, Forged 428 ls3 stroker, GMPP ported heads, Katech chain, Mast windage, Cam Motion Cam, trunnion upgrade, Stainless Power headers HFC, CAI w/kit, Vmax PTD, Fluidampr, Powermaster xs 9509 starter, BMR strut brace,trailing arms, toes, bushings, Crossfire wheels & extreme contacts, elite catch can, clutch reservoir, dash/body LED, DRL rewire, Sparks badges, Forza 3way, tint, MRT louvers, ZL1 spoiler, MGW short throw, Monster dual LT1S clutch, bleeder, support, high vol pump, Speed hut shift light, ACC flames stripes, Driven ls30 oil, NGK TR6IX , Granatelli wires.
christianchevell is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:33 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.