Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
JDP Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis


Reply
 
Thread Tools
Old 06-12-2018, 08:33 PM   #1
MrRabbit24
 
Drives: 2014 White camaro 1ss automatic L99
Join Date: Apr 2016
Location: Tulsa, Oklahoma
Posts: 17
BMR suspension

Well i recently purchased some badass BMR suspension parts, but i have only one concern. Each time i get in and out of the driveway i hear it pop its probably past the break in period but i dont know if Firestone did not tighten to spec or what is causeing it.
Attached Images
   
MrRabbit24 is offline   Reply With Quote
Old 06-13-2018, 06:16 AM   #2
hrpiii
AKA "Beefcake"
 
hrpiii's Avatar
 
Drives: CGM w/Black stripes
Join Date: Oct 2009
Location: Indy
Posts: 7,577
pop as in "endlinks" or "swaybar"? hearing it from the front or back? Not sure what all suspension parts you got. There is more than one you know...lol.
__________________
BMR Suspension, SLPTVS2300, GFORCE Driveshaft & HalfShafts, Kooks with cutouts and other fun things.
hrpiii is offline   Reply With Quote
Old 06-13-2018, 07:51 AM   #3
frankwjr

 
frankwjr's Avatar
 
Drives: 2010 SS 2SS M6
Join Date: Aug 2016
Location: Smithsburg, Md.
Posts: 2,166
sounds like something may have been tighten before the car was sitting on all 4...timing or clocking the suspension components is very important and that popping to me sounds like a bushing....would not hurt to have them double check everything...


good luck and report back!


peace
__________________
2010 SS 2SS M6 - Tune by RDP dynoSteve!(Woot) - Daily Driver - 126K! - All work by me...
frankwjr is offline   Reply With Quote
Old 06-13-2018, 08:00 AM   #4
MrRabbit24
 
Drives: 2014 White camaro 1ss automatic L99
Join Date: Apr 2016
Location: Tulsa, Oklahoma
Posts: 17
Quote:
Originally Posted by hrpiii View Post
pop as in "endlinks" or "swaybar"? hearing it from the front or back? Not sure what all suspension parts you got. There is more than one you know...lol.
Thank you, the most recent suspension work has been done to the rear and its definitely comeing from the rear never usto do this before. On straightline its fine but if i hit a small bump just pops or if i get into my driveway it pops.
Attached Images
  
MrRabbit24 is offline   Reply With Quote
Old 06-13-2018, 09:43 AM   #5
BMR Sales



 
BMR Sales's Avatar
 
Drives: Race Car
Join Date: Sep 2009
Location: Seffner, FL
Posts: 4,723
Well, the 1st thing is that you have our version with Rod Ends. Rod Ends are always going to be noisier than a version with Poly or the OEM Rubber. The reason being is that there is nothing to absorb any NVH.

That being said, it still could definitely be something else
BMR Sales is offline   Reply With Quote
Old 06-13-2018, 11:09 AM   #6
MrRabbit24
 
Drives: 2014 White camaro 1ss automatic L99
Join Date: Apr 2016
Location: Tulsa, Oklahoma
Posts: 17
Quote:
Originally Posted by BMR Sales View Post
Well, the 1st thing is that you have our version with Rod Ends. Rod Ends are always going to be noisier than a version with Poly or the OEM Rubber. The reason being is that there is nothing to absorb any NVH.

That being said, it still could definitely be something else
Oh it has nothing to do with your parts, i know what i got myself into dailying the car and the noise that comes with TC went over it with me before i made my purchase. Just pops loudly like something is loose or shifted out of place. The pictures above is what just seemed to be leaveing any type of mark. Your product is amazing and is very inpressive. I plan on doing coliovers soon so ill give TC a call when ready dude knows his stuff.
MrRabbit24 is offline   Reply With Quote
Old 06-14-2018, 10:41 AM   #7
MrRabbit24
 
Drives: 2014 White camaro 1ss automatic L99
Join Date: Apr 2016
Location: Tulsa, Oklahoma
Posts: 17
Update: upon putting the car on the rack look like the noise is comeing from just the right passenger side. I was recommended to remove sway bar links because they thinks thats were the popping sound is comeing from only when the car is at a angle. The squeaking seems to be comeing from the Toe Rods/trailing arms. I will be picking up some chain oil re lube everything give a couple more days see if it fixis the problem. I just think it was not adjusted properly. To snyone intrested on BMR suspension products dont let this deter you from buying their stuff as i am 100% satisfied with quality,finish, and gains very very very minimal wheel hop car does not rock
Attached Images
 

Last edited by MrRabbit24; 06-14-2018 at 09:28 PM.
MrRabbit24 is offline   Reply With Quote
Old 06-14-2018, 09:20 PM   #8
MrRabbit24
 
Drives: 2014 White camaro 1ss automatic L99
Join Date: Apr 2016
Location: Tulsa, Oklahoma
Posts: 17
Update: Got home removed anti roll bar links and vuala the poping sounds gone. Why did i have to remove links i would like some input on what it can possibly be. The anti roll bar does not even budge when i removed the links like there is no play what so ever was it over tighten? Any info would be helpful thank you. Passenger side still creaks :( put more teflon oil spray.

Last edited by MrRabbit24; 06-14-2018 at 11:19 PM.
MrRabbit24 is offline   Reply With Quote
Old 06-16-2018, 01:55 PM   #9
MrRabbit24
 
Drives: 2014 White camaro 1ss automatic L99
Join Date: Apr 2016
Location: Tulsa, Oklahoma
Posts: 17
Update: do these need to be replaced? Upon looking at my sway bar links i found these groves in the bottom of the eylet.
Attached Images
 
MrRabbit24 is offline   Reply With Quote
Old 06-16-2018, 05:11 PM   #10
TWOFORTYZ
 
Drives: 2015 Camaro 1SS 6M
Join Date: Dec 2017
Location: The Freeway
Posts: 220
Quote:
Originally Posted by MrRabbit24 View Post
Update: do these need to be replaced? Upon looking at my sway bar links i found these groves in the bottom of the eylet.
Those look to have been twisted too far or misaligned causing the damage. Very interesting considering this is not a rock crawler... I also noticed they are nearly maxed out in one of your installed pictures, the geometry seems flawed. If you jack up one corner and look I'd bet you will see the spacers/bolts touching that bent section.
__________________
TWOFORTYZ is offline   Reply With Quote
Old 06-18-2018, 01:22 PM   #11
MrRabbit24
 
Drives: 2014 White camaro 1ss automatic L99
Join Date: Apr 2016
Location: Tulsa, Oklahoma
Posts: 17
Update on squeaking, during install on the toe rods they did not spray the teflon lubericant on the parts circled. They shook it several times and figured it out. $ 67.00 dollar fix but its quiet so far i hope because of his mistake there isnt badly damaged :(
Attached Images
 
MrRabbit24 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:27 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.