Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Phastek Performance
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 05-20-2020, 10:54 PM   #1
Camaro_Fuzion
 
Camaro_Fuzion's Avatar
 
Drives: 2010 Chevy Camaro 2SS
Join Date: Dec 2016
Location: Houston, TX
Posts: 71
Failed Texas emissions test! Help! Codes P0556, P013A, P013C, P219A

I am the owner of the 2010 Camaro 2SS I've been having catalytic converters and 01/02 sensor issues for the last six months. To try and resolve the problem. I had my ASE mechanic install aftermarket parts. A Kinetixracing high flow Catalytic Converter set left/right and all the 01/02 sensors front and back. The mechanic cleared the codes after installation. But the check engine light came back on. I already failed the Texas emissions test today. I really need to pass the emissions test on the next visit within 15 days. I don't know if this all has to do with the car's electrical system or mass air flow sensor. I want to rid of all the issues that affect the catalytic converters and 01/02 sensors. I have attached the error codes report that pertains to my vehicle. I wonder if there is an underlining issue that is causing all these issues. I hope to get this resolved. Any advice would be greatly appreciated from the team. Thank you!





Parts installed.


Kinetixracing Catalytic Converters




Aftermarket 01/02 Sensors





Last edited by Camaro_Fuzion; 05-20-2020 at 11:11 PM.
Camaro_Fuzion is offline   Reply With Quote
Old 05-20-2020, 11:54 PM   #2
Vegas Bound

 
Drives: 2013 Sparkly Red One
Join Date: Dec 2018
Location: Landed in Vegas
Posts: 1,589
Is the battery original? Weak battery can cause these issues.
__________________
Lots of bolt on stuff
Bests in each category
1.36 - 60'
6.29 - 1/8 mile
10.18 - 1/4 mile
Vegas Bound is offline   Reply With Quote
Old 05-21-2020, 12:09 AM   #3
CuseZilla
 
Drives: 2013 ZL1 Camaro
Join Date: May 2018
Location: Liverpool
Posts: 4
If the car was tuned that may be the issue. That may also be a solution. GL
CuseZilla is offline   Reply With Quote
Old 05-21-2020, 12:50 AM   #4
Camaro_Fuzion
 
Camaro_Fuzion's Avatar
 
Drives: 2010 Chevy Camaro 2SS
Join Date: Dec 2016
Location: Houston, TX
Posts: 71
Quote:
Originally Posted by Vegas Bound View Post
Is the battery original? Weak battery can cause these issues.
No, the battery is not original. The battery is an Odyssey Extreme. The battery appears to still be in good running condition. Sometimes my car won't start when I turn the ignition switch on. It doesn't happen very often. I really don't want to get taken by some of these shops locally in Houston, TX They might want to fix everything but the problem. Or try to make up extra repairs so they can dime and nickle me out of money.



https://www.carid.com/odyssey/extrem...l?urlId=168444
Camaro_Fuzion is offline   Reply With Quote
Old 05-21-2020, 12:59 AM   #5
Camaro_Fuzion
 
Camaro_Fuzion's Avatar
 
Drives: 2010 Chevy Camaro 2SS
Join Date: Dec 2016
Location: Houston, TX
Posts: 71
Quote:
Originally Posted by CuseZilla View Post
If the car was tuned that may be the issue. That may also be a solution. GL
I've never had my car tuned before. I did take it to a performance shop the other day. The tech plugged his hardware code reader into my dashboard. He tried to make my computer relearn the fuel system. To try and rid of all the Catalytic Converter and 02 sensor codes. The check engine light went away. But after a short while. The check engine came back on. All I did was after he cleared my codes. I started my car. I went down the road and stopped at Love's gas station for a 32 oz diet coke drink. I got back in my car and turned it on again. The check engine light returned. I have had the codes cleared many times. And each time the check engine light returns. What do you all really think the problem is?
Camaro_Fuzion is offline   Reply With Quote
Old 05-21-2020, 01:04 AM   #6
Camaro_Fuzion
 
Camaro_Fuzion's Avatar
 
Drives: 2010 Chevy Camaro 2SS
Join Date: Dec 2016
Location: Houston, TX
Posts: 71
I've been told by one person who never tested my car. That I might have a leaking manifold or a vacuum line leak. I won't rule out the battery being weak. I will have Autozone test my battery, starter, and alternator. The error codes report is very long. I'm hoping a master mechanic sees this post and responds with some suggestions also.

Last edited by Camaro_Fuzion; 05-21-2020 at 08:23 AM.
Camaro_Fuzion is offline   Reply With Quote
Old 05-21-2020, 09:48 AM   #7
Vegas Bound

 
Drives: 2013 Sparkly Red One
Join Date: Dec 2018
Location: Landed in Vegas
Posts: 1,589
Have a local shop do a smoke test on the engine. If smoke comes out, you found your vacuum leak.
__________________
Lots of bolt on stuff
Bests in each category
1.36 - 60'
6.29 - 1/8 mile
10.18 - 1/4 mile
Vegas Bound is offline   Reply With Quote
Old 05-21-2020, 10:34 AM   #8
Camaro_Fuzion
 
Camaro_Fuzion's Avatar
 
Drives: 2010 Chevy Camaro 2SS
Join Date: Dec 2016
Location: Houston, TX
Posts: 71
Quote:
Originally Posted by Vegas Bound View Post
Have a local shop do a smoke test on the engine. If smoke comes out, you found your vacuum leak.
Thank you for the response bro. Can that throw out codes like the ones I reported?
Camaro_Fuzion is offline   Reply With Quote
Old 05-21-2020, 10:35 AM   #9
Vegas Bound

 
Drives: 2013 Sparkly Red One
Join Date: Dec 2018
Location: Landed in Vegas
Posts: 1,589
Quote:
Originally Posted by Camaro_Fuzion View Post
Thank you for the response bro. Can that throw out codes like the ones I reported?

Vacuum leak can throw codes. Messes with AFR.
__________________
Lots of bolt on stuff
Bests in each category
1.36 - 60'
6.29 - 1/8 mile
10.18 - 1/4 mile
Vegas Bound is offline   Reply With Quote
Old 05-21-2020, 10:45 AM   #10
frankwjr


 
frankwjr's Avatar
 
Drives: 2010 SS 2SS M6
Join Date: Aug 2016
Location: Smithsburg, Md.
Posts: 2,367
get a tune! stock computer will never learn HFC's....give dynoSteve at RDP a holler...his SCT/tune for life deal can't be beat.


I just passed MD. emissions with JBA shorties/HFC/cam/and no rear mufflers lol.


Good luck!


PEACE
__________________
2010 SS 2SS M6 - Tune by RDP dynoSteve!(Woot) - Daily Driver - 139K! - All work by me...
frankwjr is offline   Reply With Quote
Old 05-21-2020, 01:16 PM   #11
RupertPupkin
 
Drives: 2014 Camaro SS 1Le
Join Date: Feb 2016
Location: IL
Posts: 572
Is Texas emissions pretty strict? I’m from Chicago, and they just hook up OBD and that’s it. I’m looking to move down to Houston/Austin area.
__________________
14SS 1LE 2SS/RS/Recaros|Tick Polluter Stg-3|E85
LS7 Lifters|BTR .660 Springs|Speed Engineering LTs|Muffler Mod|ECS 1500 Unrestricted|DSX Aux Pump|DSX Flex Fuel Sensor|FIC 127#|ATI Balancer|DashLogic|BMR 1.4 Springs|MightyMouse Wild CC|AEM WideBand|AEM BoostGauge|ZL1Addons Splitter|VA Sideskirts|McLeod RXT Twin|POWER : 737whp/635trq
RupertPupkin is offline   Reply With Quote
Old 05-21-2020, 01:29 PM   #12
Aries240SS
 
Drives: 2011 1SS RS Camaro, 1995 LSX 240SX
Join Date: Mar 2011
Location: Austin, TX
Posts: 448
Quote:
Originally Posted by RupertPupkin View Post
Is Texas emissions pretty strict? Iím from Chicago, and they just hook up OBD and thatís it. Iím looking to move down to Houston/Austin area.
Texas is the same. You just can't have 2+ not ready codes, or any permanent codes. +visual inspection of course.
__________________
2011 Camaro 1SS
Whipple Supercharged street monster
Aries240SS is offline   Reply With Quote
Old 05-21-2020, 01:38 PM   #13
JB'sZL1

 
Drives: 2013 ZL1 and 2019 Ram Laramie
Join Date: May 2017
Location: Milwaukee
Posts: 1,017
Hah. You seem to be jumping all over the place. Just because the battery "appears" to be in good condition means absolutely nothing. Check the voltage before starting and while starting.
JB'sZL1 is offline   Reply With Quote
Old 05-21-2020, 02:22 PM   #14
RupertPupkin
 
Drives: 2014 Camaro SS 1Le
Join Date: Feb 2016
Location: IL
Posts: 572
Quote:
Originally Posted by Aries240SS View Post
Texas is the same. You just can't have 2+ not ready codes, or any permanent codes. +visual inspection of course.
Visual inspection as in?
__________________
14SS 1LE 2SS/RS/Recaros|Tick Polluter Stg-3|E85
LS7 Lifters|BTR .660 Springs|Speed Engineering LTs|Muffler Mod|ECS 1500 Unrestricted|DSX Aux Pump|DSX Flex Fuel Sensor|FIC 127#|ATI Balancer|DashLogic|BMR 1.4 Springs|MightyMouse Wild CC|AEM WideBand|AEM BoostGauge|ZL1Addons Splitter|VA Sideskirts|McLeod RXT Twin|POWER : 737whp/635trq
RupertPupkin is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:19 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.