Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
dave@hennessey
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing


Reply
 
Thread Tools
Old 02-25-2018, 10:15 AM   #1
DonM
This is my 3rd Camaro
 
DonM's Avatar
 
Drives: All black '13 LS-M6 / Darth Camaro
Join Date: Dec 2015
Location: NE Ohio (Akron)
Posts: 900
Check Engine Light/Codes 2099 and 2097

This morning I went to visit my dad, and when I started the car the check engine light stayed on. I went to Auto Zone and they pulled 4 codes: Post Catalyst Fuel System Trim Too Rich 2099 X3 (bank 2) and Post Catalyst Fuel Trim System Too Rich 2097 (bank 1).

The car is running awesome and I took it for a quick sprint on the highway (nothing crazy, only went to 65 mph and didn't redline it). No issues.

Does anyone have any ideas on how to remedy this?
__________________
Don M

DonM is offline   Reply With Quote
Old 02-25-2018, 12:25 PM   #2
Olddudesrule
Resident nomad
 
Olddudesrule's Avatar
 
Drives: 2014 Summit White 1SS/1LE
Join Date: Nov 2015
Location: Gilbert, AZ
Posts: 1,767
Have you made any changes recently to the intake or intake filter?
__________________
Sold:
2007 Z06
2002 Viper GTS/ACR
2003 Z06
1965 FFR Cobra
2012 Nissan 370Z

ADM LSA Stage II, Roto-Fab CAI, Kooks LTH/HFC's, Phastek CC, ported TB, Mishimoto radiator and oil cooler, BC Racing ER Series CO's, JPSS 32mm Black Magic rear bar, JPSS front inserts, R1 Concepts Premier slotted rotors/Goodrich SS lines, Schroth ASM harness, MGW flatstick, Brey-Krause HB, Tuned by NicD, at Cordes Performance Racing.
Olddudesrule is offline   Reply With Quote
Old 02-25-2018, 01:00 PM   #3
DonM
This is my 3rd Camaro
 
DonM's Avatar
 
Drives: All black '13 LS-M6 / Darth Camaro
Join Date: Dec 2015
Location: NE Ohio (Akron)
Posts: 900
Quote:
Originally Posted by Olddudesrule View Post
Have you made any changes recently to the intake or intake filter?
I *might* have run a can of Sea Foam through the throttle body 3 days ago ... but I've driven the car a few hundred miles since then and the CEL just came on when I started it this morning
__________________
Don M

DonM is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:32 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.