Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
dave@hennessey
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Regional Forums > International Regions > UK


Reply
 
Thread Tools
Old 12-14-2015, 04:08 AM   #1
kidCOMATOSE
 
kidCOMATOSE's Avatar
 
Drives: 2015 ZL1
Join Date: Mar 2011
Location: shalimar, fl
Posts: 141
ZL1 help!

Hello all! I'm here in the UK with my 2015 ZL1 and I'm having DTC P012C pop up. I've read up on it and it says it's my supercharger voltage low. I've changed my MAP sensor, reset the cars computer...and it still pops up. And if I go above 4K rpms it goes to stability track control and shuts down engine power. The guys at the Chevy accredited dealership here are having trouble figuring it out. I don't know how familiar they are with this car. Does anyone here in the UK know of a good place I can go to that will support my warranty or know of what may be causing this issue. Please help! Thanks!

Damien
__________________
LAS ESPADAS DE MUNDO HUECO
kidCOMATOSE is offline   Reply With Quote
Old 12-14-2015, 04:25 AM   #2
pete-1le
pete1le
 
pete-1le's Avatar
 
Drives: 2013 Camaro 2SS RS 1LE
Join Date: Aug 2014
Location: West Midlands, United Kingdom
Posts: 435
Hi Damien,

If I had to guess I would say there's about 5 ZL1's in the whole country.
This is going to mean a limited amount of knowledge for ZL1 specific faults.
I took my Camaro to a GM dealership over here for a brake fluid change and they asked if it was a Dodge Camaro #facepalm

There isn't anywhere in the UK that will honour an american warranty. I would forget warranty and using normal car dealerships, you'll be better off using a specialist.

There's a guy on here called "2013HWE" who recently put a supercharger on a hot wheels edition, if you specifically need help with a supercharger fault you could ask him who helped him fit it.

Also speak to "Uk Blown SS" he's always really knoweldegable with these things and has done supercharger mods for other members.

Hope you're able to get it fixed soon, in time for our summer meet. :-)
__________________
__________________
WEBSITE 1le.uk | FACEBOOK facebook.com/pete.1le
pete-1le is offline   Reply With Quote
Old 12-14-2015, 04:30 AM   #3
pete-1le
pete1le
 
pete-1le's Avatar
 
Drives: 2013 Camaro 2SS RS 1LE
Join Date: Aug 2014
Location: West Midlands, United Kingdom
Posts: 435
Also there's a guy called evildave who's about 40 miles away from you. He might have some advice or somewhere local you could take it.
__________________
__________________
WEBSITE 1le.uk | FACEBOOK facebook.com/pete.1le
pete-1le is offline   Reply With Quote
Old 12-14-2015, 01:10 PM   #4
scites
 
Drives: 2010 camaro SS/RS
Join Date: Dec 2012
Location: swaffham UK
Posts: 370
Call Mr,I'm on Mildenhall and assuming you are as well seeing you were at hurby before.I have Hp Tuners,so we can figure it out. 07884581910
scites is offline   Reply With Quote
Old 12-14-2015, 01:11 PM   #5
scites
 
Drives: 2010 camaro SS/RS
Join Date: Dec 2012
Location: swaffham UK
Posts: 370
Me not Mr...lol
scites is offline   Reply With Quote
Old 12-14-2015, 01:25 PM   #6
Uk Blown SS
 
Uk Blown SS's Avatar
 
Drives: 2010 camaro ss
Join Date: Apr 2015
Location: United Kingdom
Posts: 209
Try clearing codes. Leaving the sensor disconnected , start up and recheck the codes. You should get P012D .This code relates to open circuit of the sensor (the opposite). This will help to eliminate the wiring and what the ECU is seeing. Sometimes a handy trick . Also check to see if all the data looks correct. Difficult without the patient in front of you.!
Uk Blown SS is offline   Reply With Quote
Old 12-15-2015, 02:48 AM   #7
kidCOMATOSE
 
kidCOMATOSE's Avatar
 
Drives: 2015 ZL1
Join Date: Mar 2011
Location: shalimar, fl
Posts: 141
Quote:
Originally Posted by pete-1le View Post
Hi Damien,

If I had to guess I would say there's about 5 ZL1's in the whole country.
This is going to mean a limited amount of knowledge for ZL1 specific faults.
I took my Camaro to a GM dealership over here for a brake fluid change and they asked if it was a Dodge Camaro #facepalm

There isn't anywhere in the UK that will honour an american warranty. I would forget warranty and using normal car dealerships, you'll be better off using a specialist.

There's a guy on here called "2013HWE" who recently put a supercharger on a hot wheels edition, if you specifically need help with a supercharger fault you could ask him who helped him fit it.

Also speak to "Uk Blown SS" he's always really knoweldegable with these things and has done supercharger mods for other members.

Hope you're able to get it fixed soon, in time for our summer meet. :-)
So is there a UK camaro group here on the forum? Or is it just through FB?
__________________
LAS ESPADAS DE MUNDO HUECO
kidCOMATOSE is offline   Reply With Quote
Old 12-15-2015, 03:01 AM   #8
pete-1le
pete1le
 
pete-1le's Avatar
 
Drives: 2013 Camaro 2SS RS 1LE
Join Date: Aug 2014
Location: West Midlands, United Kingdom
Posts: 435
The majority of camaro owners are on here, scites, UKblownSS and evildave might offer some assistance on this. The Facebook pages might not be as helpful but worth a try. PM me and I'll let you a list of FB groups, but take it to scites or UKblownSS if they're offering :-)


Sent from my iPhone using Tapatalk
__________________
__________________
WEBSITE 1le.uk | FACEBOOK facebook.com/pete.1le
pete-1le is offline   Reply With Quote
Old 12-15-2015, 06:54 AM   #9
evildave
 
evildave's Avatar
 
Drives: 2010 2SS RS GFX
Join Date: Jan 2015
Location: Uk
Posts: 62
I know a few garages in the norwich area that could identify/confirm the fault. Nothing under warranty though, better to pay a couple of hours (if it takes that long) to diagnose then import and fit parts yourself. Or better to go see scites with hp tuners, he knows his stuff :-)
__________________
2010 2SS RS GFX airaid, SP LT Headers, SW retro chambered exhaust & SCT tune
1968 SS RS 408ci, drag car, too many mods to list!
evildave is offline   Reply With Quote
Old 12-15-2015, 08:38 AM   #10
kidCOMATOSE
 
kidCOMATOSE's Avatar
 
Drives: 2015 ZL1
Join Date: Mar 2011
Location: shalimar, fl
Posts: 141
Quote:
Originally Posted by scites View Post
Call Mr,I'm on Mildenhall and assuming you are as well seeing you were at hurby before.I have Hp Tuners,so we can figure it out. 07884581910
Yea I'm actually on Lakenheath and was at Eglin before. I'll def give you a call this weekend. I changed out my other map sensor so I'll see if it pops up in a few days. But I'll probably give you call regardless just to meet up with some fellow camaros.

Damien
__________________
LAS ESPADAS DE MUNDO HUECO
kidCOMATOSE is offline   Reply With Quote
Old 12-15-2015, 08:39 AM   #11
kidCOMATOSE
 
kidCOMATOSE's Avatar
 
Drives: 2015 ZL1
Join Date: Mar 2011
Location: shalimar, fl
Posts: 141
Quote:
Originally Posted by Uk Blown SS View Post
Try clearing codes. Leaving the sensor disconnected , start up and recheck the codes. You should get P012D .This code relates to open circuit of the sensor (the opposite). This will help to eliminate the wiring and what the ECU is seeing. Sometimes a handy trick . Also check to see if all the data looks correct. Difficult without the patient in front of you.!
So leave the map sensor open? And if so which one?
__________________
LAS ESPADAS DE MUNDO HUECO
kidCOMATOSE is offline   Reply With Quote
Old 12-15-2015, 01:52 PM   #12
Uk Blown SS
 
Uk Blown SS's Avatar
 
Drives: 2010 camaro ss
Join Date: Apr 2015
Location: United Kingdom
Posts: 209
The one which you think is causing the fault. The one you replaced. I assume the pressure sensor in the plenum . Under the blower rotors.
Uk Blown SS is offline   Reply With Quote
Old 12-16-2015, 02:41 AM   #13
RickGM

 
RickGM's Avatar
 
Drives: 2013 SS V8 L99 Magnusson Heartbeat
Join Date: Jun 2012
Location: South Leicestershire, United Kingdom
Posts: 864
This is all over my head but if our aforementioned resident C5UK experts can't help (unlikely) you could try these guys who are hot on GM V8's.
www.monkfishperformance.co.uk
__________________
UK Camaro Owner. One of a few.
RickGM is offline   Reply With Quote
Old 01-12-2016, 03:34 AM   #14
kidCOMATOSE
 
kidCOMATOSE's Avatar
 
Drives: 2015 ZL1
Join Date: Mar 2011
Location: shalimar, fl
Posts: 141
So update on my ZL1. I found a accredited dealership here. They advertise as camaro specialist and honour all GM warranties. They are called WH Brand and are located in Lincolnshire. About an 1 1/2 Hr from Lakenheath. Anyone ever heard of them? I got my appointment on Monday...so I'll give you guys some feedback just in case you guys are interested.
__________________
LAS ESPADAS DE MUNDO HUECO
kidCOMATOSE is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:07 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.