Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
dave@hennessey
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > 5th Gen Camaro SS LS LT General Discussions


Reply
 
Thread Tools
Old 04-29-2011, 02:59 AM   #1
ohioballer
 
Drives: 2ss/rs black w iom stripe/int
Join Date: May 2009
Location: lima ohio
Posts: 17
bad battery and steering angle sensor

I noticed a lot of people have been having stabilitrack problems and brake pedal issues so i thought id post this to let everyone know that i recently had all my dash lights (stabilitrack abs traction control check engine) coming on therefor not working. i also had the open then close window show up on the dic whenever i started the car. I also had a vibration in my brakes whenever i use the brake at low speeds. So I took it to the dealer today and they told me i had a bad battery and that my systems werent getting enough juice to stay on and they replaced it.I was told the only light on now is the stabilitrack which is the result of a bad steering angle sensor and they had to order the part. The brakes were a result of the abs being off So hopefully ill get it back tomorrow and let everyone know if that corrects the problem.
ohioballer is offline   Reply With Quote
Old 04-29-2011, 03:37 AM   #2
ihaveacamaro
I like teeth.
 
ihaveacamaro's Avatar
 
Drives: #198
Join Date: Oct 2009
Location: Ft. Lauderdale, Florida
Posts: 4,840
I have never heard of stabilitrack or brake pedal issues.

I have a pre-production model so trust me, I have had my share of problems, but never any stabilitrack or brake pedal issues.


Another thread is here on those issues, but it seems that the driver was at fault actually.
ihaveacamaro is offline   Reply With Quote
Old 04-29-2011, 10:37 AM   #3
The Stig
knows 2 facts about ducks
 
The Stig's Avatar
 
Drives: ...and they're both wrong
Join Date: Aug 2009
Location: The HMS Invincible
Posts: 26,270
Yea I haven't had any issues either. I would maybe have the dealer take a look at it if the problem keeps occurring.
__________________
Click to view my build thread
The Stig is offline   Reply With Quote
Old 05-02-2011, 12:32 PM   #4
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 9,328
ohioballer, I hope the next update is the last update for your issues. If you run into any other issues feel free to contact me. I hope to hear good things back from the dealership!

Jeff Morris, Chevrolet Customer Service
Chevrolet Customer Svc is offline   Reply With Quote
Old 05-02-2011, 03:08 PM   #5
scottyvegas
X SS
 
scottyvegas's Avatar
 
Drives: 2010 Camaro 2SSRSM6 1988 Sportside
Join Date: Jan 2011
Location: iN tHE zEN dEN
Posts: 661
No issue.
__________________
MODS: PEDDERS XA COIL OVERS, STAGE 3 CAM, McLEOD CLUTCH, SKIP SHIFT, , HURST SHORT THROW, CAI INTAKE, SCOOP, WASHER RELO KIT, KOOKS HEADERS, KOOKS HI FLOW CATS, CUSTOM TUNE, QTP CUT OUTS, PAINTED STRIPES, PAINTED SS EMBLEMS, PAINTED FIN, PAINTED REAR TAIL LAMP BEZELS, HERITAGE GRILLE, DUCTS, AAC STUFF, BAER ROTORS, HAWK PADS, FUZZY DICE, LASER BEAMS, DISCO BALL, SYBIAN & 3 CHROME VALVE STEM CAPS................
scottyvegas is offline   Reply With Quote
Old 10-13-2011, 08:01 PM   #6
Awesome_SS
Jeff
 
Awesome_SS's Avatar
 
Drives: 2010 Camaro SS/RS
Join Date: Feb 2010
Location: Hayes, Va
Posts: 590
Jeff Morris - I have tried opening a customer relation case about GM not covering a steering wheel angle sensor that has gone bad. The dealer is telling me it went bad because of the modifications to my engine(B.S.). I can't even get the local GM representative to call me back. Bad business practice! I need to make an appeal and move this higher up. Can you help?
__________________

Awesome_SS is offline   Reply With Quote
Old 06-14-2015, 09:58 PM   #7
Redrage2010
 
Drives: 2010 Chevrolet Camaro
Join Date: Jun 2015
Location: Round Rock, Texas
Posts: 1
I am having the same problem with my wife's 2010 camaro. I had the battery checked and it was a bad battery. I changed the battery, and the windows down notice went away, but still having issues with the steering. Did that steering sensor fix your problem? Was the steering sensor something that only the dealer can replace? Cost?
Redrage2010 is offline   Reply With Quote
Old 03-14-2018, 04:32 AM   #8
kville988
Lurking in my SS
 
kville988's Avatar
 
Drives: '14 2SS/RS L99
Join Date: Jul 2014
Location: Louisiana
Posts: 290
was the issue fixed?
kville988 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Add HUD to your 2010 2SSRS@Gen5diy Camaro DIY & HOW-TO instructions & discussions 1980 10-03-2018 03:49 PM
Remote Start System Installation – Need Assistance Railcar Camaro DIY & HOW-TO instructions & discussions 27 12-09-2013 05:51 PM
What do all the abbreviations mean? CrzyGamr2 5th Gen Camaro SS LS LT General Discussions 77 12-07-2012 05:34 AM
Acronyms? KEEP RT Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 20 03-11-2011 09:57 PM
Camaro info from GM dahulk 5th Gen Camaro SS LS LT General Discussions 5 03-01-2011 11:39 AM


All times are GMT -5. The time now is 08:14 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.