Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Caryle Racing
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 11-15-2017, 07:24 PM   #43
Screwblower
 
Drives: 14' 2ss convertible
Join Date: Oct 2017
Location: In my underwear
Posts: 90
You can move the shifter from D or M to Park without fully depressing the shifter lock( button) . This causes the locking mechanism not to work properly. Squeeze it again , you'll hear the release if the radio isn't playing.
Screwblower is offline   Reply With Quote
Old 11-19-2017, 01:04 AM   #44
MjrStfy
 
MjrStfy's Avatar
 
Drives: 2015 Chevy Camaro V6 2LT RS
Join Date: Jul 2015
Location: SoCal
Posts: 92
Quote:
Originally Posted by y2kgt46 View Post
I think I have a fix. I noticed on my 2014 if you squeeze the trigger in the shifter after you put the car in park, you can hear the lock release in the ignition. Going into park it doesn't always make contact. If you put the car in park, and squeeze the trigger once it should solve the key issue. At least it has for me so far, 3 weeks and counting! Hope this helps.
Thanks I tried doing what you said and it does work.
MjrStfy is offline   Reply With Quote
Old 12-12-2017, 01:49 PM   #45
MjrStfy
 
MjrStfy's Avatar
 
Drives: 2015 Chevy Camaro V6 2LT RS
Join Date: Jul 2015
Location: SoCal
Posts: 92
So I took mine in to get the key getting stuck in the ignition they replaced the shifter itís still under warranty.

Guess what Iím still having issues with ?

Yup key still gets stuck !!!

I drove across the street to the shell mini mart to grab a energy drink. Shut the car off and the key doesnít want to come out !!!

Walk back to the dealership and talk to one of the service managers we walk back to the car and he goes straight for the shifter wiggles it around and pulls the key out.

Hell I couldíve done that, but it defeats the purpose of supposably them replacing the shifter in the first place? To me they didnít fix the issue. I shouldnít have to sit there and fool around with the shifter to get the key out?

Thoughts ?

Live with it or ?
MjrStfy is offline   Reply With Quote
Old 12-12-2017, 04:53 PM   #46
JerTM

 
JerTM's Avatar
 
Drives: 2011 2SS/RS M6
Join Date: Oct 2015
Location: Utah
Posts: 1,564
I would ask them to look at it again, clearly it wasn't fixed correctly. You may have to pay for the part but I wouldn't pay for any labor.
__________________
Quote:
Originally Posted by Zezima View Post
(exaggerated example) omg they said my car is slow cause its a v6 isn't this surreal

followed by empathetic but also some genuine comments but mostly nut sucking the v6 owner
JerTM is offline   Reply With Quote
Old 01-05-2018, 07:46 AM   #47
Spurshot
 
Drives: 2014 2SS blue
Join Date: Jun 2016
Location: Socal
Posts: 557
So, what's the problem? Is it the micro switch on the shifter? Or the solenoid on the column? Mine seems to be related to the shifter and I would guess the micro switch is either out of adjustment or the switch itself is going bad.

The solenoid p/n 22891588 ($18) seems to be common to about every GM vehicle made since the column lock has been around. Weak/bad solenoid? The complete shifter assembly is $122 online, but that seems like overkill if the microswitch is bad or out of adjustment.
__________________

Last edited by Spurshot; 01-05-2018 at 08:07 AM.
Spurshot is offline   Reply With Quote
Old 01-09-2018, 01:42 PM   #48
MjrStfy
 
MjrStfy's Avatar
 
Drives: 2015 Chevy Camaro V6 2LT RS
Join Date: Jul 2015
Location: SoCal
Posts: 92
In the past couple of weeks I haven’t had any problems with the key getting stuck. But it has happened like 2 or 3 times since getting the shifter change, out of a whim I started using my spare key and haven’t had a issue with it getting stuck ?

Had one time it did get stuck started to make a video on my phone I didn’t do anything but start to record and narrate saying the keys stuck in the ignition again try the key and it’s no longer stuck.
MjrStfy is offline   Reply With Quote
Old 01-22-2018, 11:30 AM   #49
Dante2673
 
Drives: 2014 Camaro 2LS
Join Date: Dec 2013
Location: Fort Worth, Texas
Posts: 9
Thanks!

Quote:
Originally Posted by marshagem7 View Post
I started having the same problem with my 2014 Camaro. It was driving me crazy. Dealership said I was over my warranty period, I drive a lot!!!! So I was going to have to pay for it out of my pocket. So I did some research, and took the covers off my steering column. There is a pin that moves back and forth that is connected to a little arm on the lock cylinder that locks the key in when you push the button on the gear shifter. I just simply pulled the pin out of the little arm and it works perfect now. Just like it never happened. This takes about 5 minutes to do. only tools needed are a 8mm socket, ratchet with extension to take off the cover, and a flat head screw driver to pull the pin out.
If you pull the steering column covers off, put the key in the ignition and start the car, then push the button on the shifter you will see exactly what im talking about.
Just though I would share my experience with you all.
Thank you so much for your advice! I tried this and it fixed the problem, however I found that afterward, my car would let me take the key out of the ignition even if I had not shifted to park and that would allow my car to roll after I let out on the brake.

Instead of taking that risk, I used some graphite powder to lubricate the little solenoid that moves the pin you referenced so hopefully it won't get stuck again. So far, so good. If it does happen again, I'll probably go ahead and remove the pin. Thanks!
Dante2673 is offline   Reply With Quote
Old 01-27-2018, 02:27 PM   #50
DeanH
 
DeanH's Avatar
 
Drives: 2014 2LT/RS
Join Date: Jul 2015
Location: Hot Springs, AR
Posts: 59
Key stuck in ignition

Had the same issue in mine, although it was not consistent. Sometimes it would come out, sometimes it would not. Had to bump the shifter forward just a touch which usually worked, but not always. Finally took it in to the dealership and lo and behold, I pull it in to the service bay and guess what? The key is stuck in the ignition. Guess it was just my lucky day. Shifter replaced.. Problem solved.
All under warranty.
__________________
My mods so far: Removed front license plate bracket. Reflective Concepts White bowtie overlay.
DeanH is offline   Reply With Quote
Old 02-13-2018, 04:49 PM   #51
Dante2673
 
Drives: 2014 Camaro 2LS
Join Date: Dec 2013
Location: Fort Worth, Texas
Posts: 9
The dealership said it was the shifter (without looking at the car; they said it was common), but I removed the steering column cover and can confirm that the solenoid is not working consistently. Thanks, Spurshot, for the part info.
Dante2673 is offline   Reply With Quote
Old 04-18-2018, 11:50 PM   #52
havelegs
 
havelegs's Avatar
 
Drives: 2015 1SS RS L99
Join Date: Oct 2015
Location: Austin Texas
Posts: 640
Quote:
Originally Posted by Dante2673 View Post
The dealership said it was the shifter (without looking at the car; they said it was common), but I removed the steering column cover and can confirm that the solenoid is not working consistently. Thanks, Spurshot, for the part info.
shifter only or the entire shifter assembly?
havelegs is offline   Reply With Quote
Old 05-05-2018, 09:57 PM   #53
Mistyk616
 
Drives: 2011 Chevy Camaro SS
Join Date: Oct 2017
Location: Missouri
Posts: 1
I am having this issue now. The first couple times I could mess with it and get the key out within a minute or so. The last two times it's been 20-30 minutes. I've tried moving the steering wheel, pressing the shift button, putting it in neutral and moving the car... none of these were a sure fix. After reading all the comments I'm even more confused. I understand what the problem is but have no idea how to fix it.
Mistyk616 is offline   Reply With Quote
Old 05-06-2018, 01:48 AM   #54
havelegs
 
havelegs's Avatar
 
Drives: 2015 1SS RS L99
Join Date: Oct 2015
Location: Austin Texas
Posts: 640
Quote:
Originally Posted by Mistyk616 View Post
I am having this issue now. The first couple times I could mess with it and get the key out within a minute or so. The last two times it's been 20-30 minutes. I've tried moving the steering wheel, pressing the shift button, putting it in neutral and moving the car... none of these were a sure fix. After reading all the comments I'm even more confused. I understand what the problem is but have no idea how to fix it.
Mine works when the shiter button is pressed a few times. I hear a sound from the column when the release engages. You could block off the plunger near the key cylinder. I think someone posted how to do it here.
havelegs is offline   Reply With Quote
Old 05-19-2018, 10:19 PM   #55
aldaran
 
aldaran's Avatar
 
Drives: 2016 Camaro 2SS/RS
Join Date: Oct 2008
Location: Alice, Texas
Posts: 557
My cousins 2015 started having this problem. Bad part is her warranty just ran out in April. Going to try the shifter button if that doesn't work will disconnect the solenoid in the column. She wouldn't pull the key out while driving anyway.
__________________
2016 2SS: Silver Ice, A8 Auto, Adrenaline Red, Black Rally Stripes, and Black bowties.
My Journey.....
1100 Status - 08/17/2015 : 2000 Status - 09/28/2015
2500 Status - 09/29/2015 : 3000 Status - 09/29/2015
3000 Status - 10/19/2015 TPW 11/9
3800 Status - 11/04/2015 Seq: 122808
4300 Status - 12/17/2015 (Charlotte, MI)
4200 Status - 01/08/2016
4800 Status - 01/14/2016
5000 Status - 01/19/2016
6000 Status - 01/20/2016
aldaran is offline   Reply With Quote
Old 05-20-2018, 01:13 PM   #56
KenKat
 
KenKat's Avatar
 
Drives: 2014 2LT RS Summit White
Join Date: Apr 2017
Location: Cincinnati
Posts: 183
I am having this problem with my 2014. Luckily it is still under the CPO warranty; I am taking it in next Tuesday - the service manager said he’s done a couple of these (fix is to replace the shifter) so hopefully it gets fixed.
KenKat is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:37 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.