Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
dave@hennessey
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 09-23-2021, 03:28 PM   #1
KenBaker
 
Drives: 2010 Camaro SS
Join Date: Jan 2019
Location: Saint Charles MO
Posts: 75
Please help me identify this connector

I had my car throwing a code for the oxygen sensor. I trace the wires up and near the transmission dipstick there is a connector that has some melted wires. I am enclosing a picture. Itís not the first thing that the oxygen sensor plugged into. Iím just trying to find a part number or some reference number. Thank you
Attached Images
 
KenBaker is offline   Reply With Quote
Old 09-23-2021, 06:53 PM   #2
HyperV117
 
HyperV117's Avatar
 
Drives: 2010 Camaro 1SS
Join Date: Nov 2015
Location: CA
Posts: 308
There's front and rear sensors on both sides. Is it possible you have extenders in there? You usually only need extenders if you have Long Tubes

https://www.americanmuscle.com/kooks...E&gclsrc=aw.ds
__________________
HyperV117 is offline   Reply With Quote
Old 09-23-2021, 07:00 PM   #3
G8One2
 
Drives: 2014 Camaro 2SS
Join Date: Feb 2015
Location: Metro Detroit
Posts: 493
Thats an o2 sensor connector. The downstream sensor connectors are not that shape, and the pigtails come out of the harness down by the sides of the transmission.
G8One2 is offline   Reply With Quote
Old 09-25-2021, 02:08 AM   #4
AlanRubin
 
Drives: 2010 LS
Join Date: Feb 2021
Location: Pgh
Posts: 393
Yep, that is an upstream sensor plug. What is the CODE you're getting?
AlanRubin is offline   Reply With Quote
Old 09-26-2021, 12:13 PM   #5
KenBaker
 
Drives: 2010 Camaro SS
Join Date: Jan 2019
Location: Saint Charles MO
Posts: 75
You guys are awesome. It is the connector that plugs into the 02 Extension Harness. I just purchased a pair so I have everything that I need. I am enclosing a picture of the carnage. Thank you all for the help
Attached Images
 
KenBaker is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:57 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.