Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vararam
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing


Reply
 
Thread Tools
Old 06-14-2024, 11:03 AM   #1
kevint
 
Drives: 2013 1SS
Join Date: Dec 2012
Location: New Jersey
Posts: 722
Changed the original spark plugs and wires at 183k miles

2013 L99, ordered late-2012 and picked up January 2013 with 13 miles. Dynatech headers and Jannetty tune at ~40k miles and a Roto-fab intake at some point later on. Oil changes at 10 - 20% remaining oil life. 93/94 octane all the way. This is my daily driver: it still idled smooth and pulled hard--I wouldn't have changed them if I didn't feel a slight stumble at WOT. I think the plugs look fantastic given their age. I replaced the plugs with AC Delco 41-162s. I replaced the stock wires with AC Delco 9748UUs, even though the originals came off intact. I put the heat shields back on also.
Attached Images
 

Last edited by kevint; 06-14-2024 at 12:47 PM.
kevint is offline   Reply With Quote
Old 06-14-2024, 11:07 AM   #2
0stones0
It don’t come easy.
 
0stones0's Avatar
 
Drives: 2010 2SS RS M6
Join Date: May 2014
Location: WI
Posts: 2,272
Looks like a nice even color betwixt the plugs.
__________________
0stones0 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:50 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2024, vBulletin Solutions, Inc.