Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Phastek Performance
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Cosmetics and Lighting Modification Discussions


Reply
 
Thread Tools
Old 09-21-2009, 03:33 PM   #1
Adam
You Said Member
 
Drives: 2010 SIM 2LT Auto RS
Join Date: Feb 2009
Location: Why is this required?
Posts: 326
So I let a dealership put on my splash guards.

And they didn't remove the GM emblem, instead they put the guards over the top of them (covers 1/3 the emblem), bending the guards a little out of shape and on the passenger side there's now a visible (when close) gap between the guard and the body.

I honestly never expected them to do that. I expected either:

a. remove emblem
b. remove emblem and stick it back on
c. not remove emblem because it's not in the way (after reading here).

It's literally worst case scenario, so I'm pretty dissapointed. I've removed the gm emblems myself, tried to push the guards back into shape, and hopefully it will be alright. I thought maybe I should tell them to remove the emblems, but I thought it would be obvious ffs, it doesn't exactly fit on top of them.
Adam is offline   Reply With Quote
Old 09-21-2009, 03:51 PM   #2
Abygale


 
Abygale's Avatar
 
Drives: .
Join Date: Jul 2009
Location: .
Posts: 2,523
Wow, I'm surprised your front guards went on that far back. Mine come close to the GM emblems but not to them. That is strange. Do you have pictures?

Here is a not so good picture of one side of my car showing the front guard in relation to the GM emblem:

Abygale is offline   Reply With Quote
Old 09-21-2009, 03:53 PM   #3
Adam
You Said Member
 
Drives: 2010 SIM 2LT Auto RS
Join Date: Feb 2009
Location: Why is this required?
Posts: 326
I believe that the emblem was placed further back later in production. I got one of the v6s that went to dealerships, and it's emblems were much closer to the tire well.
Adam is offline   Reply With Quote
Old 09-21-2009, 03:56 PM   #4
rickerda
 
rickerda's Avatar
 
Drives: 2010 Camaro 2LT RS
Join Date: May 2009
Location: Chester VA
Posts: 513
The early Camaros have the GM logo closer to the wheel well, the guards don't fit without removing/moving the logo.
rickerda is offline   Reply With Quote
Old 09-21-2009, 04:00 PM   #5
Abygale


 
Abygale's Avatar
 
Drives: .
Join Date: Jul 2009
Location: .
Posts: 2,523
Quote:
Originally Posted by Adam View Post
I believe that the emblem was placed further back later in production. I got one of the v6s that went to dealerships, and it's emblems were much closer to the tire well.
Adam that sucks. I'd make the dealer order you a new set and install them for you free of charge. That just sounds like they did a very poor installation job.
Abygale is offline   Reply With Quote
Old 09-21-2009, 04:18 PM   #6
Tecca
.
 
Tecca's Avatar
 
Drives: ...
Join Date: Apr 2009
Location: Colorado
Posts: 1,380
Quote:
Originally Posted by Abygale View Post
Adam that sucks. I'd make the dealer order you a new set and install them for you free of charge. That just sounds like they did a very poor installation job.
Tecca is offline   Reply With Quote
Old 09-21-2009, 04:22 PM   #7
CamaroSkooter
Retarded One-Legged Owl
 
CamaroSkooter's Avatar
 
Drives: 2010 Black Camaro 2SS
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 9,662
I would leave it as is and tell people, "My dealer is an idiot!"
CamaroSkooter is offline   Reply With Quote
Old 09-21-2009, 05:30 PM   #8
THUMPER20X
GM fix my PAINT U suck!
 
THUMPER20X's Avatar
 
Drives: 2010 Black 1SS/RS 6Spd
Join Date: Sep 2009
Location: Great Red North
Posts: 1,856
The GM badge is lame IMO. Mine hit the trash the day after I bought the car lol.
__________________
THUMPER20X is offline   Reply With Quote
Old 09-21-2009, 05:54 PM   #9
SS22
 
SS22's Avatar
 
Drives: 2010 Blue Camaro RS
Join Date: Jul 2008
Location: Alaska
Posts: 462
Wow, Unbelievable.
SS22 is offline   Reply With Quote
Old 09-21-2009, 06:06 PM   #10
franknbeans
Whipped
 
franknbeans's Avatar
 
Drives: 2010 CAMARO
Join Date: Sep 2008
Location: Pittsburgh-ish - PA
Posts: 4,221
i would raise hell.
__________________
franknbeans is offline   Reply With Quote
Old 09-21-2009, 06:13 PM   #11
Ject
aka Patrick
 
Ject's Avatar
 
Drives: '10 Camaro 2SS '04 Silverado
Join Date: Jan 2009
Location: Derby Kansas
Posts: 3,072
Send a message via Yahoo to Ject
__________________
Current Modifications: Your average Bolt-ons & Suspension Upgrades
GForce Engineering: 9" Rear End, Strange Pro Iron Case w/Moser Nodular 3.70:1 Detroit locker, 3.5" Solid Drive Shaft
Ject is offline   Reply With Quote
Old 09-21-2009, 07:34 PM   #12
OUR72GTO
2010 SIM Beige RS 6M
 
OUR72GTO's Avatar
 
Drives: SIM RS 6M 66 Corvair Silverado LTZ
Join Date: Oct 2008
Location: Kamloops,British Columbia
Posts: 4,637
And they wonder why we go else where even for an oil change.

So can someone measure the distance of one that DID NOT need to move so I know which one I have ?

Thanks
__________________
CAMARO.. 2010 The Heart Beat is back in CHEVROLET
Now let's put it back in America
OUR72GTO is offline   Reply With Quote
Old 09-21-2009, 09:12 PM   #13
tjd24
Thank you Oshawa/St.Cats!
 
tjd24's Avatar
 
Drives: 2010 2LT RS 2G1FC1EV4A9103434
Join Date: May 2009
Location: NW NJ
Posts: 3,445
Sorry to hear it. I removed my GM "chicklets" before the splash guards went on my SIM - my Dealer did a good job with the install.

Don't settle - make sure you get satisfaction.
__________________
http://www.hubgarage.com/mygarage/tjd24 http://ny5thgen.com/TJD_RS.htm
#3434 Born 4-15-2009, Delivered 5-22-2009 BBOMG 2/3/4 & booked for #5
tjd24 is offline   Reply With Quote
Old 09-21-2009, 10:13 PM   #14
97one

 
97one's Avatar
 
Drives: 2016 & 1967 Camaro, 2015 Impala, +1
Join Date: Jul 2009
Location: New York
Posts: 1,165
Quote:
Originally Posted by Adam View Post
And they didn't remove the GM emblem, instead they put the guards over the top of them (covers 1/3 the emblem), bending the guards a little out of shape and on the passenger side there's now a visible (when close) gap between the guard and the body.

I honestly never expected them to do that. I expected either:

a. remove emblem
b. remove emblem and stick it back on
c. not remove emblem because it's not in the way (after reading here).

It's literally worst case scenario, so I'm pretty dissapointed. I've removed the gm emblems myself, tried to push the guards back into shape, and hopefully it will be alright. I thought maybe I should tell them to remove the emblems, but I thought it would be obvious ffs, it doesn't exactly fit on top of them.
I am NOT SHOCKED AT ALL..............

Yes you knew what to do. But the dealer did not give a SH-t !
I never go back to any dealer after I buy the car......... I learned that many many years ago.
THEY just don't care about your car....
NOBODY cares about your car like you do............

97one is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SPLASH GUARD QUESTION HELP! thebighar 5th Gen Camaro SS LS LT General Discussions 49 12-31-2009 09:54 AM
splash guards (not GM) philthy Cosmetics and Lighting Modification Discussions 0 07-24-2009 02:27 PM
Jackpot !!!! 32 Camaros in PA at dealership !!!!! scomaro22 Camaro Photos | Spyshots | Video | Media Gallery 50 05-04-2009 11:05 AM
body molded mud guards vs rear defuser mrpre10der 5th Gen Camaro SS LS LT General Discussions 9 04-10-2009 09:29 PM


All times are GMT -5. The time now is 01:45 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.